Ubuntu

ora2pg package is not installable

Reported by Angel Aguilera on 2009-01-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ora2pg (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ora2pg

ora2pg is not installable in Ubuntu 8.10:

-----------------------------------
angel@zafiro:~$ sudo aptitude install ora2pg
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  ora2pg
The following NEW packages will be installed:
  libcompress-raw-zlib-perl{a} libcompress-zlib-perl{a} libdbi-perl{a} libio-compress-base-perl{a} libio-compress-zlib-perl{a} libnet-daemon-perl{a} libplrpc-perl{a}
  libstring-random-perl{a}
0 packages upgraded, 9 newly installed, 0 to remove and 0 not upgraded.
Need to get 346kB/1216kB of archives. After unpacking 3916kB will be used.
The following packages have unmet dependencies:
  ora2pg: Depends: libdbd-oracle-perl which is a virtual package.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
ora2pg [Not Installed]

Score is -9879

Accept this solution? [Y/n/q/?]
------------------------------

Of course, the solution proposed by aptitude (keep ora2pg uninstalled) is not very useful... ;-)

Package version:
------------------------------
angel@zafiro:~$ LANG=C apt-cache policy ora2pg
ora2pg:
  Installed: (none)
  Candidate: 4.7-1
  Version table:
     4.7-1 0
        500 http://fr.archive.ubuntu.com intrepid/multiverse Packages
-------------------------------

Thank you for taking time tor eport this bug. The problem is that the "libdbd-oracl-perl" package is only available as source in Ubuntu wheras debian has also binary packages:
$ rmadison -u debian libdbd-oracle-perl
libdbd-oracle-perl | 1.21-2 | testing/contrib | source, amd64, i386
libdbd-oracle-perl | 1.21-2 | unstable/contrib | source, amd64, i386
$ rmadison libdbd-oracle-perl
libdbd-oracle-perl | 1.21-2 | intrepid/multiverse | source
libdbd-oracle-perl | 1.21-2 | jaunty/multiverse | source

Can you try to build the package on your own?

Changed in ora2pg:
status: New → Confirmed

hm...forget to build it...the depencies of pibdbd-oracle-perl (oracle-instantclient-basic and oracle-instantclient-devel) are not even available in debian...weird.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers