[feisty] oprofile does not sample samples

Bug #82862 reported by Mattias Wadenstein on 2007-02-02
4
Affects Status Importance Assigned to Milestone
oprofile (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: oprofile

At startup, I get this:

root@mupp:/var/lib/oprofile# opcontrol --start
Using default event: CPU_CLK_UNHALTED:100000:0:1:1
/usr/bin/opcontrol: 1: cannot create /dev/oprofile/0/enabled: Directory nonexistent
/usr/bin/opcontrol: 1: cannot create /dev/oprofile/0/event: Directory nonexistent
/usr/bin/opcontrol: 1: cannot create /dev/oprofile/0/count: Directory nonexistent
/usr/bin/opcontrol: 1: cannot create /dev/oprofile/0/kernel: Directory nonexistent
/usr/bin/opcontrol: 1: cannot create /dev/oprofile/0/user: Directory nonexistent
/usr/bin/opcontrol: 1: cannot create /dev/oprofile/0/unit_mask: Directory nonexistent
Using 2.6+ OProfile kernel interface.
Reading module info.
Daemon started.
Using log file /var/lib/oprofile/oprofiled.log
Profiler running.

And then I can not find any profile data, the samples dir is empty and opreport
just claims it cannot find any samples/data.

Gustavo Carneiro (gjc) wrote :

I have the same problem on my ubuntu feisty amd64 installation, running on a AMD64 3000+; however, just yesterday I tried oprofile on a ubuntu x86 installation running on a core 2 duo and it worked perfectly there. Therefore I get a feeling this might be a 64-bit issue, although I'm not sure.

Gustavo Carneiro (gjc) wrote :

Sorry, some information I forgot:

gjc@spectrum:~$ uname -a
Linux spectrum 2.6.20-9-generic #2 SMP Sun Feb 25 22:59:06 UTC 2007 x86_64 GNU/Linux

oprofile 0.9.2-3

gjc@spectrum:~$ 'ls' -F /dev/oprofile/
1/ backtrace_depth buffer_watershed dump stats/
2/ buffer cpu_buffer_size enable
3/ buffer_size cpu_type pointer_size

Gustavo Carneiro (gjc) wrote :

Appears to be fixed on 2.6.20-12-generic.

Mattias Wadenstein (maswan) wrote :

Yes, this seems to be fixed in 2.6.20-12-server for me too on amd64. Suggest we close the bug then as fixed.

Gustavo Carneiro (gjc) on 2007-03-20
Changed in oprofile:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers