libkrb53 package required instead of libkrb5-3 in Karmic

Bug #462059 reported by Miguel on 2009-10-27
100
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Grip
Invalid
Undecided
OlivierWeb
openwsman (Ubuntu)
Medium
Unassigned
Karmic
Undecided
Unassigned
root-system (Ubuntu)
Medium
Unassigned
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: root-plugin-krb5

The package libkrb53 has been replaced with libkrb5-3 in Karmic, but the dependencies of root packages which depence upon this library aren't updated, so we have broken dependencies.

I think that the same happens to another plugins in root.

http://packages.ubuntu.com/karmic/libkrb5-3

Miguel (miguel-glug) wrote :

As I see now, even libroot5.18 is affected for this updated dependency.

Krešo Kunjas (deresh) wrote :

becouse of this change zend server doesn't install. shouldnt we provide a transitional package until this is resolved.

Frank Siegert (fsiegert) wrote :

I don't know how I add an "Also affects package", I can only see project and distribution. The same problem appears for libopenwsman1 (Depends on libkrb53) and seamonkey-browser (Suggests libkrb53), should these be filed as separate bugs?

Stefan Kluth (skluth) wrote :

I also noticed that I can't install root-system on karmic :(. A transitional package libkrb53 would have helped ... btw cernlib /paw installs fine if that is of any help to you!

Alessandro Sivieri (scattino) wrote :

Confirmed here too: the dependency name in libroot should really be corrected.

Evan Broder (broder) wrote :

The transition wasn't actually libkrb53 -> libkrb5-3. The old libkrb53 package was split up into several other packages (libkrb5-3 for libkrb5 itself, but also libgssapi-krb5-2, libk5crypto3, and libkrb5support0).

As a temporary fix, you can use equivs to generate a fake transitional libkrb53 package. Run equivs on a file with these contents:

  Package: libkrb53
  Version: 1.6.dfsg.2+fake1
  Depends: libkrb5-3, libgssapi-krb5-2, libk5crypto3, libkrb5support0

then install the resulting .deb.

In the longer term, the libkrb53 dependency in the affected packages was automatically generated at build-time based on what libraries the binaries in the packages linked against. To fix the bug, it should be sufficient to just rebuild the packages with no changes.

The libkrb53 package was intentionally removed fairly early in the Karmic development process, and there was a fairly lengthy process to make sure all the affected packages were rebuilt; I'm not sure why this one got overlooked.

In any case, here's a patch that will trigger that rebuild. I've uploaded a test build to my PPA (https://launchpad.net/~broder/+archive/ubuntu-tests), but it's pretty backed up right now so it might take a while to finish.

Evan Broder (broder) wrote :

Whoops! This is the right version of the patch (not that it's doing anything exciting).

Evan Broder (broder) wrote :

The openwsman package was also not updated.

However, it looks like neither of these packages were fixed for the libkrb53 transition because both of them fail to build under recent toolchains:

https://launchpad.net/~broder/+archive/ubuntu-tests/+build/1314245/+files/buildlog_ubuntu-karmic-lpia.root-system_5.18.00-2.3ubuntu2.1~broder1_FAILEDTOBUILD.txt.gz

https://launchpad.net/~broder/+archive/ubuntu-tests/+build/1314261/+files/buildlog_ubuntu-karmic-lpia.openwsman_2.0.0b1-0ubuntu2.1~broder1_FAILEDTOBUILD.txt.gz

I don't have the necessary background with either of these packages to fix those failures to build.

Changed in root-system (Ubuntu):
status: New → In Progress
assignee: nobody → Ilya Barygin (randomaction)
James Johnson (jamesj2) wrote :

It seems libpq4 package is affected by this same issue also in karmic:

#sudo aptitude install libpq4
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  libpq4
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 297kB of archives. After unpacking 799kB will be used.
The following packages have unmet dependencies:
  libpq4: Depends: libkrb53 (>= 1.4.2) which is a virtual package.
Unable to resolve dependencies! Giving up...
The following packages are BROKEN:
  libpq4
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 297kB of archives. After unpacking 799kB will be used.
aptitude failed to find a solution to these dependencies. You can solve them yourself by hand or type 'n' to quit.
The following packages have unmet dependencies:
  libpq4: Depends: libkrb53 (>= 1.4.2) which is a virtual package.
Resolve these dependencies by hand? [N/+/-/_/:/?] ?

James Johnson (jamesj2) wrote :

My bad libpq4 is pulling from http://repos.zend.com/deb/ce/pool/non-free/p/postgresql-8.1/. Guess they need to update their packages.

Ilya Barygin (randomaction) wrote :

root-system is an evil package, it fails to build in a number of ways, and a rebuild attempt takes about an hour. I fixed several issues, but there is still a linker error:

g++ -m32 -O2 -o bin/hadd main/src/hadd.o \
     -Llib -lCore -lCint -lRIO -lNet -lHist -lGraf -lGraf3d -lGpad -lTree -lMatrix -lm -ldl -pthread -rdynamic
lib/libRIO.so: undefined reference to `int TStreamerInfo::ReadBuffer<char**>(TBuffer&, char** const&, int, int, int, int)'
collect2: ld returned 1 exit status
make[1]: *** [bin/hadd] Error 1

I'm attaching my modifications and the build log.

Ilya Barygin (randomaction) wrote :
Changed in root-system (Ubuntu):
status: In Progress → New
assignee: Ilya Barygin (randomaction) → nobody
Changed in root-system (Ubuntu):
status: New → Confirmed

Any workaround would be more than welcomed... I am really stuck right now.

I was able to compile this version : http://root.cern.ch/drupal/content/production-version-524 from source

what I did in the root/ directory :

 ./configure --enable-roofit --disable-xrootd --build=debug --disable-krb5
make clean
make
source bin/thisroot.csh

That should be a good workaround for now I think.

Miguel (miguel-glug) wrote :

It could be a good solution by now, far better that an package which can be installed.

Miguel (miguel-glug) wrote :

Sorry, What I really mean was "which can't be installed".

Miguel (miguel-glug) wrote :

While all these dependencies aren't solved, I think the better solution could be bring back the libkrb5-3 package to the Ubuntu repositories and let people use the software in the meantime.

Jorge Suárez de Lis (ys) wrote :

I agree with Miguel. It seems this bug will stay for some time, and there's some people waiting to this bug to be solved. If libkrb53 (i think you mean this one, not libkrb5-3) comes back, the problem is still there for us, but not for them.

Ilya Barygin (randomaction) wrote :

SRU justification

Most binary packages of root-system are not installable due to a missing dependency.
A rebuild fixes this problem. However, many adjustments are necessary to make the source package build.

TEST CASE:
$ LANG=C sudo apt-get install libroot5.18
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libroot5.18: Depends: libkrb53 (>= 1.6.dfsg.2) but it is not installable
E: Broken packages

Ilya Barygin (randomaction) wrote :

Same debdiff, lucid version. It fixes FTBFS in lucid.

Ilya Barygin (randomaction) wrote :

Subscribed motu-sru and u-u-s (requesting upload to lucid now, to karmic-proposed after SRU ack).

John Dong (jdong) wrote :

ACK from motu-sru for Karmic.

Michaël Perrin (sweedymick) wrote :

I'm not sure it helps, but this problem affects the installation of Zend Server 4.0.3 and Zend Server 5.0 beta as well from their dedicated repository, because of the dependency on libpq4 depending on librkb53.

Changed in root-system (Ubuntu):
assignee: nobody → fabrice_sp (fabricesp)
importance: Undecided → Medium
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package root-system - 5.18.00-2.3ubuntu3

---------------
root-system (5.18.00-2.3ubuntu3) lucid; urgency=low

  [ Evan Broder ]
  * Rebuild to pick up new krb5 library dependencies (LP: #462059).

  [ Ilya Barygin ]
  * Fix build issues:
    - cint/src/Type.cxx: fix typos in #elif directives. Patch from BTS
      #505015, thanks to Martin Michlmayr.
    - krb5auth/src/Krb5Auth.cxx: valid_cksumtype() renamed to
      krb5_c_valid_cksumtype(). Patch from BTS #529998, thanks to Jurij
      Smakov.
    - xrootd/src/xrootd/src/XrdNet/XrdNetDNS.cc:
      xrootd/src/xrootd/src/XrdXrootd/XrdXrootdPrepare.cc:
      add explicit casts to char* to fix invalid conversions. Backported
      from upstream 2.24.00.
    - xrootd/src/xrootd/src/XrdClient/XrdClientConn.hh: add missing
      header.
    - io/Module.mk: compile with -O as a workaround for gcc bug 40056.
 -- Ilya Barygin <email address hidden> Sun, 08 Nov 2009 16:40:57 +0300

Changed in root-system (Ubuntu):
status: In Progress → Fix Released
Fabrice Coutadeur (fabricesp) wrote :

uploaded to Lucid. thansk for your contribution!

Can you please also forward the changes to Debian? Actual version in Unstable still FTBFS.
thanks,
Fabrice

Changed in root-system (Ubuntu):
assignee: fabrice_sp (fabricesp) → nobody
status: Fix Released → Fix Committed
Changed in root-system (Ubuntu):
status: Fix Committed → Fix Released
Fabrice Coutadeur (fabricesp) wrote :

Fixed by fixing bug #427217

Changed in openwsman (Ubuntu Karmic):
status: New → Fix Released
Changed in openwsman (Ubuntu):
importance: Undecided → Medium
status: New → Fix Released

Accepted root-system into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in root-system (Ubuntu Karmic):
status: New → Fix Committed
tags: added: verification-needed
StepLg (steplg) wrote :

it seems that's all ok in proposed package (at least for amd64 platform, libroot-dev package). thanks a lot

Martin Pitt (pitti) on 2009-11-13
tags: added: verification-donee
removed: verification-needed
tags: added: verification-done
removed: verification-donee

I enabled karmic-proposed, then installed root-system-bin, and the dependencies were handled correctly. So it's fine on i386 as well.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package root-system - 5.18.00-2.3ubuntu2.1

---------------
root-system (5.18.00-2.3ubuntu2.1) karmic-proposed; urgency=low

  [ Evan Broder ]
  * Rebuild to pick up new krb5 library dependencies (LP: #462059).

  [ Ilya Barygin ]
  * Fix build issues:
    - cint/src/Type.cxx: fix typos in #elif directives. Patch from BTS
      #505015, thanks to Martin Michlmayr.
    - krb5auth/src/Krb5Auth.cxx: valid_cksumtype() renamed to
      krb5_c_valid_cksumtype(). Patch from BTS #529998, thanks to Jurij
      Smakov.
    - xrootd/src/xrootd/src/XrdNet/XrdNetDNS.cc:
      xrootd/src/xrootd/src/XrdXrootd/XrdXrootdPrepare.cc:
      add explicit casts to char* to fix invalid conversions. Backported
      from upstream 2.24.00.
    - xrootd/src/xrootd/src/XrdClient/XrdClientConn.hh: add missing
      header.
    - io/Module.mk: compile with -O as a workaround for gcc bug 40056.
 -- Ilya Barygin <email address hidden> Sun, 08 Nov 2009 16:40:57 +0300

Changed in root-system (Ubuntu Karmic):
status: Fix Committed → Fix Released
David Robert Lewis (afrodeity) wrote :

Got no idea how to go about getting the transition package. Omvviewer depends upon libcurl3-cares which depends upon libkrb53. Surely I should be able to apt-get libkrb53?

Steve Langasek (vorlon) wrote :

> Omvviewer depends upon libcurl3-cares which depends upon libkrb53.

Neither of these packages is in Ubuntu.

> Surely I should be able to apt-get libkrb53?

No, this package was dropped as obsolete in Ubuntu 9.10, and any package still depending on it is buggy. This is a bug report about fixing those few packages that still depended on it at release time.

David Robert Lewis (afrodeity) wrote :

Then how do I install omvviewer? Second LIfe depends upon it.

Steve Langasek (vorlon) wrote :

You should talk to whoever is providing this omvviewer package, since this is not an Ubuntu package.

Oedipe (oedipe) wrote :

Just a mess ! Leaving the Linux-Ubuntu shit... Returning to Microsoft. I've lost to much money with that "free" dream !

Jon Burgin (jon-burgin) wrote :

Also libpq5 has this issue.

Fitch (brafferton) wrote :

libpq5 seems to be quite important (mark for removal and see what else would have to be removed) and there are actually a few issues with docvert and upgrades crashing
https://bugs.launchpad.net/bugs/450569. Wouldn't happen to be related would they?
Bottom line is libkrb53 (>=1.6.dfsg.2) MUST be made available again.
I'm starting to agree with Oedipe

Sven Bendel (ubuntudroid) wrote :

I have the same problem with libpq5 - and I need this for a whole bunch of programs...

Ilya Barygin (randomaction) wrote :

Jon, Fitch, Sven,

This is fixed in libpq5 version 8.4.2-0ubuntu9.10, which is available from karmic-security and karmic-updates. Please update your systems.

$ apt-cache depends libpq5
libpq5
  Depends: libc6
  Depends: libcomerr2
  Depends: libgssapi-krb5-2
  Depends: libkrb5-3
  Depends: libldap-2.4-2
  Depends: libssl0.9.8

$ apt-cache policy libpq5
libpq5:
  Installed: 8.4.2-0ubuntu9.10
  Candidate: 8.4.2-0ubuntu9.10
  Version table:
 *** 8.4.2-0ubuntu9.10 0
        500 http://archive.ubuntu.com karmic-security/main Packages
        500 http://archive.ubuntu.com karmic-updates/main Packages
        100 /var/lib/dpkg/status
     8.4.1-1 0
        500 http://archive.ubuntu.com karmic/main Packages

Sven Bendel (ubuntudroid) wrote :

Hm, that's strange: Synaptic tells me the same info you posted (apart from another available jaunty-backports update to version 8.4.2-1~jaunty1, but that's another story I think), while "apt-cache depends libpq5" states, that the package still depends on the (not available) libkrb53 - I'm wondering where this inconsistency comes from...

Steve Langasek (vorlon) wrote :

The libpq5 package that was shipped in karmic, libpq5 8.4.1-1, also does not depend on libkrb53.

Frans Gifford (fgiff) wrote :

Also affects grip, have notified the package maintainer.

Frans Gifford (fgiff) wrote :

Reply from daniel@debian indicates that he's not the correct maintainer for Grip, it seems this is olivierweb

Changed in grip:
assignee: nobody → OlivierWeb (olivierweb)
Frans Gifford (fgiff) wrote :

Grip is no longer packaged, so expiring this as invalid.

Changed in grip:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.