[SRU] ovs 2.9.2

Bug #1780752 reported by James Page on 2018-07-09
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Medium
Unassigned
Queens
Medium
Unassigned
Rocky
Medium
Unassigned
openvswitch (Ubuntu)
Medium
Unassigned
Bionic
Medium
Unassigned
Cosmic
Medium
Unassigned

Bug Description

[Impact]
This release sports mostly bug-fixes and we would like to make sure all of our supported customers have access to these improvements.

The update contains the following package updates:

   * openvswitch 2.9.2

[Test Case]
The following SRU process was followed:

https://wiki.ubuntu.com/OpenStackUpdates

In order to avoid regression of existing consumers, the OpenStack team will
run their continuous integration test against the packages that are in
-proposed. A successful run of all available tests will be required before the
proposed packages can be let into -updates.

The OpenStack team will be in charge of attaching the output summary of the
executed tests. The OpenStack team members will not mark ‘verification-done’ until
this has happened.

[Regression Potential]
In order to mitigate the regression potential, the results of the
aforementioned tests are attached to this bug.

James Page (james-page) on 2018-07-09
Changed in openvswitch (Ubuntu Bionic):
status: New → Triaged
Changed in openvswitch (Ubuntu Cosmic):
status: New → Triaged
Changed in openvswitch (Ubuntu Bionic):
importance: Undecided → Medium
Changed in openvswitch (Ubuntu Cosmic):
importance: Undecided → Medium
description: updated
Peter Sabaini (peter-sabaini) wrote :

Does this include the fix in Bug #1737866? Do you perhaps have an ETA on a release? Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openvswitch - 2.10.0-0ubuntu2

---------------
openvswitch (2.10.0-0ubuntu2) cosmic; urgency=medium

  * d/{openvswitch-switch,ovn-common}.install: Add missed scripts and
    binaries.
  * d/p/erspan-add-big-endian-bit-fields.patch,tests-Fix-hash-function-
    dependencies-in-tunnel-ERSPA.patch: Cherry pick upstream fixes for
    s390x issues (LP: #1788133).
  * d/rules: Don't skip any tests on s390x.

 -- James Page <email address hidden> Wed, 22 Aug 2018 09:08:55 +0100

Changed in openvswitch (Ubuntu Cosmic):
status: Triaged → Fix Released
Changed in cloud-archive:
status: Triaged → Fix Committed
Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package openvswitch - 2.10.0-0ubuntu2~cloud0
---------------

 openvswitch (2.10.0-0ubuntu2~cloud0) bionic-rocky; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 openvswitch (2.10.0-0ubuntu2) cosmic; urgency=medium
 .
   * d/{openvswitch-switch,ovn-common}.install: Add missed scripts and
     binaries.
   * d/p/erspan-add-big-endian-bit-fields.patch,tests-Fix-hash-function-
     dependencies-in-tunnel-ERSPA.patch: Cherry pick upstream fixes for
     s390x issues (LP: #1788133).
   * d/rules: Don't skip any tests on s390x.
 .
 openvswitch (2.10.0-0ubuntu1) cosmic; urgency=medium
 .
   * d/control: Add BD on python{3}-sortedcontainers.
   * d/watch: Update for upstream website changes.
   * New upstream release.
   * d/p/py3-compat.patch: Rebased on latest upstream review.
   * d/rules: Disable tests 805,810,814 on s390x.
   * d/rules: Rename SKIP_TEST -> TEST_LIST.
   * d/rules: Re-enable all tests on arm64/armhf.
   * d/control: Add libunbound-dev to BD's.
 .
 openvswitch (2.9.2-0ubuntu1) cosmic; urgency=medium
 .
   * Switch openvswitch-* packages to use Python 3 (LP: #1735377):
     - d/p/py3-compat.patch: Misc py3 compat fixes for bug tools.
     - d/control: ${python:Depends} -> ${python3:Depends}.
   * New upstream release (LP: #1780752).
   * d/rules: Tidy test execution.
   * d/rules: Skip test 8 on arm64,armhf.

Changed in cloud-archive:
status: Fix Committed → Fix Released
James Page (james-page) wrote :

Uploaded to bionic UNAPPROVED queue for SRU team review.

Hello James, or anyone else affected,

Accepted openvswitch into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/openvswitch/2.9.2-0ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in openvswitch (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
Albert Damen (albrt) wrote :

After installing this upgrade, my openstack neutron services didn't start anymore.
Neutron log shows:
2018-10-18 08:08:10.573 16703 CRITICAL neutron [-] Unhandled error: ImportError: No module named compat
...
2018-10-18 08:04:30.302 14895 ERROR neutron File "/usr/lib/python2.7/dist-packages/ovs/db/custom_index.py", line 12, in <module>
2018-10-18 08:04:30.302 14895 ERROR neutron from ovs.compat import sortedcontainers
2018-10-18 08:04:30.302 14895 ERROR neutron ImportError: No module named compat

Downgrading openvswitch-common, openvswitch-switch and python-openvswitch to version python-openvswitch solved the problem.

I found https://bugzilla.redhat.com/show_bug.cgi?id=1619712 which suggests the issue is due to a change in openvswitch 2.9.1.

tags: added: verification-failed-bionic
removed: verification-needed-bionic
James Page (james-page) wrote :

I see the patch we need to pick - doing so now with a revised upload.

https://github.com/openvswitch/ovs/commit/58a7ce60b9f7d964d2fccd4deb11cb1d39bf64cf.patch

Brian Murray (brian-murray) wrote :

Hello James, or anyone else affected,

Accepted openvswitch into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/openvswitch/2.9.2-0ubuntu0.18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed-bionic
removed: verification-failed-bionic
Albert Damen (albrt) wrote :

I confirm the issue I reported in comment #7 has been fixed.
After installing openvswitch-common, openvswitch-switch, python-openvswitch 2.9.2-0ubuntu0.18.04.2 the neutron-openvswitch-agent continued working and after restarting neutron-openvswitch-agent network traffic between running instances was working again.
Restarting the neutron nodes also worked, neutron-ovs-cleanup.log did not complain about the missing compat module anymore.
(leaving formal verification to the openstack team, as mentioned in the bug description)

James Page (james-page) wrote :

Hello James, or anyone else affected,

Accepted openvswitch into queens-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:queens-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-queens-needed to verification-queens-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-queens-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-queens-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.