openvswitch: Use of Python3 needed

Bug #1735377 reported by Matthias Klose on 2017-11-30
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openvswitch (Debian)
New
Unknown
openvswitch (Ubuntu)
Critical
James Page

Bug Description

openvswitch: Use of Python3 needed. Upstream seems to support it.

Matthias Klose (doko) on 2017-11-30
tags: added: py2-demotion py2-removal
Changed in openvswitch (Ubuntu):
assignee: nobody → Ubuntu OpenStack (ubuntu-openstack)
Changed in openvswitch (Debian):
status: Unknown → New
James Page (james-page) on 2017-12-05
Changed in openvswitch (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
milestone: none → ubuntu-18.04
Changed in openvswitch (Debian):
status: New → Fix Released
Changed in openvswitch (Debian):
status: Fix Released → New
James Page (james-page) wrote :

I've made a start on this however alot of the tools that currently use py2 in the openvswitch source package don't have test coverage, so its a bit of a manual test process at the moment.

branch-py3 under ~ubuntu-server-dev contains work to-date.

Changed in openvswitch (Ubuntu):
assignee: Ubuntu OpenStack (ubuntu-openstack) → James Page (james-page)
status: Triaged → In Progress
Dimitri John Ledkov (xnox) wrote :

Sounds good, what assistance do you require?

Should we make alternative package available to force python3 there and test in parallel?

At this point we may want to upload python3 based package asap, and continue fixing it upto 18.10 GA.

Changed in openvswitch (Ubuntu):
milestone: ubuntu-18.04 → ubuntu-18.10
importance: Medium → Critical
James Page (james-page) wrote :

@xnox

Revisiting this work this week with intent to upload ASAP.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.