functional gate failed with git clone timeout on fetching ovs from github

Bug #1617282 reported by Ihar Hrachyshka on 2016-08-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
neutron
Medium
Jakub Libosvar
openvswitch (Ubuntu)
Undecided
Unassigned

Bug Description

http://logs.openstack.org/68/351368/23/check/gate-neutron-dsvm-functional/0d68031/console.html

2016-08-25 10:06:34.915685 | fatal: unable to access 'https://github.com/openvswitch/ovs.git/': Failed to connect to github.com port 443: Connection timed out
2016-08-25 10:06:34.920456 | + functions-common:git_timed:603 : [[ 128 -ne 124 ]]
2016-08-25 10:06:34.921769 | + functions-common:git_timed:604 : die 604 'git call failed: [git clone' https://github.com/openvswitch/ovs.git '/opt/stack/new/ovs]'
2016-08-25 10:06:34.922982 | + functions-common:die:186 : local exitcode=0
2016-08-25 10:06:34.924373 | + functions-common:die:187 : set +o xtrace
2016-08-25 10:06:34.924404 | [Call Trace]
2016-08-25 10:06:34.924430 | /opt/stack/new/neutron/neutron/tests/contrib/gate_hook.sh:53:compile_ovs
2016-08-25 10:06:34.924447 | /opt/stack/new/neutron/devstack/lib/ovs:57:git_timed
2016-08-25 10:06:34.924463 | /opt/stack/new/devstack/functions-common:604:die
2016-08-25 10:06:34.926689 | [ERROR] /opt/stack/new/devstack/functions-common:604 git call failed: [git clone https://github.com/openvswitch/ovs.git /opt/stack/new/ovs]

I guess we should stop pulling OVS from github. Instead, we could use Xenial platform that already provides ovs == 2.5 from .deb packages.

Single hit in 7 days.

tags: added: gate-failure
Changed in neutron:
importance: Undecided → Medium
tags: added: functional-tests

Kuba and I talked about this tangentially. He will be working on providing a functional job (experimental to start with) that tests on Xenial.

Changed in neutron:
assignee: nobody → Jakub Libosvar (libosvar)
status: New → Confirmed

We still need to pull 2.5.1 because of a fix. We gotta bump it in Ubuntu first to avoid compilation.

The ovs fix we need for functional job stability: https://mail.openvswitch.org/pipermail/ovs-git/2016-March/017804.html

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openvswitch (Ubuntu):
status: New → Confirmed
Changed in neutron:
status: Confirmed → Fix Released
James Page (james-page) wrote :

This fix is included in 2.5.1

James Page (james-page) wrote :

2.5.2 will be covered under bug 1673063

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers