high latency between VMs in openstack using OVS

Bug #1280370 reported by Chris J Arges on 2014-02-14
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openvswitch (Ubuntu)
Undecided
Unassigned
Precise
Medium
Chris J Arges

Bug Description

SRU Justification:
[Impact]
* There is high latency when testing latency between VMs in an Openstack environment.
* This affects OVS in P/Q.

[Test Case]
* Setup Openstack.
* On a compute node create at least 15 tenants and add 50 instances (more instances show larger latencies).
* From the Neutron node ping to a particular instance:
ip netns exec qrouter-<uuid> ping -c 1 <instance ip>
* We expect this latency to be similar to the latency from not using OVS.

[Regression Potential]
* The following patch from upstream OVS solves the issue: c37d4da4f0fd0190ea8fef97399df6d27ebf6ee2.
* It requires 755be9ea9d7250edd37e1056362e08a7436f6983 to be backported as well since the 1.4.6 still uses sysfs to get carrier info (/sys/class/net/%s/carrier) instead of ioctl. Once we are using ioctls the second patch c37d4da4f0fd0190ea8fef97399df6d27ebf6ee2 reduces the number of times the ioctl is called from netdev_get_carrier().
* There has been testing already done with these two patches applied on top of 1.4.6 in precise.

Chris J Arges (arges) on 2014-02-14
Changed in openvswitch (Ubuntu):
status: New → Fix Released
Changed in openvswitch (Ubuntu Precise):
assignee: nobody → Chris J Arges (arges)
Changed in openvswitch (Ubuntu Quantal):
assignee: nobody → Chris J Arges (arges)
Changed in openvswitch (Ubuntu Precise):
importance: Undecided → Medium
Changed in openvswitch (Ubuntu Quantal):
importance: Undecided → Medium
Changed in openvswitch (Ubuntu Precise):
status: New → Triaged
status: Triaged → In Progress
Changed in openvswitch (Ubuntu Quantal):
status: New → In Progress
Chris J Arges (arges) wrote :
Chris J Arges (arges) wrote :

Hello Chris, or anyone else affected,

Accepted openvswitch into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/openvswitch/1.4.6-0ubuntu1.12.10.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in openvswitch (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in openvswitch (Ubuntu Precise):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Chris, or anyone else affected,

Accepted openvswitch into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/openvswitch/1.4.6-0ubuntu1.12.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of openvswitch from precise-proposed was performed and bug 1307787 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1307787 "bot-stop-nagging". Thanks!

tags: added: verification-failed
Chris J Arges (arges) wrote :

I don't believe bug 130778 is caused by this SRU. I looked at this bug and was unable to reproduce the issue with 3.2 and 3.8 kernels using the -proposed package.

tags: removed: verification-failed
Chris J Arges (arges) on 2014-09-02
no longer affects: openvswitch (Ubuntu Quantal)
Bryan Quigley (bryanquigley) wrote :

Same user verified as had the initial issue.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for openvswitch has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openvswitch - 1.4.6-0ubuntu1.12.04.3

---------------
openvswitch (1.4.6-0ubuntu1.12.04.3) precise; urgency=low

  * d/p/0011-netdev-linux-Get-carrier-from-ioctl-instead-of-sysfs.patch:
    d/p/0012-netdev-linux-Cache-flags-using-netlink.patch:
    Fix latency issues between VMs using OVS. (LP: #1280370)
 -- Chris J Arges <email address hidden> Fri, 14 Feb 2014 12:38:07 -0600

Changed in openvswitch (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers