[SRU] log flooded with "cannot get STP status on nonexistent port" messages

Bug #1134103 reported by James Dingwall on 2013-02-27
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openvswitch (Ubuntu)
High
Unassigned
Precise
High
James Page
Quantal
High
James Page
Raring
Undecided
Unassigned
Saucy
High
Unassigned

Bug Description

Impact:
Some Xen and OVS users will experience floods of STP errors in syslog; this generates noise and IO and fills disk space.

Test Case:
Setup Ubuntu 12.04 with Xen and OVS networking options.
Create a new guest domain using paravirtualized drivers.

Regression Potential:
Limited; the fix just switches the offending error message to be log rate-limited within openvswitch itself.

Original Bug Report:
When using Xen and OVS a log flood occurs (approx 10 entries /s) when using stubdom based HVM guests with PV drivers. This issue was reported to the OVS developers (http://openvswitch.org/pipermail/dev/2013-February/025586.html) and a fix was merged for the 1.4.6 release. Please consider updating the Ubuntu package to incorporate this fix.

$ lsb_release -rd
Description: Ubuntu 12.04.2 LTS
Release: 12.04

$ apt-cache policy openvswitch-switch
openvswitch-switch:
  Installed: 1.4.0-1ubuntu1.5
  Candidate: 1.4.0-1ubuntu1.5
  Version table:
 *** 1.4.0-1ubuntu1.5 0
        500 http://repo/ubuntu/ precise-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     1.4.0-1ubuntu1 0
        500 http://repo/ubuntu/ precise/universe amd64 Packages

Serge Hallyn (serge-hallyn) wrote :

Thanks for reporting this bug. Marking confirmed based on the upstream confirmation.

We need to look at the 1.4.6 branch to see how much of a change it would be to SRU that to precise.

Changed in openvswitch (Ubuntu):
status: New → Confirmed
importance: Undecided → High
James Page (james-page) on 2013-07-07
Changed in openvswitch (Ubuntu):
status: Confirmed → Fix Released
Changed in openvswitch (Ubuntu Precise):
status: New → Triaged
Changed in openvswitch (Ubuntu Quantal):
status: New → Triaged
Changed in openvswitch (Ubuntu Precise):
importance: Undecided → Medium
Changed in openvswitch (Ubuntu Quantal):
importance: Undecided → Medium
James Page (james-page) on 2013-07-07
Changed in openvswitch (Ubuntu Precise):
assignee: nobody → James Page (james-page)
Changed in openvswitch (Ubuntu Quantal):
assignee: nobody → James Page (james-page)
James Page (james-page) on 2013-07-08
Changed in openvswitch (Ubuntu Precise):
importance: Medium → High
Changed in openvswitch (Ubuntu Quantal):
importance: Medium → High
Changed in openvswitch (Ubuntu Precise):
status: Triaged → In Progress
summary: - openvswitch-switch: log flooded with "cannot get STP status on
- nonexistent port" messages
+ [SRU] log flooded with "cannot get STP status on nonexistent port"
+ messages
James Page (james-page) on 2013-07-08
description: updated
James Page (james-page) wrote :

Fixed version uploaded to precise-proposed for SRU team review.

James Page (james-page) wrote :

and for quantal as well.

@James - hoping that you will be able to test the proposed packages for precise when they are available for testing- thanks!

James Page (james-page) on 2013-07-11
Changed in openvswitch (Ubuntu Quantal):
status: Triaged → In Progress

Hello James, or anyone else affected,

Accepted openvswitch into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/openvswitch/1.4.0-1ubuntu1.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in openvswitch (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in openvswitch (Ubuntu Quantal):
status: In Progress → Fix Committed
Dave Walker (davewalker) wrote :

Hello James, or anyone else affected,

Accepted openvswitch into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/openvswitch/1.4.3-0ubuntu2.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in openvswitch (Ubuntu Raring):
status: New → Invalid
Dave Walker (davewalker) wrote :

Does not affect Raring.

Thanks

James Page (james-page) wrote :

@James Dingwall

Any chance you can test this out? otherwise it will get bumped from the SRU queue as I need to get on with hardware enablement kernel compatibility fixes for 12.04.3

Cheers

James

@James Page

We moved our platform to 13.04 for other reasons and we stopped seeing this issue due to a newer ovs release. I will try to find a system with 12.04 to test the proposed fix but I may not be able to do this immediately.

James

Dave Walker (davewalker) wrote :

@James Page, this upload is blocking your MRE upload which has been in the queue since 2013-09-03.

As this MRE upload also includes this bug, and this one hasn't yet received satisfactory verification - we could drop this upload and progress directly to the MRE.. but this issue would still need verification.

Would you agree that this would be best action?

Thanks.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

On 13/10/13 22:24, Dave Walker wrote:
> As this MRE upload also includes this bug, and this one hasn't yet
> received satisfactory verification - we could drop this upload and
> progress directly to the MRE.. but this issue would still need
> verification.
>
> Would you agree that this would be best action?

Agreed

- --
James Page
Ubuntu and Debian Developer
<email address hidden>
<email address hidden>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.14 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJSW9TTAAoJEL/srsug59jD/7EQAK77MvlGPBlspnS3bV2iJ+Q9
YHfAx6QLjXOZTxr8jSuavYYsQto3WWLBUz82ASJ+/idyObuQbfDNbgtlrbRtemEu
KMrfXQPFAvC+BYrs8iMXdrdsNr3nk1ieXfAJiyratQKJZ0GI7nuewnMbWuUB8dMu
eWeHQTbKk5LAjQtoPaeB7RkiD40mshAm+XR5VrYChAvoEuSPYZ4BT6kwkiRMk4rT
BjT/X/kgklOx8Kc/2Zw+BAkj4qkFA3YUws+22RHbNg/88IgB3owX92l2a9pQ2ewf
DU1ojNVOz+i5HOJBmEDiNmm9/5nvyyAeYo7Iy2B9QeUy71nN+vq8W5xxu/wZX35v
TDsnu6+zazGBbbyqx1yi/nNULfLqbSwSjxNoxMZNGZPUcU13KH8ublDzlfis0Mnl
FteLlT2hNh4tI8eNRNrdKEW4TLTvXtdGFzcMAj8WsIuQpWijs8ED34LRcu1DQBzb
2cqzyFeIVpzIureFrFdQkwgmmmWh8zhxJlF05NCTV6TWgycBuljO9KgUozpowKcb
flB9Cqwmn6tfczOQA12YMzAXjPFlZ2HSHDAbAtwLv2kEN6pggEVov9K60+7kpMrv
GmgRP3fj5IXk/iu0EsRQxQYTaq1H2zXXHE/Q/7DQPruBV/uRXsJY/N0xl7H20wEI
Z68IGgEDU0kQmTlXhsxc
=4HMF
-----END PGP SIGNATURE-----

Hello James, or anyone else affected,

Accepted openvswitch into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/openvswitch/1.4.6-0ubuntu1.12.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Dave Walker (davewalker) wrote :

Hello James, or anyone else affected,

Accepted openvswitch into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/openvswitch/1.4.6-0ubuntu1.12.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Chris J Arges (arges) wrote :

The change is in the code, and according to https://wiki.ubuntu.com/StableReleaseUpdates/MicroReleaseExceptions:
" For MRE packages only, it can generally be assumed that bugs claimed to be fixed have actually been fixed upstream, and it is not necessary to manually independently verify them. (Some bugs may deserve specific verification if for example they are hard to reproduce upstream.)"
Marking this verification-done-*

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openvswitch - 1.4.6-0ubuntu1.12.04.2

---------------
openvswitch (1.4.6-0ubuntu1.12.04.2) precise; urgency=low

  * d/p/0010-datapath_ip_select_ident_fix.patch: linux commit 703133de changes
    the first parameter of ip_select_ident from iph to skb (LP: #1262692)
 -- Chris J Arges <email address hidden> Wed, 08 Jan 2014 13:36:14 -0600

Changed in openvswitch (Ubuntu Precise):
status: Fix Committed → Fix Released
Chris J Arges (arges) on 2014-02-14
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openvswitch - 1.4.6-0ubuntu1.12.10.2

---------------
openvswitch (1.4.6-0ubuntu1.12.10.2) quantal; urgency=low

  * d/p/0010-datapath_ip_select_ident_fix.patch: linux commit 703133de changes
    the first parameter of ip_select_ident from iph to skb (LP: #1262692)
 -- Chris J Arges <email address hidden> Wed, 08 Jan 2014 13:54:40 -0600

Changed in openvswitch (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers