openvswitch-datapath-dkms FTBFS with 12.04.2 3.5 kernel

Bug #1116382 reported by James Page on 2013-02-05
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
openvswitch (Ubuntu)
Undecided
Unassigned
Precise
Critical
James Page

Bug Description

[Impact]

Openvswitch DKMS module is not compatible with the 3.5 kernel which will be provided from 12.04.2. Users of openvswitch will only be able to use the native kernel module which does not support all features including GRE tunnelling.

Openstack Quantum, for example, makes extensive use of this feature.

[Test Case]

Install 12.04.2 from ISO
sudo apt-get install openvswitch-datapath-dkms
DKMS module fails to build

[Regression Potential]

The cherry picked fixes provide support for the 3.5 kernel and rename the DKMS built modules to remove the _mod suffix.

This could regress the dkms package for 3.2 kernel users (that said I have tested this scenario and the upgrade from 3.2->3.5 as well).

[Original Bug Report]
The openvswitch-datapath-dkms module FTBFS with the 3.5 kernel proposed for 12.04.2:

DKMS make.log for openvswitch-1.4.0 for kernel 3.5.0-23-generic (x86_64)
Tue Feb 5 15:45:41 GMT 2013
checking build number... none
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking whether the C compiler works... no
configure: error: in `/var/lib/dkms/openvswitch/1.4.0/build':
configure: error: C compiler cannot create executables
See `config.log' for more details
make: Entering directory `/var/lib/dkms/openvswitch/1.4.0/build/datapath/linux'
make: *** No targets specified and no makefile found. Stop.
make: Leaving directory `/var/lib/dkms/openvswitch/1.4.0/build/datapath/linux'

Although the 3.5 kernel does provide a native openvswitch module, it does not support GRE tunnels which are used extensively by OpenStack Quantum.

The patches currently held for quantal should suffice to fix this problem.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: openvswitch-datapath-dkms 1.4.0-1ubuntu1.3
ProcVersionSignature: Ubuntu 3.5.0-23.35~precise1-generic 3.5.7.2
Uname: Linux 3.5.0-23-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
Date: Tue Feb 5 15:45:03 2013
InstallationMedia: Ubuntu-Server 12.04.2 LTS "Precise Pangolin" - Release amd64 (20130205)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: openvswitch
UpgradeStatus: No upgrade log present (probably fresh install)

James Page (james-page) wrote :
James Page (james-page) on 2013-02-05
Changed in openvswitch (Ubuntu):
status: New → Fix Released
James Page (james-page) wrote :

Error in original bug report was due to lack of libc6-dev.

Same errors as for quantal.

James Page (james-page) on 2013-02-05
Changed in openvswitch (Ubuntu Precise):
importance: Undecided → Critical
status: New → In Progress
assignee: nobody → James Page (james-page)
milestone: none → ubuntu-12.04.2
James Page (james-page) on 2013-02-06
description: updated
James Page (james-page) on 2013-02-06
description: updated

Hello James, or anyone else affected,

Accepted openvswitch into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/openvswitch/1.4.0-1ubuntu1.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in openvswitch (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
James Page (james-page) wrote :

Tested with 3.2 and 3.5 kernels in proposed.

tags: added: verification-done
removed: verification-needed
Colin Watson (cjwatson) wrote :

This was a bit late to be on .2 images, but should be in -updates immediately after .2 releases and will be in .3.

Changed in openvswitch (Ubuntu Precise):
milestone: ubuntu-12.04.2 → ubuntu-12.04.3

On 12 February 2013 18:48, Colin Watson <email address hidden> wrote:
> This was a bit late to be on .2 images, but should be in -updates
> immediately after .2 releases and will be in .3.
>
> ** Changed in: openvswitch (Ubuntu Precise)
> Milestone: ubuntu-12.04.2 => ubuntu-12.04.3
>

@Colin, I don't think openvswitch is seeded on any ISO's... And
without this update, openvswitch is entirely useless on 12.04.2.
Unless I am mistaken about it being on an ISO, could it be released
prior to 12.04.2 please?

Thanks.

--
Kind Regards,
Dave Walker

Colin Watson (cjwatson) wrote :

I don't see why it really matters if it's not on images; it can go into -updates pretty much as soon as .2 releases (or possibly slightly before depending on how my schedule works out).

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in openvswitch (Ubuntu Precise):
milestone: ubuntu-12.04.3 → ubuntu-12.04.2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openvswitch - 1.4.0-1ubuntu1.4

---------------
openvswitch (1.4.0-1ubuntu1.4) precise-proposed; urgency=low

  * Fix compatibility with 3.5 kernel (LP: #1116382):
    - d/p/000*.patch: Cherry picked fixes from upstream VCS for kernel 3.5
      support, including removing the _mod suffix from DKMS built modules.
    - d/dkms.conf.in,rule.modules: Drop _mod suffix from built modules.
  * Ensure DKMS modules are automatically re-built with kernel upgrades
    (LP: #962189):
    - d/dkms.conf.in: Use AUTOINSTALL=yes.
 -- James Page <email address hidden> Wed, 06 Feb 2013 09:41:27 +0000

Changed in openvswitch (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers