module-assistant install of openvswitch-datapath fails on quantal due to drop of _mod postfix

Bug #1088160 reported by Kamil Madac on 2012-12-09
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
openvswitch (Ubuntu)
Medium
Unassigned
Quantal
Medium
James Page

Bug Description

[Impact]
module-assistance build/installs fail due to removal of _mod postfix from module names

[Test Case]
sudo apt-get install module-assistant
sudo module-assistant auto-install openvswitch-datapath

Error:
install: cannot stat `openvswitch/datapath/linux/*_mod.ko': No such file or directory

[Regression Potential]
Minimal; one-line fix in d/rules.modules which is only used for this install method.

[Original Bug Report]
Hello,

after installation of openvswitch packages I'm not able to start brcompat service.
I used package openvswitch-datapath-dkms.

brcompat module is loaded
#> lsmod | grep brcompat
brcompat 12387 0

#> service openvswitch-switch status
ovsdb-server is running with pid 4689
ovs-vswitchd is running with pid 4698
ovs-brcompatd is not running

when I try to restart openvswitch services it end up with error message:

#> service openvswitch-switch restart
 * ovs-brcompatd is not running
 * Killing ovs-vswitchd (8226)
 * Killing ovsdb-server (8217)
 * Starting ovsdb-server
 * Configuring Open vSwitch system IDs
 * Starting ovs-vswitchd
ovs-brcompatd: could not open brcompat socket. Check "brcompat" kernel module.
 * Starting ovs-brcompatd

I tried to compile module

#> module-assistant auto-install openvswitch-datapath

but it was terminated with error"
install: cannot stat `openvswitch/datapath/linux/*_mod.ko': No such file or directory

#> 'lsb_release -rd'
Description: Ubuntu 12.10
Release: 12.10

#> apt-cache policy openvswitch-datapath-dkms
openvswitch-datapath-dkms:
  Installed: 1.4.3-0ubuntu2
  Candidate: 1.4.3-0ubuntu2
  Version table:
 *** 1.4.3-0ubuntu2 0
        500 http://sk.archive.ubuntu.com/ubuntu/ quantal-updates/universe amd64 Packages
        100 /var/lib/dpkg/status

Changed in openvswitch (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Bjorn Gott (bbgott) wrote :

I am running into the same problem, but did find information on an upstream patch that apparently addresses this issue.

http://openvswitch.org/pipermail/dev/2012-March/015581.html

Kamil Madac (kamil-madac) wrote :

After I applied the path I was able to compile and install module brcompat.ko, but after openvswitch restart I still get same error message:

# service openvswitch-switch start
 * Starting ovsdb-server
 * Configuring Open vSwitch system IDs
 * Starting ovs-vswitchd
ovs-brcompatd: could not open brcompat socket. Check "brcompat" kernel module.
 * Starting ovs-brcompatd

Forest Zhang (forest-zrd) wrote :

Hi, i spent lots of time to get this brcompat module loaded but all failed on Ubuntu12.10.

Is anybody still working on this?

James Page (james-page) on 2013-01-16
Changed in openvswitch (Ubuntu):
status: Confirmed → Fix Released
Changed in openvswitch (Ubuntu Quantal):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → James Page (james-page)
James Page (james-page) wrote :

brcompat module problem in bug 1125611

summary: - ovs-brcompatd: could not open brcompat socket. Check "brcompat" kernel
- module.
+ module-assistant install of openvswitch-datapath fails on quantal
description: updated
James Page (james-page) wrote :

Fix uploaded to quantal-proposed for module-assistant install problem

summary: - module-assistant install of openvswitch-datapath fails on quantal
+ module-assistant install of openvswitch-datapath fails on quantal due to
+ drop of _mod postfix
James Page (james-page) on 2013-02-16
Changed in openvswitch (Ubuntu Quantal):
status: Triaged → In Progress

Hello Kamil, or anyone else affected,

Accepted openvswitch into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/openvswitch/1.4.3-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in openvswitch (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Bjorn Gott (bbgott) wrote :

I couldn't wait for the fix, so I went ahead and rebuilt that box with a different version of Ubuntu. I can not test the fix patch as the machine is now in production and I can not take it down to rebuild it again.

Hi Colin,

I'm going to test the package tomorrow.

Kamil

On Mon, Feb 18, 2013 at 4:52 PM, Bjorn Gott <email address hidden>wrote:

> I couldn't wait for the fix, so I went ahead and rebuilt that box with a
> different version of Ubuntu. I can not test the fix patch as the
> machine is now in production and I can not take it down to rebuild it
> again.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1088160
>
> Title:
> module-assistant install of openvswitch-datapath fails on quantal due
> to drop of _mod postfix
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/openvswitch/+bug/1088160/+subscriptions
>

James Page (james-page) wrote :

module-assistant auto-install openvswitch-datapath results in an full working brcompat and openvswitch module

tags: added: verification-done
removed: verification-needed
Colin Watson (cjwatson) wrote :

Waiting the usual seven-day waiting period since this goes with regression bug 1125611.

Colin Watson (cjwatson) wrote :

s/Waiting/Waiving/

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openvswitch - 1.4.3-0ubuntu2.1

---------------
openvswitch (1.4.3-0ubuntu2.1) quantal-proposed; urgency=high

  * Fix broken brcompat module due to circular DKMS build dependency
    causing brcompat.o to be excluded from module (LP: #1125611):
    - d/p/0009-datapath-rename-brcompat.c-to-brcompat_main.c.patch:
      Cherry picked fix from upstream VCS which renames brcompat.c ->
      brcompat_main.c to support drop of _mod postfix.
  * Fix module-assistant installs of openvswitch-datapath (LP: #1088160):
    - d/rules.modules: Drop _mod postfix when installing modules.
 -- James Page <email address hidden> Sat, 16 Feb 2013 14:02:05 +0000

Changed in openvswitch (Ubuntu Quantal):
status: Fix Committed → Fix Released
Peng Yong (ppyy) wrote :

brcompat failed with linux-image-3.5.0-24-generic.

# /etc/init.d/openvswitch-switch start
FATAL: Error inserting brcompat (/lib/modules/3.5.0-24-generic/kernel/brcompat.ko): Unknown symbol in module, or unknown parameter (see dmesg)
 * Inserting brcompat module
Module has probably not been built for this kernel.
For instructions, read
/usr/share/doc/openvswitch-datapath-source/README.Debian
FATAL: Error inserting brcompat (/lib/modules/3.5.0-24-generic/kernel/brcompat.ko): Unknown symbol in module, or unknown parameter (see dmesg)
 * Inserting brcompat module

dmesg shows:

[ 362.917013] brcompat: Unknown symbol ovs_dp_ioctl_hook (err 0)

# find /lib/modules/ -name "*openvs*"
/lib/modules/3.5.0-24-generic/kernel/net/openvswitch
/lib/modules/3.5.0-24-generic/kernel/net/openvswitch/openvswitch.ko
/lib/modules/3.5.0-24-generic/kernel/openvswitch.ko

# dpkg -S /lib/modules/3.5.0-24-generic/kernel/net/openvswitch/openvswitch.ko
linux-image-3.5.0-24-generic: /lib/modules/3.5.0-24-generic/kernel/net/openvswitch/openvswitch.ko

there is a openvswitch module in linux-image-3.5.0-24-generic now.

James Page (james-page) wrote :

Please can you try:

 sudo service openvswitch-switch force-reload-kmod

Modprobe should prefer the DKMS openvswitch module over the kernel provided one; brcompat only works with the DKMS version.

Peng Yong (ppyy) wrote :

# service openvswitch-switch force-reload-kmod
 * Inserting openvswitch module
FATAL: Error inserting brcompat (/lib/modules/3.5.0-24-generic/kernel/brcompat.ko): Unknown symbol in module, or unknown parameter (see dmesg)
 * Inserting brcompat module
Module has probably not been built for this kernel.
For instructions, read
/usr/share/doc/openvswitch-datapath-source/README.Debian
Feb 20 00:07:52|00001|stream_unix|ERR|/tmp/stream-unix.2932.0: connection to /var/run/openvswitch/db.sock failed: No such file or directory
Feb 20 00:07:52|00002|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt failed (No such file or directory)
Feb 20 00:07:53|00003|stream_unix|ERR|/tmp/stream-unix.2932.1: connection to /var/run/openvswitch/db.sock failed: No such file or directory
Feb 20 00:07:53|00004|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt failed (No such file or directory)
Feb 20 00:07:55|00005|stream_unix|ERR|/tmp/stream-unix.2932.2: connection to /var/run/openvswitch/db.sock failed: No such file or directory
Feb 20 00:07:55|00006|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt failed (No such file or directory)
Alarm clock
 * Detected internal interfaces:
 * ovs-brcompatd is not running
 * ovs-vswitchd is not running
 * ovsdb-server is not running
 * Saving interface configuration
 * Removing openvswitch module
 * Inserting openvswitch module
FATAL: Error inserting brcompat (/lib/modules/3.5.0-24-generic/kernel/brcompat.ko): Unknown symbol in module, or unknown parameter (see dmesg)
 * Inserting brcompat module
 * Restoring interface configuration
 * iptables already has a rule for gre, not explicitly enabling

i remove the module provided by kernel, then it works:

#mv /lib/modules/3.5.0-24-generic/kernel/net/openvswitch/openvswitch.ko /tmp
#depmod -a
#/etc/init.d/openvswitch-switch start <<<
 * Inserting openvswitch module
 * Inserting brcompat module
 * Starting ovsdb-server
 * Configuring Open vSwitch system IDs
 * Starting ovs-vswitchd
 * Starting ovs-brcompatd
 * iptables already has a rule for gre, not explicitly enabling

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers