openvpn does not work due to max-locked-memory limit

Bug #154696 reported by icemaann on 2007-10-20
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openvpn (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openvpn

After upgrading to gutsy I noticed that openvpn was not working properly. After using strace and researching online I found this post:
http://openvpn.net/archive/openvpn-users/2006-05/msg00339.html

Which states that the max-locked-memory limit can cause the problem (ulimit -l). Sure enough after setting `ulimit -l unlimited` openvpn worked perfectly.

It is possible that this memory limit could affect other applications as well.

I forgot to mention.... openvpn fails to start with an "out of memory" error. I added "ulimit -l unlimited" to the init script which fixed it (it could also be done in limits.conf).

yaplik (yaplik) wrote :

Happened also to me, so I confirm the bug.
Quick workaround is not to use mlock option.

Changed in openvpn:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openvpn - 2.1~rc7-1ubuntu3

---------------
openvpn (2.1~rc7-1ubuntu3) hardy; urgency=low

  * More init script LSB compliance. (LP: #134210)
  * Added warning about max-locked-memory-limit to Readme.Debian. (LP: #154696)

 -- Chuck Short <email address hidden> Wed, 20 Feb 2008 13:43:29 -0500

Changed in openvpn:
status: Confirmed → Fix Released
Simon Déziel (sdeziel) wrote :

Is there any way to implement a clean work around other that editing the init script as suggested in
The workaround suggested in Readme.Debian is to "put a "ulimit -l <reasonable number>" in the openvpn init script."

I was wondering if a cleaner way of doing this exist ? I tried adding the new limits in /etc/security/limits.d/openvpn.conf and /etc/security/limits.conf and but it didn't work.

Thanks in advance,
Simon

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers