sync openttd 1.0.0-1 from Debian unstable

Bug #556593 reported by Jordi Mallach on 2010-04-06
74
This bug affects 12 people
Affects Status Importance Assigned to Milestone
openttd (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openttd

OpenTTD released version 1.0.0 a week ago. Due to Debian's ries.d.o being down, the package only entered unstable a few days ago, though.

I'm asking for a Freeze Exception for the following reasons:

 - OpenTTD 1.0.x is the first version to be completely DFSG-free. A community of artists have created a new graphic set from scratch and the game engine can now be used without depending on the original, non-free data. This would allow to move the package from multiverse to universe in Ubuntu.
 - This is a network game. The new upstream version is already widely used in most multiplayer servers, and the current version in lucid isn't protocol-compatible with the new branch.
 - The package fixes most of the currently open Ubuntu bugs.
 - The new code has been through a very delicate polishing process: several beta versions, and three release candidates. No important issues are known.

Jordi Mallach (jordi) wrote :

Please note that to make OpenTTD a valid candidate for universe, new packages will need to be imported from Debian:

 - openttd-opengfx (directly recommended by openttd)
 - nforenum and grfcodec (Build-Dependencies of openttd-opengfx)
 - openttd-opensfx (for optional sounds)
 - catcodec (Build-Dependencies of -opensfx).

I'm attaching a patch with the changes to the Debian packaging between 0.7.5-1 and 1.0.0-1. The most import changes are:
 - openttd was moved from contrib to main
 - openttd now uses the 3.0 (quilt) source format
 - All maintainer scripts were removed, openttd no longer prompts about missing datafiles on installation and upgrades. This fixes the most commonly reported bugs: People were annoyed by the prompts, and the prompts seemed to be somehow broken in Ubuntu's debconf.
 - The architecture-independent data was split out into a new openttd-data binary package.

The upstream changelog since 0.7.5 is available at
  http://binaries.openttd.org/releases/1.0.0/changelog.txt

Daniel Holbach (dholbach) wrote :

Sponsors ACK. Needs only release team ACK now.

StefanPotyra (sistpoty) wrote :

hm, sdl in lucid has some problems, will openttd be affected by it (bug #528957 comes to my mind, not too sure if there are more)?

I'm also little bit hesitant due to needing 4 packages getting shoved through source new (at this point of the release).

Jordi Mallach (jordi) wrote :

FWIW, 3 of those new packages are solely used by the openttd open media packages to generate the media from their source. I doubt they'll have any more usefulness in the near future other than that.

Regarding libSDL, I hope someone watching this and that has a current lucid box can comment.

William Grant (wgrant) wrote :

I encounter that bug in Wesnoth, but not in the OpenTTD 1.0.0 packages that I've built in ppa:wgrant/openttd. They work just fine.

StefanPotyra (sistpoty) wrote :

Ok, thanks.

Oh, I assume we'd regress wrt sparc (just guessing from the build failure in unstable), however I guess the main audience of openttd won't be playing it on sparc, so I could live with that.

Problem with the new packages is archive admin's time to do the processing, not the impact. I'll see if I can convince someone.

Generally I'm in favor of the FFe, but I'll talk to archive admins first.

Remko Bijker (rubidium) wrote :

The sparc build failure is something very odd. It fails on line about 4 million, but the file has about 1000 lines. Furthermore with the same toolchain 1.0.0~RC3-1 compiled fine and neither the file it fails on nor the dependencies of that file have changed since 1.0.0~RC-1.

I was actually amazed that it failed on sparc.

Jordi Mallach (jordi) wrote :

Note the build failure on Sparc seems to be a buildd hiccup or something transitory. Look at the error message, which reports something bad being in like 4 million. The previous version (rc3) compiled just ok with no code changes on that source file, but it was built by another buildd.

StefanPotyra (sistpoty) wrote :

Ok, thanks. Just did a test-build of my own on lucid/sparc, and that worked like a charm, so nothing to fear in this regard.

StefanPotyra (sistpoty) wrote :

Ok, Scott volunteered to do source-new. FFe granted, please go ahead.

Changed in openttd (Ubuntu):
status: New → Confirmed
Jordi Mallach (jordi) wrote :

Many thanks, Stefan!

I've just uploaded 1.0.0-2 to unstable which fixes upgrades from 0.7.5-1 due to an off-by-one error in the Replaces (upgrading from all other versions already worked). Please use this version for Lucid, thanks.

StefanPotyra (sistpoty) wrote :

good as well for me, thanks for following up!
And great thanks for doing all the work in Debian! :)

James Westby (james-w) wrote :

[Updating] openttd (0.7.5-1 [Ubuntu] < 1.0.0-2 [Debian])
 * Trying to add openttd...
2010-04-12 11:10:11 INFO - <openttd_1.0.0-2.dsc: downloading from http://ftp.debian.org/debian/>
2010-04-12 11:10:11 INFO - <openttd_1.0.0-2.debian.tar.gz: downloading from http://ftp.debian.org/debian/>
2010-04-12 11:10:11 INFO - <openttd_1.0.0.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
I: openttd [multiverse] -> openttd_0.7.5-1 [multiverse].

Changed in openttd (Ubuntu):
status: Confirmed → Fix Released
Jordi Mallach (jordi) wrote :

Regarding build-depends, I thought they would be dealt with at the same time.

I'm reopening the bug.

Can you please sync:

catcodec 1.0.0-1 from Debian testing
grfcodec 0.9.10+svn2306-1 from Debian unstable
nforenum 3.4.6+svn2309-1 from Debian unstable
openttd-opengfx 0.2.3-1 from Debian unstable
openttd-opensfx 0.2.3-1 from Debian unstable/non-free

Also, consider moving openttd from multiverse to universe, which is one of the main goals of this bug report.

Many thanks,
Jordi

Changed in openttd (Ubuntu):
status: Fix Released → Confirmed
Steve Langasek (vorlon) wrote :

Getting binaries for lucid...
[Updating] grfcodec (None [Ubuntu] < 0.9.10+svn2306-1 [Debian])
 * Trying to add grfcodec...
2010-04-13 00:49:30 INFO - <grfcodec_0.9.10+svn2306-1.debian.tar.gz: downloading from http://ftp.debian.org/debian/>
2010-04-13 00:49:30 INFO - <grfcodec_0.9.10+svn2306-1.dsc: downloading from http://ftp.debian.org/debian/>
2010-04-13 00:49:30 INFO - <grfcodec_0.9.10+svn2306.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
[Updating] nforenum (None [Ubuntu] < 3.4.6+svn2309-1 [Debian])
 * Trying to add nforenum...
2010-04-13 00:49:31 INFO - <nforenum_3.4.6+svn2309-1.debian.tar.gz: downloading from http://ftp.debian.org/debian/>
2010-04-13 00:49:31 INFO - <nforenum_3.4.6+svn2309.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
2010-04-13 00:49:31 INFO - <nforenum_3.4.6+svn2309-1.dsc: downloading from http://ftp.debian.org/debian/>
[Updating] openttd-opengfx (None [Ubuntu] < 0.2.3-1 [Debian])
 * Trying to add openttd-opengfx...
2010-04-13 00:49:31 INFO - <openttd-opengfx_0.2.3.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
2010-04-13 00:49:47 INFO - <openttd-opengfx_0.2.3-1.debian.tar.gz: downloading from http://ftp.debian.org/debian/>
2010-04-13 00:49:47 INFO - <openttd-opengfx_0.2.3-1.dsc: downloading from http://ftp.debian.org/debian/>

Steve Langasek (vorlon) wrote :

Getting binaries for lucid...
[Updating] catcodec (None [Ubuntu] < 1.0.0-1 [Debian])
 * Trying to add catcodec...
2010-04-13 00:50:26 INFO - <catcodec_1.0.0-1.debian.tar.gz: downloading from http://ftp.debian.org/debian/>
2010-04-13 00:50:26 INFO - <catcodec_1.0.0.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
2010-04-13 00:50:26 INFO - <catcodec_1.0.0-1.dsc: downloading from http://ftp.debian.org/debian/>

Steve Langasek (vorlon) wrote :

Getting binaries for lucid...
[Updating] openttd-opensfx (None [Ubuntu] < 0.2.3-1 [Debian])
 * Trying to add openttd-opensfx...
2010-04-13 00:56:01 INFO - <openttd-opensfx_0.2.3.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
2010-04-13 00:56:23 INFO - <openttd-opensfx_0.2.3-1.debian.tar.gz: downloading from http://ftp.debian.org/debian/>
2010-04-13 00:56:23 INFO - <openttd-opensfx_0.2.3-1.dsc: downloading from http://ftp.debian.org/debian/>

Steve Langasek (vorlon) wrote :

(Build)Dependencies synced and source-accepted from NEW, and openttd moved to universe.

Changed in openttd (Ubuntu):
status: Confirmed → Fix Released

Awesome, thanks all :-D

Adam Niedling (krychek) wrote :

It doesn't work, I get the following message when I try to start openttd:

OpenTTD returned with error code 1. The following error messages were produced:

Error: Failed to find a graphics set. Please acquire a graphics set for
OpenTTD. See section 4.1 of readme.txt.

Isn't this bug report supposed to fix this?

mrl586 (mrl586) wrote :

Reply to 22: This isn't bug. You can install OpenGXF manually using this guide: http://wiki.openttd.org/OpenGFX#Installing_OpenGFX_Manually

Adam Niedling (krychek) wrote :

I know I can install it manually but the whole point of this report that it all should be automatic. Openttd-opengfx package is not yet available.

Remko Bijker (rubidium) wrote :

openttd-opengfx has been added to Ubuntu's repository, however it has not been compiled yet and as such it is not available for you to install. I don't know who to poke/prod to get the builder to retry compiling as the dependency its waiting on has been about half a day ago.

https://launchpad.net/ubuntu/+source/openttd-opengfx

Adam Niedling (krychek) wrote :

Yes it works, but the OpenSFX and the OpenMSX still needs to be downloaded manually in the game.

Adam Niedling (krychek) wrote :

Hmm.. the music doesn't work even after downloading OpenMSX.

William Grant (wgrant) wrote :

openttd-opensfx is only Suggested, not Recommended. Is there a good reason for that?

StefanPotyra (sistpoty) wrote :

opensfx is still sitting in binary new (I assume it'll get accepted soonish).
OpenMSX isn't packaged, so won't be available from the archive. I'm not too sure why manually downloaded openMSX doesn't work for you but I guess you could try if midi sounds are working in the first place. However we're getting a little bit off-topic for this bug report ;).

Remko Bijker (rubidium) wrote :

OpenTTD-OpenSFX is Suggested because it is in Debian's non-free section and OpenTTD is in main. Debian's policy is to not allow Recommending packages from non-free/contrib in main. As such it is Suggested.

OpenTTD-OpenSFX is in non-free because it uses the Creative Commons Sampling Plus which is deemed non-free by Debian. That license has been "chosen" because all but one sample are from a database with samples under that license, the other is "public domain".

OpenMSX requires some sort of midi synthesizer, which is why OpenTTD suggests timidity and freepats. However, the suggests are not included automatically on installation, i.e. you need to install timidity to get the music working. Why that isn't a recommends I do not know, but I guess it has to do with the number of people that actually use the music instead of their own (external) music player.

Adam Niedling (krychek) wrote :

After installing timidity the music is working.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions