[FFe request] Please sync opensync_0.22-2 from Debian unstable (main)

Bug #214083 reported by Michael Banck on 2008-04-08
16
Affects Status Importance Assigned to Milestone
libopensync-plugin-evolution2 (Ubuntu)
Undecided
Steve Langasek
libopensync-plugin-google-calendar (Ubuntu)
Undecided
Steve Langasek
libopensync-plugin-kdepim (Ubuntu)
Undecided
Unassigned
libopensync-plugin-sunbird (Ubuntu)
Undecided
Unassigned
opensync (Ubuntu)
Undecided
Unassigned

Bug Description

Rationale for dropping Ubuntu changes:

The python build process got fixed in Debian and now supports multiple python versions, so the current Ubuntu hardcoding is no longer necessary. Further, .a/.la files for the python extensions are no longer shipped. No other Ubuntu changes were present.

debian/changelog:

opensync (0.22-2) unstable; urgency=low

  * debian/libopensync0-dev.install: Do not install python stuff.
  * debian/control (Standards-Version): Bump to 3.7.3.
  * debian/control: Replaced ${Source:Version} with ${binary:Version}.

 -- Michael Banck <email address hidden> Sun, 02 Mar 2008 12:39:41 +0100

opensync (0.22-1) unstable; urgency=low

  * New upstream release (Closes: #404856, #442827)
  * debian/control (Uploaders): Added myself.
  * debian/rules (debian/build-stamp): Added --enable-tracing.
  * opensync/opensync_user.c: Change user config dir to ~/.opensync-0.22.
  * debian/rules (debian/configure-stamp): New target.
  * debian/rules (debian/build-stamp): Move configuring to it.
  * debian/copyright: Added download location and clarified copyright and
    licensing (Closes: #439876, #455827).
  * debian/pyversions: Set 2.4 as minimum version (Closes: #445394).
  * debian/rules: Ported generic python handling from experimental branch.
  * debian/python-opensync: Wildcard python directory.
  * acinclude.m4: Add python2.5 to list of python interpreters.
  * Reran aclocal and autoconf.
  * debian/control (libopensync0-dbg): Set Priority to extra.
  * debian/control (python-opensync): Set Section to python.
  * debian/rules (binary-arch): Tighten shlibs to dh_makeshlibs -V.

 -- Michael Banck <email address hidden> Fri, 29 Feb 2008 00:45:57 +0100

Rationale for new upstream version:

opensync-0.19 has been unmaintained upstream for years now and should not get shipped in a LTS release. opensync-0.22 has been released last autumn and is the currently recommended version by upstream for distributions to include, while the opensync-0.3x is still considered experimental and is discouraged from packaging by upstream. Opensync-0.22 works fine with kitchensync (universe) and reasonably well with multisync0.90 and msynctool (both universe as well). Even though no support for Windows Mobile or Blackberry devices is available in hardy, shipping opensync-0.22 (and the accompayning plugins in universe) will give hardy (KDE) users a reasonable syncing experience, compared to the last couple of Ubuntu releases.

Conducted testing:

The opensync_0.22-2 package has been made available as hardy packages (together with the plugins and multisync-gui) as PPA at

deb http://ppa.launchpad.net/debian-opensync/ubuntu hardy main

for several weeks. User testing has been unconclusive (some success reports, one failure report). I have verified that kitchensync still works after upgrading to opensync-0.22. Partial upgrades have not been extensively tested I believe.

If this FFE is getting accepted, FFEs for the plugins in universe should get issued accordingly.

Diffstat output (136 files changed, 10434 insertions(+), 34491 deletions(-)) is being attached.

Michael Banck (mbanck) wrote :
Steve Langasek (vorlon) wrote :

I'm inclined to ok this in spite of the lateness of the change, but for the plugins we also need sign-off from motu-release; subscribing them now.

Do you have a list of the affected source packages for the plugins?

Luke Yelavich (themuso) wrote :

+1 from me. I have a mobile that doesn't work with 0.19, so syncing with it for me would be something I'd like.

Ack

...... Original Message .......
On Thu, 10 Apr 2008 23:19:39 -0000 Steve Langasek
<email address hidden> wrote:
>I'm inclined to ok this in spite of the lateness of the change, but for
>the plugins we also need sign-off from motu-release; subscribing them
>now.
>
>Do you have a list of the affected source packages for the plugins?
>
>--
>[FFe request] Please sync opensync_0.22-2 from Debian unstable (main)
>https://bugs.launchpad.net/bugs/214083
>You received this bug notification because you are a member of MOTU
>Release Team, which is a direct subscriber.
>

Changed in opensync:
status: New → Confirmed
Steve Langasek (vorlon) wrote :

Getting binaries for hardy...
[Updating] opensync (0.19-1.2ubuntu1 [Ubuntu] < 0.22-2 [Debian])
 * Trying to add opensync...
  - <opensync_0.22-2.diff.gz: downloading from http://ftp.debian.org/debian/>
  - <opensync_0.22.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
  - <opensync_0.22-2.dsc: downloading from http://ftp.debian.org/debian/>
I: opensync [main] -> libopensync0-dbg_0.19-1.2ubuntu1 [main].
I: opensync [main] -> libopensync0-dev_0.19-1.2ubuntu1 [main].
I: opensync [main] -> python-opensync_0.19-1.2ubuntu1 [universe].
I: opensync [main] -> libopensync0_0.19-1.2ubuntu1 [main].
I: opensync [main] -> opensyncutils_0.19-1.2ubuntu1 [universe].

Changed in opensync:
status: Confirmed → Fix Released
Steve Langasek (vorlon) wrote :

The following plugin packages have also been synced:

  libopensync-plugin-file
  libopensync-plugin-irmc
  libopensync-plugin-palm
  libopensync-plugin-syncml

But several other packages require merges (or reviews to confirm that they can be synced). Tasks opened for each of these plugin packages.

Steve Langasek (vorlon) on 2008-04-11
Changed in libopensync-plugin-evolution2:
assignee: nobody → vorlon
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libopensync-plugin-evolution2 - 0.22-2ubuntu1

---------------
libopensync-plugin-evolution2 (0.22-2ubuntu1) hardy; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - debian/rules: don't invoke dh_python(1).
    LP: #214083.
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

libopensync-plugin-evolution2 (0.22-2) unstable; urgency=low

  * debian/control (Build-Depends): Require libopensync0-dev (>= 0.22-1).

libopensync-plugin-evolution2 (0.22-1) unstable; urgency=low

  * New upstream release.

 -- Steve Langasek <email address hidden> Fri, 11 Apr 2008 06:27:48 +0000

Changed in libopensync-plugin-evolution2:
status: In Progress → Fix Released
Steve Langasek (vorlon) wrote :

the 1ubuntu1 of -kdepim was a false-positive, this should've really been -1build1. Synced now:

Getting binaries for hardy...
[Updating] libopensync-plugin-kdepim (0.19-1ubuntu1 [Ubuntu] < 0.22-3 [Debian])
 * Trying to add libopensync-plugin-kdepim...
  - <libopensync-plugin-kdepim_0.22-3.diff.gz: downloading from http://ftp.debian.org/debian/>
  - <libopensync-plugin-kdepim_0.22-3.dsc: downloading from http://ftp.debian.org/debian/>
  - <libopensync-plugin-kdepim_0.22.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
I: libopensync-plugin-kdepim [universe] -> opensync-plugin-kdepim_0.19-1ubuntu1 [universe].

Changed in libopensync-plugin-kdepim:
status: New → Fix Released
Steve Langasek (vorlon) wrote :

resolved for libopensync-plugin-sunbird by the subtle method of removing the package from the archive, since it's not compatible with current versions of sunbird.

Changed in libopensync-plugin-sunbird:
status: New → Fix Released
Steve Langasek (vorlon) on 2008-04-12
Changed in libopensync-plugin-google-calendar:
assignee: nobody → vorlon
Michael Banck (mbanck) wrote :

For google-calendar, it is probably best to take the 1-line patch from 0.19-2ubuntu3; basing it on 0.22-4 (0.22-5 should be disregarded, it was a bogus/wrong upload).

The real fix appears to be a 3-line port to python-4suite-xml, however an upstream bug in python-4suite-xml makes that impossible for hardy.

Michael Banck (mbanck) wrote :

Turned it was not an upstream bug in 4suite, John L. Clark completed the port to 4suite (see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=468601#32 ), so syncing (or merging) opensync-plugin-google-calendar_0.22-6 (just uploaded containing John's patch) should work as well.

Steve Langasek (vorlon) wrote :

Getting binaries for hardy...
[Updating] libopensync-plugin-google-calendar (0.19-2ubuntu3 [Ubuntu] < 0.22-6 [Debian])
 * Trying to add libopensync-plugin-google-calendar...
  - <libopensync-plugin-google-calendar_0.22-6.dsc: cached>
  - <libopensync-plugin-google-calendar_0.22.orig.tar.gz: cached>
  - <libopensync-plugin-google-calendar_0.22-6.diff.gz: cached>
I: libopensync-plugin-google-calendar [universe] -> opensync-plugin-google-calendar_0.19-2ubuntu3 [universe].

Changed in libopensync-plugin-google-calendar:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.