openswan ftbfs in karmic

Bug #436540 reported by Bhavani Shankar on 2009-09-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openswan (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openswan

Package is ftbfs due to gcc in karmic

https://edge.launchpad.net/ubuntu/+source/openswan/1:2.6.22+dfsg-1/+build/1093145

Bhavani Shankar (bhavi) wrote :
Bhavani Shankar (bhavi) wrote :
Changed in openswan (Ubuntu):
status: New → Confirmed
StefanPotyra (sistpoty) wrote :

Hi,

nope, sorry, that's not good:

"/build/buildd/openswan-2.6.22+dfsg/programs/tncfg/tncfg.c:362: error: dereferencing pointer 'shc' does break strict-aliasing rules"

this should get fixed either with -fno-strict-aliasing or even better by an explicit cast to void * (and then to struct ipsecwhatever) in line 179.

Short explanation: In C, it's only legal to cast a pointer of one type to another, if it is a char * or a void *. gcc makes use of this knowledge in its alias anylsis (can one pointer refer to the same thing as another pointer), and hence has the possibility to assume that these two pointers are never the same. This can hence result in wrong optimizations.

Can you respin the debdiff please? (if there are other errors, it might of course be a good idea to disable Werror nonetheless).

Thanks,
     Stefan.

Bhavani Shankar (bhavi) wrote :

Okay stefan , thanks for pointing out mistake of my notion of overriding the errors here is the modified diff

Regards

StefanPotyra (sistpoty) wrote :

Nice, thanks. Because I just saw it, I've added -1.1 from unstable before applying your patch. Hope that's ok with you. Uploading.

Changed in openswan (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openswan - 1:2.6.22+dfsg-1.1ubuntu1

---------------
openswan (1:2.6.22+dfsg-1.1ubuntu1) karmic; urgency=low

  * Build with -fno-strict-aliasing against gcc 4.4 fix ftbfs LP: #436540

openswan (1:2.6.22+dfsg-1.1) unstable; urgency=low

  * Non-maintainer upload.
  * Fix LSB header in programs/setup/setup.in to fix init.d script
    (Closes: #537335).

 -- Bhavani Shankar <email address hidden> Sat, 26 Sep 2009 05:33:44 +0530

Changed in openswan (Ubuntu):
status: Fix Committed → Fix Released
Bhavani Shankar (bhavi) wrote :

Thanks for quick sponsoring :)

Regards

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers