Default connection parameters fails when running dbsync

Bug #1451134 reported by Emilien Macchi on 2015-05-03
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
openstack-trove (Ubuntu)
High
James Page
Vivid
High
Unassigned

Bug Description

[Impact]
Trove is not installable with default configuration

[Test Case]
sudo apt-get install trove-common

[Regression Potential]
Minimal - just fixing up path for sqlite db

[Original bug report]
Most of the packages are running dbsync during the installation of trove.
When doing the dbsync the script will look at trove.conf for connection (previously sql_connection), which is default to sqlite:///trove_test.sqlite.

Here is the output when installing Trove on Ubuntu: http://paste.openstack.org/show/214767/

If we change the default value in trove/common/cfg.py, it will not lead to any issue if we put the right path.

Fix proposed to branch: master
Review: https://review.openstack.org/179626

Changed in trove:
assignee: nobody → Emilien Macchi (emilienm)
status: New → In Progress
affects: trove → openstack-trove (Ubuntu)
Changed in openstack-trove (Ubuntu):
assignee: Emilien Macchi (emilienm) → nobody
status: In Progress → New

Change abandoned by Emilien Macchi (<email address hidden>) on branch: master
Review: https://review.openstack.org/179626
Reason: I think this is something that needs to be solved in packaging.

James Page (james-page) wrote :

connection = sqlite:///trove_test.sqlite

->

connection = sqlite://var/lib/trove/trove_test.sqlite

Changed in openstack-trove (Ubuntu):
importance: Undecided → High
status: New → Triaged
James Page (james-page) on 2015-05-07
description: updated
Changed in openstack-trove (Ubuntu):
status: Triaged → In Progress
assignee: nobody → James Page (james-page)

Hello Emilien, or anyone else affected,

Accepted openstack-trove into vivid-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/openstack-trove/2015.1.0-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in openstack-trove (Ubuntu Vivid):
status: New → Fix Committed
tags: added: verification-needed
James Page (james-page) on 2015-05-07
Changed in openstack-trove (Ubuntu):
status: In Progress → New
Changed in openstack-trove (Ubuntu Vivid):
importance: Undecided → High
status: Fix Committed → Triaged
status: Triaged → Fix Committed
Pundaleek P Belamge (pbelamge) wrote :
Download full text (4.0 KiB)

After this change [ connection = sqlite://var/lib/trove/trove_test.sqlite ], we are getting below error now. Looks like we need to change this line to - [ connection = sqlite:////var/lib/trove/trove_test.sqlite ]

Installing new version of config file /etc/trove/api-paste.ini ...
addgroup: The group `trove' already exists as a system group. Exiting.
The system user `trove' already exists. Exiting.
Command failed, please check log for more info.
2015-05-12 08:14:19.101 10140 CRITICAL root [-] ArgumentError: Invalid SQLite URL: sqlite://var/lib/trove/trove_test.sqlite
Valid SQLite URL forms are:
 sqlite:///:memory: (or, sqlite://)
 sqlite:///relative/path/to/file.db
 sqlite:////absolute/path/to/file.db
2015-05-12 08:14:19.101 10140 TRACE root Traceback (most recent call last):
2015-05-12 08:14:19.101 10140 TRACE root File "/usr/bin/trove-manage", line 10, in <module>
2015-05-12 08:14:19.101 10140 TRACE root sys.exit(main())
2015-05-12 08:14:19.101 10140 TRACE root File "/usr/lib/python2.7/dist-packages/trove/cmd/manage.py", line 177, in main
2015-05-12 08:14:19.101 10140 TRACE root Commands().execute()
2015-05-12 08:14:19.101 10140 TRACE root File "/usr/lib/python2.7/dist-packages/trove/cmd/manage.py", line 57, in execute
2015-05-12 08:14:19.101 10140 TRACE root exec_method(**kwargs)
2015-05-12 08:14:19.101 10140 TRACE root File "/usr/lib/python2.7/dist-packages/trove/cmd/manage.py", line 42, in db_sync
2015-05-12 08:14:19.101 10140 TRACE root self.db_api.db_sync(CONF, repo_path=repo_path)
2015-05-12 08:14:19.101 10140 TRACE root File "/usr/lib/python2.7/dist-packages/trove/db/sqlalchemy/api.py", line 103, in db_sync
2015-05-12 08:14:19.101 10140 TRACE root migration.db_sync(options, version, repo_path)
2015-05-12 08:14:19.101 10140 TRACE root File "/usr/lib/python2.7/dist-packages/trove/db/sqlalchemy/migration.py", line 118, in db_sync
2015-05-12 08:14:19.101 10140 TRACE root _version_control(options, repo_path)
2015-05-12 08:14:19.101 10140 TRACE root File "/usr/lib/python2.7/dist-packages/trove/db/sqlalchemy/migration.py", line 106, in _version_control
2015-05-12 08:14:19.101 10140 TRACE root return versioning_api.version_control(sql_connection, repo_path)
2015-05-12 08:14:19.101 10140 TRACE root File "<string>", line 2, in version_control
2015-05-12 08:14:19.101 10140 TRACE root File "/usr/lib/python2.7/dist-packages/migrate/versioning/util/__init__.py", line 156, in with_engine
2015-05-12 08:14:19.101 10140 TRACE root engine = construct_engine(url, **kw)
2015-05-12 08:14:19.101 10140 TRACE root File "/usr/lib/python2.7/dist-packages/migrate/versioning/util/__init__.py", line 141, in construct_engine
2015-05-12 08:14:19.101 10140 TRACE root return create_engine(engine, **kwargs)
2015-05-12 08:14:19.101 10140 TRACE root File "/usr/lib/python2.7/dist-packages/sqlalchemy/engine/__init__.py", line 362, in create_engine
2015-05-12 08:14:19.101 10140 TRACE root return strategy.create(*args, **kwargs)
2015-05-12 08:14:19.101 10140 TRACE root File "/usr/lib/python2.7/dist-packages/sqlalchemy/engine/strategies.py", line 82, in create
2015-05-12 08:14:19.101 10140 TRACE root (cargs, ...

Read more...

James Page (james-page) on 2015-05-13
tags: added: verification-failed
removed: verification-needed
Chris J Arges (arges) wrote :

Hello Emilien, or anyone else affected,

Accepted openstack-trove into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/openstack-trove/2015.1.0-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-failed
tags: added: verification-needed
James Page (james-page) on 2015-05-13
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openstack-trove - 2015.1.0-0ubuntu1.2

---------------
openstack-trove (2015.1.0-0ubuntu1.2) vivid; urgency=medium

  * d/p/patch-default-config-file.patch: Fix to ensure that path to
    sqlite database is fully specified (LP: #1451134).

 -- James Page <email address hidden> Wed, 13 May 2015 11:55:48 +0100

Changed in openstack-trove (Ubuntu):
status: New → Fix Released
Pundaleek P Belamge (pbelamge) wrote :

Yes, now it works, thank you

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openstack-trove - 2015.1.0-0ubuntu1.2

---------------
openstack-trove (2015.1.0-0ubuntu1.2) vivid; urgency=medium

  * d/p/patch-default-config-file.patch: Fix to ensure that path to
    sqlite database is fully specified (LP: #1451134).

 -- James Page <email address hidden> Wed, 13 May 2015 11:55:48 +0100

Changed in openstack-trove (Ubuntu Vivid):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for openstack-trove has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in trove:
importance: Undecided → Medium
Changed in trove:
assignee: nobody → khushbu (khushbuparakh)
Changed in trove:
assignee: khushbu (khushbuparakh) → nobody
Craig Vyvial (cp16net) wrote :

Marked this bug as invalid because this is just a config change. Let me know if there are questions raised. Thanks.

Changed in trove:
status: New → Invalid
no longer affects: trove
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers