libssl0.9.8 config asking me 'which services should be restarted to make them use the new lbraries?'

Bug #91814 reported by Stuart Bishop on 2007-03-13
26
Affects Status Importance Assigned to Milestone
openssl (Ubuntu)
Medium
Luke Yelavich

Bug Description

Binary package hint: update-manager

This seems a rather pointless question to ask the user giving we are doing an OS upgrade and we have been told to shut down all the running programs.

Related branches

Michael Vogt (mvo) on 2007-03-13
Changed in update-manager:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Tollef Fog Heen (tfheen) wrote :

Bringing milestone forward

Paul Sladen (sladen) wrote :

Just hit this on an upgrade:

 * Services to restart in make them use the new libraries
 * [ntp ] [Help]

This question shouldn't be appearing at all; "mummy, what's 'ntp'?".

Paul Sladen (sladen) wrote :

Target for 8.04 since it clearly got missed for 7.04...

Changed in openssl:
milestone: ubuntu-7.04 → ubuntu-8.04
Colin Watson (cjwatson) wrote :

Luke, can you have a look at this? Perhaps lowering the priority of the question will be sufficient, though it might be worth doing a cursory check that there's nothing there that could seriously break on a desktop system if automatically restarted. I would also recommend triggering the stock "reboot soon" desktop notification.

Changed in openssl:
assignee: nobody → themuso
James Westby (james-w) wrote :

Hi,

bug 182446 appears to be a duplicate of this bug,
or at least very similar, it may be a different version of
openssl.

https://bugs.edge.launchpad.net/ubuntu/+source/openssl/+bug/182446

Thanks,

James

Michael Vogt (mvo) wrote :

We had a similar upgrade issue with libc6. Currently there are two environment variables that may be interessting:
RELEASE_UPGRADE_IN_PROGRESS=1
RELEASE_UPGRADE_MODE={desktop,server}

The libc6.preinst looks like this:
...
                  db_subst glibc/upgrade services $services
                    if [ "$RELEASE_UPGRADE_MODE" = desktop ]; then
                        db_input medium glibc/upgrade || true
                    else
                        db_input critical glibc/upgrade || true
                    fi
...

We can probably use a similar solution. If the default is to restart, we need to be careful that nothing on the desktop breaks due to the restart.

Kees Cook (kees) wrote :

Still seeing this, Gutsy -> Hardy upgrade.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openssl - 0.9.8g-4ubuntu3

---------------
openssl (0.9.8g-4ubuntu3) hardy; urgency=low

  * Use a different priority for libssl0.9.8/restart-services depending on whether
    a desktop, or server dist-upgrade is being performed. (LP: #91814)
  * Display a system restart required notification bubble on libssl0.9.8 upgrade.

 -- Luke Yelavich <email address hidden> Tue, 22 Apr 2008 10:50:53 +1000

Changed in openssl:
status: Confirmed → Fix Released
Milan Bouchet-Valat (nalimilan) wrote :

I like seeing this kind of long-standing issues fixed. Thanks - we're not only here to complain!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers