Comment 3 for bug 686825

Andreas Olsson (andol) wrote :

This is by the way where it was introduced:

  openssl (0.9.8g-4ubuntu3) hardy; urgency=low

    * Use a different priority for libssl0.9.8/restart-services depending on whether
      a desktop, or server dist-upgrade is being performed. (LP: #91814)
    * Display a system restart required notification bubble on libssl0.9.8 upgrade.

   -- Luke Yelavich <email address hidden> Tue, 22 Apr 2008 10:50:53 +1000

andreas@stilgar:~/temp$ debdiff openssl_0.9.8g-4ubuntu2.dsc openssl_0.9.8g-4ubuntu3.dsc | grep -i reboot
+ [ -x /usr/share/update-notifier/notify-reboot-required ] && /usr/share/update-notifier/notify-reboot-required
andreas@stilgar:~/temp$

/usr/share/update-notifier/notify-reboot-required belongs to the update-notifier-common package.