OpenSSL/DTLS compatibility

Bug #516318 reported by centy on 2010-02-02
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
openssl (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by centy

Bug Description

openssl 0.9.8l contains a compatibility fix for DTLS communication with Cisco ASA peers. The package openconnect requires this fix in order to meaningfully implement DTLS.

The version of openssl in Ubuntu Lucid is currently 0.9.8k. Please apply the following patch:

http://cvs.openssl.org/chngview?cn=18037

It should apply cleanly to 0.9.8k and is included in upstream's 0.9.8l.

This fix would greatly increase the usefulness of the package openconnect.

Related branches

Marc D. (koshy) on 2010-02-12
description: updated
Marc D. (koshy) on 2010-02-12
description: updated
dwmw2 (dwmw2) wrote :

0.9.8l ended up being a panic release with a single bugfix. I think the first 0.9.8 release which includes the DTLS compatibility patch is 0.9.8m. But 0.9.8n is out now, so just upgrading to that would be best.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openssl - 0.9.8k-7ubuntu7

---------------
openssl (0.9.8k-7ubuntu7) lucid; urgency=low

  * debian/patches/dtls-compatibility.patch: backport dtls compatibility
    code from 0.9.8m to fix interopability. (LP: #516318)
 -- Marc Deslauriers <email address hidden> Fri, 26 Mar 2010 08:31:09 -0400

Changed in openssl (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers