Comment 3 for bug 257464

I have a fix:

1. Download libssl: apt-get source libssl0.9.8
2. Compile it: cd <to packge>; ./config shared; make
3. Move package to the right place: cd /usr/lib/i686/cmov; mv libssl.0.9.8 libssl.0.9.8.orig, cp <package>/libssl.so.0.9.8 /usr/lib/i686/cmov

Google Earth works for me now.