Change in OpenSSL triggers bug in XMLTooling

Bug #1553137 reported by Kolargol00 on 2016-03-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openssl (Ubuntu)
Undecided
Unassigned
xmltooling (Ubuntu)
Undecided
Unassigned

Bug Description

A recent change in the openssl package provided by Ubuntu triggers a bug in xmltooling. The change was introduced in openssl 1.0.1f-1ubuntu2.17 (14.04) and 1.0.1-4ubuntu5.34 (12.04) when releasing for USN-2913-3 [1]. Patch alt-cert-chains-7.patch (found in [2,3]) changes the intended use of the OpenSSL API and xmltooling was using it wrongly. This is fixed in upstream xmltooling version 1.5.6 [4]. Please backport the fix from 1.5.6 or upgrade the xmltooling package to 1.5.6.

[1] http://www.ubuntu.com/usn/usn-2913-3/
[2] https://launchpadlibrarian.net/236983031/openssl_1.0.1-4ubuntu5.33_1.0.1-4ubuntu5.34.diff.gz
[3] https://launchpadlibrarian.net/236982637/openssl_1.0.1f-1ubuntu2.16_1.0.1f-1ubuntu2.17.diff.gz
[4] https://issues.shibboleth.net/jira/browse/CPPXT-105

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: libxmltooling6 (not installed)
ProcVersionSignature: Ubuntu 3.13.0-79.123-generic 3.13.11-ckt33
Uname: Linux 3.13.0-79-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.19
Architecture: amd64
CurrentDesktop: MATE
Date: Fri Mar 4 11:43:47 2016
InstallationDate: Installed on 2015-02-04 (394 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
SourcePackage: xmltooling
UpgradeStatus: No upgrade log present (probably fresh install)

Kolargol00 (kolargol00) wrote :
Simon Déziel (sdeziel) wrote :

Xenial ships 1.5.6-2 so marking as fix released.

Changed in xmltooling (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments