Ubuntu

Add basic arm64 support into OpenSSL

Reported by Wookey on 2013-01-20
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro AArch64 cross-distro work
Medium
Unassigned
Linaro OpenEmbedded
Medium
Marcin Juszkiewicz
OpenSSL
Fix Released
Unknown
openssl (Ubuntu)
Undecided
Unassigned

Bug Description

Openssl doesn't build for arm without having a suitable config line in its ./configure.

This patch adds one, with assembler turned off, which allows the package to build.

Related branches

Wookey (wookey) wrote :

The attachment "openssl_1.0.1c-4ubuntu2-arm64support.patch" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Riku Voipio (riku-voipio) wrote :

The patch is probably broken.

it should have SIXTY_FOUR_BIT instead of BN_LLONG

Riku Voipio (riku-voipio) wrote :

Updated patch - now with 64bit pointers.

Changed in openssl (Ubuntu):
status: New → Confirmed
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in openssl (Ubuntu):
status: Confirmed → In Progress
assignee: Dmitrijs Ledkovs (xnox) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openssl - 1.0.1c-4ubuntu3

---------------
openssl (1.0.1c-4ubuntu3) raring; urgency=low

  * Add basic arm64 support (no assembler) (LP: #1102107)
 -- Wookey <email address hidden> Sun, 20 Jan 2013 17:30:15 +0000

Changed in openssl (Ubuntu):
status: In Progress → Fix Released
Marcin Juszkiewicz (hrw) on 2013-02-12
summary: - Add basic arm64 support
+ Add basic arm64 support into OpenSSL
Marcin Juszkiewicz (hrw) on 2013-02-13
Changed in linaro-oe:
status: New → Triaged
assignee: nobody → Marcin Juszkiewicz (hrw)
Marcin Juszkiewicz (hrw) wrote :

Just checked - OE has same line - since October.

Changed in linaro-oe:
status: Triaged → Fix Released
Fathi Boudra (fboudra) on 2013-02-14
Changed in linaro-oe:
milestone: none → 13.01
milestone: 13.01 → 12.12
Changed in linaro-aarch64:
status: New → Fix Released
Ard Biesheuvel (ard-biesheuvel) wrote :

In fact, this still does not look correct: it should read SIXTY_FOUR_BIT_LONG not SIXTY_FOUR_BIT (the latter is intended for Win64 style LLP64 model)

Riku Voipio (riku-voipio) wrote :

Hi Ard,

Thanks, good catch - apparently we have the correct item OpenEmbedded but the Ubuntu patch has wrong one. Not sure how it ended up there. Updated patched attached.

We would still need someone to write the assembler code to take advantage of the ARMv8 AES and SHA instructions.

Changed in linaro-aarch64:
importance: Undecided → Medium
Changed in linaro-oe:
importance: Undecided → Medium
Ard Biesheuvel (ard-biesheuvel) wrote :

Hi Riku,

I am in touch with the OpenSSL maintainer who authored most of the assembler code in OpenSSL (for all architectures).

ARMv8 versions will likely be done in collaboration with him, including (NEON) accelerated versions of SHA and AES (as the crypto extensions on v8 are optional). I will keep you informed about when any of this is expected to appear upstream.

Changed in openssl:
status: Unknown → New
Changed in openssl:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.