openssh in natty breaks monkeysphere

Bug #793115 reported by Christian Juner on 2011-06-05
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
openssh (Debian)
Fix Released
Unknown
openssh (Ubuntu)
Low
Unassigned

Bug Description

Monkeysphere allows you to store your ssh keys in your gpg key. `monkeysphere s` should export your ssh key to the ssh-agent. This does not work in natty because of a change introduced in openssh (`ssh-add -l` lists nothing).

The bug is already fixed in Debian (see <http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=614897>). Suggested fix: pull patch / current openssh version from Debian.

I have verified that the version in Debian built on my machine fixes the bug for me.

Clint Byrum (clint-fewbar) wrote :

Marking Triaged/Low since multiple people are affected. Hopefully will be fixed on the next merge.

Changed in openssh (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in openssh (Debian):
status: Unknown → Fix Released

(question) Will that happen for natty/natty-proposed or will the fix only be included in the next Ubuntu release? The latter would be quite a disappointment considering the problem makes the client side of monkeysphere unusable for everyone running natty (without building their own openssh packages).

tags: added: breaks-monkeysphere natty patch-accepted-debian regression-release ssh-agent
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.