GSSAPI Cascading Credentials support

Bug #416958 reported by Björn Torkelsson on 2009-08-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openssh (Ubuntu)
Wishlist
Colin Watson

Bug Description

Please upgrade the patch set from Simon Wilkinson for support of Cascading Credentials (and also updates to GSSAPI key exchange)

See: http://www.sxw.org.uk/computing/patches/openssh.html

ProblemType: Bug
Architecture: amd64
Date: Fri Aug 21 15:47:12 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: openafs
Package: openssh-client 1:5.1p1-6ubuntu1
ProcEnviron:
 LANGUAGE=en_DK.UTF-8
 LANG=en_DK.UTF-8
 SHELL=/bin/bash
 LC_NUMERIC=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-6.25-generic
SourcePackage: openssh
Uname: Linux 2.6.31-6-generic x86_64

Related branches

Björn Torkelsson (torkel) wrote :
Andreas Olsson (andol) on 2009-10-04
Changed in openssh (Ubuntu):
importance: Undecided → Wishlist
Chuck Short (zulcss) on 2009-10-14
Changed in openssh (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) on 2010-01-04
Changed in openssh (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package openssh - 1:5.2p1-1ubuntu1

---------------
openssh (1:5.2p1-1ubuntu1) lucid; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Add support for registering ConsoleKit sessions on login.
    - Drop openssh-blacklist and openssh-blacklist-extra to Suggests; they
      take up a lot of CD space, and I suspect that rolling them out in
      security updates has covered most affected systems now.
  * Convert to Upstart. The init script is still here for the benefit of
    people running sshd in chroots. Note that the Upstart job does not
    support /etc/default/ssh, because it's much more straightforward to edit
    the job (/etc/init/ssh.conf) than it was to edit the init script.

openssh (1:5.2p1-1) unstable; urgency=low

  * New upstream release (closes: #536182). Yes, I know 5.3p1 has been out
    for a while, but there's no GSSAPI patch available for it yet.
    - Change the default cipher order to prefer the AES CTR modes and the
      revised "arcfour256" mode to CBC mode ciphers that are susceptible to
      CPNI-957037 "Plaintext Recovery Attack Against SSH".
    - Add countermeasures to mitigate CPNI-957037-style attacks against the
      SSH protocol's use of CBC-mode ciphers. Upon detection of an invalid
      packet length or Message Authentication Code, ssh/sshd will continue
      reading up to the maximum supported packet length rather than
      immediately terminating the connection. This eliminates most of the
      known differences in behaviour that leaked information about the
      plaintext of injected data which formed the basis of this attack
      (closes: #506115, LP: #379329).
    - ForceCommand directive now accepts commandline arguments for the
      internal-sftp server (closes: #524423, LP: #362511).
    - Add AllowAgentForwarding to available Match keywords list (closes:
      #540623).
    - Make ssh(1) send the correct channel number for
      SSH2_MSG_CHANNEL_SUCCESS and SSH2_MSG_CHANNEL_FAILURE messages to
      avoid triggering 'Non-public channel' error messages on sshd(8) in
      openssh-5.1.
    - Avoid printing 'Non-public channel' warnings in sshd(8), since the
      ssh(1) has sent incorrect channel numbers since ~2004 (this reverts a
      behaviour introduced in openssh-5.1; closes: #496017).
    - Disable nonfunctional ssh(1) ~C escape handler in multiplex slave
      connections (closes: #507541).
    - Fix "whitepsace" typo in ssh_config(5) (closes: #514313, LP: #303835).
  * Update to GSSAPI patch from
    http://www.sxw.org.uk/computing/patches/openssh-5.2p1-gsskex-all-20090726.patch,
    including cascading credentials support (LP: #416958).
  * Use x11.pc when compiling/linking gnome-ssh-askpass2 (closes: #555951).
  * Moved to bzr.debian.org; add Vcs-Bzr and Vcs-Browser control fields.
  * Add debian/README.source with instructions on bzr handling.
  * Make ChrootDirectory work with SELinux (thanks, Russell Coker; closes:
    #556644).
  * Initialise sc to NULL in ssh_selinux_getctxbyname (thanks, Václav Ovsík;
    closes: #498684).
  * Don't duplicate backslashes when displaying server banner (thanks,
    Michał Górny; closes: #505378, LP...

Read more...

Changed in openssh (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers