Typo in ssh_config man page

Bug #303835 reported by kenrose on 2008-12-01
6
Affects Status Importance Assigned to Milestone
portable OpenSSH
Invalid
Unknown
openssh (Debian)
Fix Released
Unknown
openssh (Ubuntu)
Low
Colin Watson

Bug Description

Binary package hint: openssh-client

Using Ubuntu 8.10.

In ssh_config(5), there is a typo in the Description section regarding the Host option. It currently reads:

"If more than one pattern is provided, they should be separated by whitepsace".

The last word, whitespace, is spelled incorrectly.

This occurs in the openssh-client package, and the affected file is:

/usr/share/man/man5/ssh_config.5.gz

The above sentence is new in Ubuntu 8.10. In Ubuntu 8.04, the above sentence did not appear.

Trey Brown (trey.brown) wrote :

I can confirm this bug, using an up to date Ubuntu 8.10, the typo is on line 51 of the man page

Changed in openssh:
status: New → Confirmed
Changed in openssh (Ubuntu):
assignee: nobody → David Stansby (dstansby)
status: Confirmed → In Progress

Here's a patch.

Changed in openssh (Ubuntu):
assignee: David Stansby (dstansby) → nobody
status: In Progress → Invalid

Why mark your bug invalid right after providing a patch? That's an
excellent way to cause it to be ignored. :-)

Anyway, please send this upstream (bugzilla.mindrot.org). It isn't
usually worth carrying trivial manual page patches in the Ubuntu openssh
package; better to get them upstream so that we don't have to maintain
them.

 status triaged
 importance low

Changed in openssh (Ubuntu):
importance: Undecided → Low
status: Invalid → Triaged

Sorry about that. Must have pressed the wrong option :S I've sent it upstream now and added a watch on this bug.

Changed in openssh:
status: Unknown → Confirmed

Created an attachment (id=1645)
Debian patch that correctst the problem

Binary package hint: openssh-client

Using Ubuntu 8.10.

In ssh_config(5), there is a typo in the Description section regarding
the Host option. It currently reads:

"If more than one pattern is provided, they should be separated by
whitepsace".

The last word, whitespace, is spelled incorrectly.

This occurs in the openssh-client package, and the affected file is:

/usr/share/man/man5/ssh_config.5.gz

Thanks, but this is already fixed in 5.2:

$ cvs log ssh_config.5
[...]
revision 1.112
date: 2008/11/03 08:17:33; author: djm; state: Exp; lines: +3 -3
   - <email address hidden> 2008/08/02 04:29:51
     [ssh_config.5]
     whitepsace -> whitespace. From Matthew Clarke via bugs@.

Changed in openssh:
status: Confirmed → Invalid
Colin Watson (cjwatson) wrote :

OK, so according to the upstream bug I basically need to pull my finger out and package 5.2. That isn't really something anyone can help with at present, since my version control is still regrettably in CVS; getting it into bzr is on my list, but preserving the history is complicated ...

Mass move of RESOLVED bugs to CLOSED now that 5.3 is out.

Colin Watson (cjwatson) on 2010-01-04
Changed in openssh (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package openssh - 1:5.2p1-1ubuntu1

---------------
openssh (1:5.2p1-1ubuntu1) lucid; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Add support for registering ConsoleKit sessions on login.
    - Drop openssh-blacklist and openssh-blacklist-extra to Suggests; they
      take up a lot of CD space, and I suspect that rolling them out in
      security updates has covered most affected systems now.
  * Convert to Upstart. The init script is still here for the benefit of
    people running sshd in chroots. Note that the Upstart job does not
    support /etc/default/ssh, because it's much more straightforward to edit
    the job (/etc/init/ssh.conf) than it was to edit the init script.

openssh (1:5.2p1-1) unstable; urgency=low

  * New upstream release (closes: #536182). Yes, I know 5.3p1 has been out
    for a while, but there's no GSSAPI patch available for it yet.
    - Change the default cipher order to prefer the AES CTR modes and the
      revised "arcfour256" mode to CBC mode ciphers that are susceptible to
      CPNI-957037 "Plaintext Recovery Attack Against SSH".
    - Add countermeasures to mitigate CPNI-957037-style attacks against the
      SSH protocol's use of CBC-mode ciphers. Upon detection of an invalid
      packet length or Message Authentication Code, ssh/sshd will continue
      reading up to the maximum supported packet length rather than
      immediately terminating the connection. This eliminates most of the
      known differences in behaviour that leaked information about the
      plaintext of injected data which formed the basis of this attack
      (closes: #506115, LP: #379329).
    - ForceCommand directive now accepts commandline arguments for the
      internal-sftp server (closes: #524423, LP: #362511).
    - Add AllowAgentForwarding to available Match keywords list (closes:
      #540623).
    - Make ssh(1) send the correct channel number for
      SSH2_MSG_CHANNEL_SUCCESS and SSH2_MSG_CHANNEL_FAILURE messages to
      avoid triggering 'Non-public channel' error messages on sshd(8) in
      openssh-5.1.
    - Avoid printing 'Non-public channel' warnings in sshd(8), since the
      ssh(1) has sent incorrect channel numbers since ~2004 (this reverts a
      behaviour introduced in openssh-5.1; closes: #496017).
    - Disable nonfunctional ssh(1) ~C escape handler in multiplex slave
      connections (closes: #507541).
    - Fix "whitepsace" typo in ssh_config(5) (closes: #514313, LP: #303835).
  * Update to GSSAPI patch from
    http://www.sxw.org.uk/computing/patches/openssh-5.2p1-gsskex-all-20090726.patch,
    including cascading credentials support (LP: #416958).
  * Use x11.pc when compiling/linking gnome-ssh-askpass2 (closes: #555951).
  * Moved to bzr.debian.org; add Vcs-Bzr and Vcs-Browser control fields.
  * Add debian/README.source with instructions on bzr handling.
  * Make ChrootDirectory work with SELinux (thanks, Russell Coker; closes:
    #556644).
  * Initialise sc to NULL in ssh_selinux_getctxbyname (thanks, Václav Ovsík;
    closes: #498684).
  * Don't duplicate backslashes when displaying server banner (thanks,
    Michał Górny; closes: #505378, LP...

Read more...

Changed in openssh (Ubuntu):
status: Fix Committed → Fix Released
Changed in openssh (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.