sshd does not pass DISPLAY even if adviced to forward X11 connections

Bug #1291696 reported by Thomas Schweikle on 2014-03-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openssh (Ubuntu)
High
Unassigned

Bug Description

sshd does not set DISPLAY-variable even if using "ssh -l user -X <serveraddr>" connecting the server.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: openssh-server 1:6.5p1-6
ProcVersionSignature: Ubuntu 3.13.0-17.37-generic 3.13.6
Uname: Linux 3.13.0-17-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
Date: Thu Mar 13 01:45:19 2014
InstallationDate: Installed on 2014-01-31 (40 days ago)
InstallationMedia: Ubuntu-Server 13.10 "Saucy Salamander" - Release amd64 (20131016)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: openssh
UpgradeStatus: Upgraded to trusty on 2014-01-31 (40 days ago)

Thomas Schweikle (tps) wrote :
Anders (eddiedog988) on 2014-03-13
Changed in openssh (Ubuntu):
status: New → Confirmed

It renders essential functionality of the package (or a dependent one) broken.

Changed in openssh (Ubuntu):
importance: Undecided → High
Dmitry Mn (progscrt) wrote :

I add In /etc/ssh/sshd_config

X11UseLocalhost no

This solve X11 forward for me.

This params allow any host connect and forward X11

Hope this help

David (ochoadavid) wrote :

I was also affected. But the solution posted by Dmitry Mn solved it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers