fails to login with error fatal: monitor_read: unsupported request: 144

Bug #1179202 reported by Dave Gilbert on 2013-05-12
86
This bug affects 13 people
Affects Status Importance Assigned to Milestone
openssh (Ubuntu)
Critical
Colin Watson

Bug Description

loggin in from raring host to saucy kvm guest with ssh <email address hidden>
it's accepting the password, giving me the motd and then closing the connection.

In /var/log/auth.log on the guest I see:

May 12 13:54:24 saucy pkexec: pam_unix(polkit-1:session): session opened for user root by dg(uid=1000)
May 12 13:54:24 saucy systemd-logind[645]: Removed session c1.
May 12 13:54:24 saucy pkexec[3068]: dg: Executing command [USER=root] [TTY=/dev/pts/1] [CWD=/home/dg] [COMMAND=/usr/sbin/sshd -T]
May 12 13:54:59 saucy sshd[3147]: Accepted password for dg from 192.168.122.1 port 44999 ssh2
May 12 13:54:59 saucy sshd[3147]: pam_unix(sshd:session): session opened for user dg by (uid=0)
May 12 13:54:59 saucy systemd-logind[645]: New session c4 of user dg.
May 12 13:54:59 saucy sshd[3147]: fatal: monitor_read: unsupported request: 144
May 12 13:54:59 saucy sshd[3147]: pam_unix(sshd:session): session closed for user dg
May 12 13:54:59 saucy sshd[3262]: fatal: mm_request_send: write: Broken pipe

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: openssh-server 1:6.2p1-2
ProcVersionSignature: Ubuntu 3.9.0-1.5-generic 3.9.1
Uname: Linux 3.9.0-1-generic x86_64
ApportVersion: 2.10-0ubuntu3
Architecture: amd64
Date: Sun May 12 13:53:59 2013
InstallationDate: Installed on 2013-05-06 (5 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130506)
MarkForUpload: True
SourcePackage: openssh
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Dave Gilbert (ubuntu-treblig) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openssh (Ubuntu):
status: New → Confirmed
Jason Conti (jconti) wrote :

I think I see the issue. In monitor.h, the request types have been renumbered, and the consolekit.patch sets MONITOR_REQ_CONSOLEKIT_REGISTER = 400. But, monitor_read() only reads a single byte for the type. 400 = 0x190, so we get 0x90 = 144.

Renumbering MONITOR_REQ_CONSOLEKIT_REGISTER = 144 and MONITOR_ANS_CONSOLEKIT_REGISTER = 145 fixes it. Whether these are appropriate values I couldn't say.

Jean-Baptiste Lallement (jibel) wrote :

Confirmed on Saucy with openssh 6.2p1-2

Changed in openssh (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Colin Watson (cjwatson) on 2013-05-13
Changed in openssh (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Colin Watson (cjwatson)
status: Confirmed → In Progress
Colin Watson (cjwatson) wrote :

Fix uploaded to Debian, thanks! The auto-sync will pick it up in a few hours.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openssh - 1:6.2p1-3

---------------
openssh (1:6.2p1-3) unstable; urgency=low

  * Renumber Debian-specific additions to enum monitor_reqtype so that they
    fit within a single byte (thanks, Jason Conti; LP: #1179202).

 -- Colin Watson <email address hidden> Mon, 13 May 2013 10:56:04 +0100

Changed in openssh (Ubuntu):
status: In Progress → Fix Released
Scott Moser (smoser) wrote :

Verified fix-released.
I booted a cloud image of ubuntu-daily/ubuntu-saucy-daily-amd64-server-20130513-disk1.img (where I had opened the duplicate bug 1179513) with user-data that included 'apt_upgrade: true'.

The image came up, installed the new ssh, and all was well.
Thanks.

Todd A. Jacobs (codegnome) wrote :

Also closes Bug #1179344.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers