OpenSMTPD crashes after upgrade to 18.04.1 LTS

Bug #1802146 reported by Pavneet Arora on 2018-11-07
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
opensmtpd (Arch Linux)
Fix Released
Undecided
Unassigned
opensmtpd (Fedora)
Unknown
Unknown
opensmtpd (Ubuntu)
Undecided
Unassigned

Bug Description

I had a stable 16.04 server running OpenSMTPD. Recently upgraded to 18.04.1 LTS, and smtpd would crash repeatedly with each outbound email attempt.

Logged this as an issue on github.com/OpenSMTPD/OpenSMTPD. After a great deal of assisted investigation, the problem was traced to crypt_checkpass.c for which a patch has already been made and merged back into the main branch.

In order to get back into production I have used the package source and replaced crypt_checkpass.c with the updated one. The full recipe for getting our server back into production may be found here:

https://github.com/OpenSMTPD/OpenSMTPD/issues/888#issuecomment-436686749

I would classify this as *URGENT* as it renders mail servers using OpenSMTPD on the latest stable unusable.

# lsb_release -rd
Description: Ubuntu 18.04.1 LTS
Release: 18.04

# apt-cache policy opensmtpd
opensmtpd:
  Installed: 6.0.3p1-1build1
  Candidate: 6.0.3p1-1build1
  Version table:
 *** 6.0.3p1-1build1 500
        500 http://us.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in opensmtpd (Ubuntu):
status: New → Confirmed
Changed in opensmtpd (Arch Linux):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.