Ubuntu

openshot crash when exporting to a read-only directory

Reported by Romano Giannetti on 2010-11-08
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenShot Video Editor
High
Unassigned
openshot (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openshot

Hi, openshot 1.2.2 crashes if you try to export a project in a directory where you do not have write permission.

I understand it shouldn't work, but crashing (segmentation fault) is a bit too... punitive, no? :-)

Related branches

Olivier Girard (eolinwen) wrote :

Hi,
A message could be a good think for the user.

Yes, that was what I meant :-)

asdfgh2091 (asdfgh2091) wrote :

Still there in openshot 1.4.1 from ppa with ubuntu natty

Andy Finch (fincha) on 2012-03-20
Changed in openshot:
milestone: none → 1.4.3
importance: Undecided → Medium
Andy Finch (fincha) wrote :

A fix for this has been committed to the trunk.

Changed in openshot:
status: New → Fix Committed
Andy Finch (fincha) on 2012-03-22
Changed in openshot:
importance: Medium → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openshot (Ubuntu):
status: New → Confirmed
Changed in openshot:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers