Missing FreeType support in 14.04 LTS package

Bug #1339264 reported by Chris McFarland on 2014-07-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openscenegraph (Debian)
Fix Released
Unknown
openscenegraph (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Saikrishna Arcot

Bug Description

[Impact]

The current version of openscenegraph in Ubuntu Trusty cannot load FreeType fonts. This is because the build used its own CMakeModule to try to find the Freetype libraries, and when it couldn't find the libraries, this module of the program was excluded from the build. Therefore, any programs that attempt to use FreeType fonts for their text will result in the text using something like Courier New (or some other code-style, serif font).

[Test Case]

Use any program that uses openscenegraph and attempts to load a FreeType font. Flightgear is one example; in the case of this program, an error message is displayed saying that the Liberation fonts couldn't be loaded, and the text appears to be Courier New-like.

[Regression Potential]

Minimum. The actual changes are a change in how the FreeType libraries are found and some #include changes. The worst case is a build failure. Programs are expected to continue working and shouldn't need a recompilation.

[Original Description]

The current package (3.2.0~rc1-4) available for Ubuntu 14.04 is missing support for FreeType due to a build bug that is listed as fixed in 3.2.0~rc1-5. This results in very poor quality text in OpenSceneGraph applications that are running on 14.04 (which used to be fine in 12.04). There is a discussion of the bug on the Debian bug tracker (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=743169) for more information.

Is it possible to get this fix into 14.04?

Related branches

tags: added: trusty
Changed in openscenegraph (Debian):
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openscenegraph (Ubuntu):
status: New → Confirmed
description: updated
description: updated
Iain Lane (laney) on 2014-09-29
Changed in openscenegraph (Ubuntu Trusty):
status: New → In Progress
assignee: nobody → Saikrishna Arcot (saiarcot895)

Hello Chris, or anyone else affected,

Accepted openscenegraph into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/openscenegraph/3.2.0~rc1-4ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in openscenegraph (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
tags: added: verification-failed
removed: verification-needed
Chris McFarland (cmcfarla) wrote :

I tried installing openscenegraph/trusty-proposed (3.2.0~rc1-4ubuntu0.1) following Chris Arges's instructions, but unfortunately it did not fix the issue -- the font rendering appears the same as before, even with a full rebuild of affected software.

It looks like libosgdb_freetype.so is not getting installed with the proposed package.

Saikrishna Arcot (saiarcot895) wrote :

I haven't had a chance to verify this fix, but /usr/lib/osgPlugins-3.2.0/osgdb_freetype.so is certainly being installed.

Chris McFarland (cmcfarla) wrote :

Hmm... it looks like openscenegraph/trusty-proposed just has symlinks to a few .so files instead of the actual library files. The osgdb_freetype.so file actually gets installed with libopenscenegraph99/trusty-proposed, which wasn't getting installed on my system when I did apt-get install openscenegraph/trusty-proposed for some reason. Maybe I made a mistake configuring the package manager? In any case, I have the file now, but it's too late for me to do the testing today.

I'll set the tag back to verification-needed for now and update again the next time I can test it on the system (hopefully tomorrow). Sorry for the confusion.

tags: added: verification-needed
removed: verification-failed
Chris McFarland (cmcfarla) wrote :

I tested today with libopenscenegraph99/trusty-proposed installed and it fixed the font rendering issue.

Saikrishna Arcot (saiarcot895) wrote :

+1 from me as well; the font rendering issue isn't present here.

Mathew Hodson (mathew-hodson) wrote :

Tagging based on comment #6.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openscenegraph - 3.2.0~rc1-4ubuntu0.1

---------------
openscenegraph (3.2.0~rc1-4ubuntu0.1) trusty; urgency=low

  * Add support for building on armhf by building with OpenGL ES 2.0
    (LP: #1284190).
  * Backport part of a commit to not build osgframerenderer example.
  * Add change-typedef.patch to fix conflicting typedefs for GLdouble
    with OpenGL ES 2.0
  * Exclude freeglut3-dev from dependencies for armhf
  * Add patch to fix FreeType library detection (LP: #1339264).
 -- Saikrishna Arcot <email address hidden> Wed, 06 Aug 2014 17:41:46 -0500

Changed in openscenegraph (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for openscenegraph has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openscenegraph - 3.2.1-5ubuntu1

---------------
openscenegraph (3.2.1-5ubuntu1) vivid; urgency=medium

  * Resynchronise with Debian. Remaining changes:
    - Add support for building on armhf by building with OpenGL ES 2.0.
    - Backport part of a commit to not build osgframerenderer example.
    - Add change-typedef.patch to fix conflicting typedefs for GLdouble with
      OpenGL ES 2.0.
    - Exclude freeglut3-dev from dependencies for armhf.
    - Change Depends of libopenscenegraph-dev for armhf from libgl1-mesa-
      dev to libgles2-mesa-dev.

openscenegraph (3.2.1-5) unstable; urgency=medium

  * Update fix for correctly loading plugins on platforms other than amd64.
    (Closes: 763821)
  * Cherry-pick bug fix from upstream, SVN revision 14400.
    Thanks to Rebecca N. Palmer (Closes: 765855)
  * Update Standards version to 3.9.6. No further changes required.

openscenegraph (3.2.1-4) unstable; urgency=medium

  * A preprocessor substitution was interferring with the architecture name for loading plugins.
    (Closes: 763816)

openscenegraph (3.2.1-3) unstable; urgency=medium

  * Refresh libav patches.
  * One more fix for building on FreeBSD.

openscenegraph (3.2.1-2) experimental; urgency=medium

  * Fix FTBFS on FreeBSD.
  * Enabled multiarch.
    Thanks to Saikrishna Arcot (Closes: 759593)
  * Updated debian/copyright file to machine readable format 1.0, and
    addition of missing license from file AndroidExample/EGLview.java.
    Thanks to Thorsten Alteholz (Closes: 757106)

openscenegraph (3.2.1-1) experimental; urgency=medium

  * Acknowledge NMU.
  * New upstream version.
  * Removal of old patches.
  * Confirmation that (LP: #1339264) is already closed.
  * Removed obsolete conflict rules.
 -- Colin Watson <email address hidden> Tue, 02 Dec 2014 16:00:21 +0000

Changed in openscenegraph (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.