openscad package missing from 18.04

Bug #1766555 reported by Marc Pignat on 2018-04-24
This bug affects 35 people
Affects Status Importance Assigned to Milestone
openscad (Ubuntu)

Bug Description

The openscad package is missing from 18.04 even though openscad-mcad is included.

Can you please add it?

Thank you in advance and best regards

lsb_release -rd
Description: Ubuntu Bionic Beaver (development branch)
Release: 18.04

Hans Joachim Desserud (hjd) wrote :

Thanks for reporting.

Looking at the publishing history for this package (linked to in the upper right corner on the overview page, it looks like it was removed from bionic because it failed to build.

Marc Pignat (swid) wrote :

Did you mean it was removed because it fails to build on mips/mipsel?

Can I do something to help getting this package back into ubuntu?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openscad (Ubuntu):
status: New → Confirmed
Marc Pignat (swid) wrote :

As I proposed on askubuntu ( here is a temporary workaround : installing the debian/sid package.

    # gdebi will manage .deb dependencies
    sudo apt-get install gdebi-core
    sudo gdebi openscad_2015.03-2+dfsg-2+b3_amd64.deb

Hans Joachim Desserud (hjd) wrote :

>Did you mean it was removed because it fails to build on mips/mipsel?

I know where to find the package history, but I don't know more about the specific details for this package. :) Now that you mention it, that seems a bit strange since Ubuntu doesn't support mips(el). Looks like the package had failed to build on arm64 and was missing dependencies to attempt a build on armhf ( Could possibly also be that it failed to build when attempting to rebuild packages in the archive but I don't know.

>Can I do something to help getting this package back into ubuntu?

One way would probably be to get the package resynced from Debian to Ubuntu. Note that currently it is marked as affected by two release critical bugs (the mips build failure and another), so it might be easier to reintroduce the package if those were fixed. Also note that at the time 2015.03-2+dfsg-2ubuntu5 was removed it contained some Ubuntu-specific patches (one can tell by "ubuntu" in the version number), and perhaps these would still need to be included to build and run as expected in Ubuntu.

Joachim Schäfer (oyooyo) wrote :

To those who are like me desperately missing OpenSCAD, but who'd prefer another solution than installing the .deb package:

The official OpenSCAD PPA now supports 18.04.

To install OpenSCAD from the official OpenSCAD PPA, simply follow the instructions from ; in short:

sudo add-apt-repository ppa:openscad/releases
sudo apt-get update
sudo apt-get install openscad

Patola (patola) wrote :

OpenSCAD is utterly important for my work. It was very irresponsible that the Ubuntu maintainers took if off the distribution's official repositories just because it wasn't compiling in a platform Ubuntu doesn't even have builds for.

Thanks, mr. Schäfer for the workaround.

HaydnHuntley (haydn-huntley) wrote :

OpenSCAD is also of key importance to my workflow, too.

I successfully installed it using gdebi, but now I'd like to uninstall the Debian version and install the Ubuntu one -- how does one undo this command?

sudo gdebi openscad_2015.03-2+dfsg-2+b3_amd64.deb

Or do I have to reinstall Ubuntu?

Sam (sam-ka) wrote :

I would like to add my voice to those who have been negatively effected by this issue. We use openscad in a professional production setting.

I realize the fault lies squarely with me for not checking before updating our systems to the latest lts version (though canonical have been very predictable up to this point so I got lazy, this was a good wake up slap).

I hope this issue gets resolved soon as this issue effects a long-term ubuntu release. Many more systems will break as people upgrade their systems from 14.04 (our case) and 16.04.

Thank you Joachim and Marc for your suggestions.

Tilman Baumann (tilmanbaumann) wrote :

+1 for getting it back in the distro. I was quite confused when it was suddenly gone.

yope (djander) wrote :

OpenSCAD missing in Ubuntu? This is bad. Creativity and media production is one of the areas where Open-Source software shines and has most potential to attract new users IMHO. OpenSCAD is just one crucial piece of software in this area, and missing it will hurt Ubuntu.
The Rep-rap community for instance is booming since the last 2 or 3 years, and I have seen many Windows users dip their toes in Ubuntu for the first time just because of the availability and ease of installation of OpenSCAD among other such tools. I am not an experienced package maintainer, but if there is something else I can do to help, let me know.

Well, it seems this won't be addressed anytime soon... :/

Bo Lundberg (bo-lundberg) wrote :

When I installed Bionic in April there where several problems, among openscad whas one. This and other information about the future of Ubuntu made me to leave Ubuntu for my work, after 10 years, in favor of Debian.
Is Mark Shuttleworth doing a "Red Hat"? In any case its nice to get rid of commercial considerations.

don bright (hmbright) wrote :

it "failed to build", but in the link they say it ran out of virtual memory on their MIPS architecture build.

i would guess what happened is that gcc on their build machine ran out of memory, on the file . It is actually pretty normal to have memory issues when building OpenSCAD on the files that use CGAL intensively.

That is because CGAL (geometry library, ) is a massive c++ template library which can use at least 1 Gigabytes of ram, during compile time (not run time), for some of its functionality, depending on optimizations and debug symbol options on the compiler. it can go higher with various extra options added to the compiler switches, like -O2 -g.

Here is the log showing they crashed at

What they also did was to use parallell make. You can see they have 'make -j4' right there on the log. So they were trying to build multiple files at once, alongside the massive CGAL file. That is going to also use more memory than necessary.

Also it seems to be using gcc... clang uses a lot less memory than gcc.

i am trying to figure out how much ram + swap they would have had on their mips build machine, but i am not sure how to figure that out.

David Jordan (dmj726) wrote :

Can we still try to get openscad released in Ubuntu for bionic? If it's going to take time to fix the arm failure, perhaps at least release it for the architectures that do build, especially amd64, which is what most openscad users will have.

As a stopgap for our users, I've had to put builds in our ppas, but it would look much better to have openscad back in Ubuntu proper.

SA (superaorta) wrote :

Yep got this problem and tired varios methods of installing it but every method runs into the same runtime error:

composeAndFlush: makeCurrent() failed

as soon as it loads a model.

Anyone got any clue? or an update on when openscad might return to the repos?

BloodBlight (bpwoods) wrote :


ADFH (adfh) wrote :

Looks like it's missing from Ubuntu Cosmic (18.10) also.

Peter Buck (pbuck) wrote :

Yes, missing in 18.10 and adding the ppa:openscad/releases repository doesn't work for me.

Sezer Yalcin (sy-y) wrote :

Openscad is great and worked very cleanly so far in previous ubuntu builds. I am hoping to get it from ubuntu repo ASAP.

Missing in 18.10, need it back asap please. ppa:openscad/releases also doesn't work for me.

Ben Horner (bhorner) wrote :

I upgraded to Ubuntu 18.04, and found that I couldn't use openscad anymore.
I ended up here, this sucks.

I tried this:
sudo add-apt-repository ppa:openscad/releases
sudo apt-get update
sudo apt-get install openscad

But get this error:
$ openscad
openscad: error while loading shared libraries: cannot open shared object file: No such file or directory

I tried this, which also didn't work:
$ sudo apt-get install libqt5scintilla2
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libqt5scintilla2

Alexia Death (alexiade) wrote :

using bionc-s build seems to work - just swap the ppa /etc/apt/sources.list.d file relase definition from cosmic to bionic. Any library related crashes you MAY get are probably because of lib version incompatibility, so don't report any bugs to openscad from this hack. that said, it worked for the models I had.

glenstewart (glen-stewart) wrote :

I suggest to just use the AppImage provided on the scad download page. The latest build at the moment, is OpenSCAD-2019.01-RC3.1-x86_64.AppImage

Just chmod 755 it, and then run. Much easier than all the fuss listed above. Runs fine for me on Ubuntu 18.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers