Feitian tokens unsupported in OpenSC 0.17.0 (regression)

Bug #1734594 reported by Ben Primrose
This bug affects 3 people
Affects Status Importance Assigned to Milestone
opensc (Ubuntu)

Bug Description

I've been happily using my Feitan token to access servers at work for a while, but following an upgrade to artful I can't add it to my ssh agent (this would previously give "Card added"):

    $ ssh-add -s /usr/lib/x86_64-linux-gnu/opensc-pkcs11.so
    Enter passphrase for PKCS#11:
    Could not add card "/usr/lib/x86_64-linux-gnu/opensc-pkcs11.so": agent refused operation

I have been off for a week, and thought I may be mistyping my PIN. So I tried resetting my token, and get this:

    $ pkcs15-tool -u
    Using reader with a card: Feitian ePass2003 00 00
    PKCS#15 binding failed: Unsupported card

System and package info below, AMA else you need.

$ lsb_release -rd
Description: Ubuntu 17.10
Release: 17.10

$ apt list --installed | egrep "(opensc|pkcs)"

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libengine-pkcs11-openssl/artful,now 0.4.7-1 amd64 [installed]
libpkcs11-helper1/artful,now 1.22-2 amd64 [installed,automatic]
opensc/artful,now 0.17.0-1 amd64 [installed]
opensc-pkcs11/artful,now 0.17.0-1 amd64 [installed]

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: opensc 0.17.0-1
ProcVersionSignature: Ubuntu 4.13.0-17.20-generic 4.13.8
Uname: Linux 4.13.0-17-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.5
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sun Nov 26 23:06:52 2017
EcryptfsInUse: Yes
InstallationDate: Installed on 2017-10-13 (44 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Release amd64 (20170412)
 PATH=(custom, no user)
SourcePackage: opensc
UpgradeStatus: Upgraded to artful on 2017-11-22 (5 days ago)

Revision history for this message
Ben Primrose (bprimrose) wrote :
Revision history for this message
Chang Liu (cchliu) wrote :

I am having the same issue with opensc 0.17.0-1 package and Feitian ePass2003 token. I compiled an old version (OpenSC 0.15.0) for temporary use for now.

Revision history for this message
Ershaad (ershaad-a) wrote :

My Feitian USB token also stopped working with the same error as the OP after the upgrade to artful.

David Ward (dpward)
tags: added: regression-release
Changed in opensc (Ubuntu):
status: New → Confirmed
Revision history for this message
David Ward (dpward) wrote :

Upstream issue (fixes were merged): https://github.com/OpenSC/OpenSC/issues/1073

summary: - Feitan token unsupported
+ Feitian tokens unsupported in OpenSC 0.17.0 (regression)
tags: added: bionic patch-accepted-upstream
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.