[SRU] OpenSBI 0.9 backport to Focal

Bug #1937277 reported by Heinrich Schuchardt
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
opensbi (Ubuntu)
Undecided
Graham Inggs
Focal
Undecided
Unassigned
u-boot (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned

Bug Description

OpenSBI 0.9 backport to Focal

[Impact]
* OpenSBI is used to create RISC-V images for various boards and to boot RISC-V virtual machines.
 * Our current 0.8 release lacks a patch for CPU erratum CIP-1200 described in Errata_FU740-C000_20210205 from https://www.sifive.com/boards/hifive-unmatched
 * Bugs in OpenSBI that may lead to crashes have been resolved in v0.9.

[Test Case]

 * Build U-Boot with new OpenSBI version and boot Focal images with this U-Boot installed.

[Where problems could occur]

 * Parts of the OpenSBI code where restructured, new SBI extensions were added. Bugs in the modified code might lead to failure to boot, reboot, poweroff or might lead to crashes.

[Other Info]

Here are the release notes for OpenSBI Version 0.9:

This release has:

Lots of fixes and improvements
Optimized trap handler for both RV32 and RV64
Domain support for system-level partitioning
Device tree based domain configuration
SBI v0.3 SRST extension
More detailed boot-time prints
Makefile option to use toolchain default ISA and ABI

summary: - OpenSBI 0.9 backport
+ [SRU] OpenSBI 0.9 backport to Focal
tags: added: fr-1519
Revision history for this message
Heinrich Schuchardt (xypron) wrote :
Revision history for this message
Heinrich Schuchardt (xypron) wrote :
Revision history for this message
Heinrich Schuchardt (xypron) wrote :
Revision history for this message
Heinrich Schuchardt (xypron) wrote :
Revision history for this message
Heinrich Schuchardt (xypron) wrote :
Revision history for this message
Heinrich Schuchardt (xypron) wrote :

In ppa:xypron/opensbi package opensbi - 0.9-2~ubuntu0.20.04.2 is available.

Graham Inggs (ginggs)
Changed in opensbi (Ubuntu):
status: New → In Progress
assignee: nobody → Graham Inggs (ginggs)
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Heinrich, or anyone else affected,

Accepted opensbi into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/opensbi/0.9-2~ubuntu0.20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in opensbi (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed verification-needed-focal
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Accepted. Normally we'd expect the same version to be also backported to hirsute, but seeing that hirsute already has 0.9 and has most of the -2 changes, I don't think it's necessary. Especially that hirsute is not an LTS. We might want to think of doing that for upgrade reasons, but I for non-LTS cases that's less of a priority IMO.

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Heinrich, or anyone else affected,

Accepted u-boot into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/u-boot/2021.01+dfsg-3ubuntu0~20.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in u-boot (Ubuntu Focal):
status: New → Fix Committed
Revision history for this message
Steve Langasek (vorlon) wrote :

The updated SRU in the focal-proposed queue looks fine, but why is this bug still marked 'new' for the devel series? That shouldn't be the case for an SRU.

Changed in u-boot (Ubuntu Focal):
status: Fix Committed → Incomplete
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello Heinrich, or anyone else affected,

Accepted u-boot into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/u-boot/2021.01+dfsg-3ubuntu0~20.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in u-boot (Ubuntu Focal):
status: Incomplete → Fix Committed
Revision history for this message
Heinrich Schuchardt (xypron) wrote :

Hello Brian,

booting with
U-Boot 2021.01+dfsg-3ubuntu0~20.04.3 (Jul 30 2021 - 14:38:17 +0000)
fails.

Found 14 disks
** Invalid partition 21 **
Cannot read EFI system partition
BootOrder not defined
EFI boot manager: Cannot load any image

The following patches are missing:

3dca77b1dc1b ("efi_loader: partition numbers are hexadecimal")
17f8cda505e3 ("efi_loader: set partition GUID in device path for SIG_TYPE_GUID")

Documentation for flashing U-Boot for the HiFive Unmatched is missing:

70415e1e528d ("board: sifive: add HiFive Unmatched board support")

Generally I would prefer to have the following configuration settings:

CONFIG_CMD_EFIDEBUG=y
CONFIG_CMD_NVEDIT_EFI=y
CONFIG_HEXDUMP=y
# CONFIG_SPL_HEXDUMP is not set

But maybe adjusting these setting is a question of the current release.

Best regards

Heinrich

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Ok, that's weird. So you're saying that our current unmatched images fail to boot completely with the new u-boot from -proposed? That is not what I heard, I know William tested this backport and he was able to boot his device (minus the issues re: the kernel). I think William backported the u-boot version as we had in hirsute, and hirsute worked fine with 5.11.

So does this mean the current u-boot is completely broken? Was the hirsute backport done wrongly?

Revision history for this message
Heinrich Schuchardt (xypron) wrote :

No. On my board UEFI boot options are set to boot via the UEFI stub of our Linux kernel image. And booting fails due to the two missing patches. I suggest to add said patches.

Revision history for this message
William Wilson (jawn-smith) wrote :

The verification passed for focal. I flashed an image that has the latest openSBI and u-boot from focal-proposed and u-boot was able to successfully load the kernel.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

+1 on adding the patches later in the cycle, but for 20.04.3 I think we want to play it safe and not introduce any additional risk. We are in a semi-freeze now in focal. Let's get this done after .3 is out (since we don't use these features by default anyway).

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package u-boot - 2021.01+dfsg-3ubuntu0~20.04.3

---------------
u-boot (2021.01+dfsg-3ubuntu0~20.04.3) focal; urgency=medium

  * debian/u-boot-sifive.postinst: use correct target names for u-boot
    2021.01.

u-boot (2021.01+dfsg-3ubuntu0~20.04.2) focal; urgency=medium

  * Bump opensbi build-dependency to ensure fixed version is used by u-boot
    RISC-V images (LP: #1937277)

  [ Dimitri John Ledkov ]
  * Implement u-boot-sifive.postinst to upgrade u-boot in loader1/loader2
    partitions upon package upgrades. LP: #1936370

 -- Łukasz 'sil2100' Zemczak <email address hidden> Fri, 30 Jul 2021 16:38:17 +0200

Changed in u-boot (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for u-boot has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package opensbi - 0.9-2~ubuntu0.20.04.1

---------------
opensbi (0.9-2~ubuntu0.20.04.1) focal; urgency=medium

  * Backport to focal (LP: #1937277)
    - preserve qemu/virt and sifive/fu540 as a symlink to generic
    - use debhelper-compat 12, as 13 did not make into focal

opensbi (0.9-2ubuntu1) impish; urgency=medium

  * Merge from debian experimental, remaining changes:
    - Import meta-sifive patch for fu740 CIP 1200 errata.

opensbi (0.9-2) experimental; urgency=medium

  * debian/control: Set Multi-Arch: foreign.
  * Drop sifive/fu540 platform, which is deprecated by the "generic"
    platform and will be dropped from future upstream versions.
  * Install fw_*.bin.
  * debian/control: Remove explicit branch from Vcs-Git header.

opensbi (0.9-1) unstable; urgency=medium

  * New upstream version.

 -- Heinrich Schuchardt <email address hidden> Fri, 23 Jul 2021 10:00:34 +0200

Changed in opensbi (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers