oowriter2 break .recently-used escaping

Bug #24327 reported by Sebastien Bacher on 2005-10-20
38
Affects Status Importance Assigned to Milestone
openoffice.org2-amd64 (Ubuntu)
Medium
Matthias Klose

Bug Description

While debugging a gnome-panel issue on IRC with an user we figured than
oowriter2 breaks the .recently-used escaping which creates issues (the user had
a gnome-panel crasher, it ignores the entry on my box).

Some applications escape the "&" from filemanes as "&". oowriter2 seems to
not be happy about that and rewrite them without any escaping which makes GNOME
unhappy.

Run "totem a_file_with_the_&_char" to get an example.

Ondřej Nový (onovy) wrote :

*** Bug 28176 has been marked as a duplicate of this bug. ***

Sebastien Bacher (seb128) wrote :

Matthias could consider forwarding that bug upstream or something? It breaks the
recent documents every time somebody uses openoffice2.org to open a documents
when have a "&" somewhere in its recently-used, that should be fixed for dapper
because it impacts the desktop experience

Matthias Klose (doko) wrote :

I am unable to crash gnome-panel with these names, not sure what I have to reproduce to make it crash. please could you recheck with 2.0.2? Upstream did mark it as "needsinfo"

Changed in openoffice.org2-amd64:
status: Unconfirmed → Needs Info
Sebastien Bacher (seb128) wrote :

Works fine now, closing as fixed

Changed in openoffice.org2-amd64:
status: Needs Info → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.