Writer of OpenOffice.org2 freezes whole Desktop

Bug #24313 reported by Kuropka on 2005-10-20
8
Affects Status Importance Assigned to Milestone
openoffice.org2-amd64 (Ubuntu)
Medium
Matthias Klose

Bug Description

When opening a (long) MS-Word document in OpenOffice.org2 the whole Gnome
Desktop freezes after some scrolling in the document.

Matthias Klose (doko) wrote :

(In reply to comment #0)
> When opening a (long) MS-Word document in OpenOffice.org2 the whole Gnome
> Desktop freezes after some scrolling in the document.

Please attach the document to the bug report; if you do not want to attach it,
please send it with email. If neither of the two options is possible, we'll have
difficulties reproducing the report.

Günter Haus (mcframe) wrote :

Created an attachment (id=4741)
OO 1.1.3 Writer text document, which freezes (K)Ubuntu while navigating
through

Günter Haus (mcframe) wrote :

I confirm this annoying bug, which unfortunately shows up on all our (even virgin installed) Breezy
PCs. I assume it could be somehow related to embedded grpahics (gdi), because scrolling often stops
at a page with graphics. I have posted this bug as well at OO bugzilla.
I have added one of several writer documents where this bug shows up.

Serhiy Kachaniuk (serzholino) wrote :

For me this happends when document contains OLE-objects and this objects appears
on the screen.
There is bug in upstream http://www.openoffice.org/issues/show_bug.cgi?id=56408
and some workaround export MALLOC_CHECK_=1 before OOo start

Serhiy Kachaniuk (serzholino) wrote :

Created an attachment (id=5208)
Opedn Document Text file with OLE object, that causes OOo2 crash

Matthias Klose (doko) wrote :

I'm able to open and scroll both documents with current dapper (m143 packages).

ischoegl (inch) wrote :

I observed practically the same behavior (box locks whenever I scroll into some
graphics object) on all impress, draw and writer as long as they contain the
same graphics object (both 1.9.129 and 2.00 from
http://people.ubuntu.com/~doko/OOo2). BTW, the work-around export MALLOC_CHECK=1
didn't work for me.
Interestingly enough, the documents open with OOo 1.1.5 and I had originally
created (i.e. imported) the files using some late 1.9.122 version that I
installed from rpm's. They also open without problem on the OOo2 installation on
the other side of my computer (i.e. windows). I would be really happy if this
problem were resolved in breezy.
I'll attach a file producing the unruly behavior (it's an .sxd file, but the
problem is not linked to the new/old OOo formats).

ischoegl (inch) wrote :

Created an attachment (id=5347)
Test file that causes ubuntu's OOo2 to freeze

Breezy/OOo2: writer, impress and draw lock whenever these objects have to be
displayed.

Matthias Klose (doko) wrote :

(In reply to comment #7)
> http://people.ubuntu.com/~doko/OOo2). BTW, the work-around export MALLOC_CHECK=1
> didn't work for me.

s/MALLOC_CHECK/MALLOC_CHECK_/

please could you recheck?

ischoegl (inch) wrote :

(In reply to comment #9)
> (In reply to comment #7)
> > http://people.ubuntu.com/~doko/OOo2). BTW, the work-around export MALLOC_CHECK=1
> > didn't work for me.
>
> s/MALLOC_CHECK/MALLOC_CHECK_/
>
> please could you recheck?

I did recheck with the right syntax MALLOC_CHECK_=1, but without success. Just
to make sure:
$ export MALLOC_CHECK_=1
$ echo $MALLOC_CHECK_
1

PS: I'll double-check starting OOo2 from the commandline to see whether it spits
anything out (but I have to restart since OOo2 won't come up again ... )

ischoegl (inch) wrote :

(In reply to comment #9)
Update:
OK, I just verified that the work-around actually works, as long as I start OOo2
from the commandline :)
$ export MALLOC_CHECK_=1
$ ooffice2

I'd still be happy if this bug could be tracked down

Matthias Klose (doko) wrote :

fixed in 2.0.2, as found in dapper

Changed in openoffice.org2-amd64:
status: Needs Info → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.