OOo does not use gtk file chooser

Bug #24107 reported by Ben Maurer on 2005-10-17
6
Affects Status Importance Assigned to Milestone
openoffice.org2-amd64 (Ubuntu)
Medium
Matthias Klose

Bug Description

In ooo writer, opening a file causes the ugly ooo file chooser to come up. The
nice gtk one should appear. This happens in Fedora and SUSE.

Dennis Kaarsemaker (dennis) wrote :

I'm sure I've seen a similar bugreport before. I just can't find it...

Ben Maurer (bmaurer) wrote :

From bug 18862:

they do work, but it not yet the default. please disable the checkbox "Use
OpenOffice.org Dialogs" in Tools/Options/OpenOffice.org/General
the interaction with the Standard OOo dialogs is considerd more stable.

That works for me. This should be the default. I don't see what the OOO dialogs
get us over the gnome ones. Other distros enable them by default.

Ben Maurer (bmaurer) wrote :

To fix this, you can remove the file:

/usr/lib/openoffice2/share/registry/modules/org/openoffice/Office/Common/Common-UseOOoFileDialogs.xcu

from the files that are shipped. This is what Fedora and SUSE do.

Matthias Klose (doko) wrote :

enabled in 2.0.2, as found in dapper

Changed in openoffice.org2-amd64:
status: Unconfirmed → Fix Released
JD (jacobdorne) wrote :

The Gnome file open dialogs are used by default in Hardy.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.