Ubuntu

/usr/bin/openoffice: Bold font displays plain

Reported by Debian Bug Importer on 2004-11-01
34
Affects Status Importance Assigned to Milestone
openoffice.org (Debian)
Fix Released
Unknown
openoffice.org (Ubuntu)
High
Matthias Klose

Bug Description

Automatically imported from Debian bug report #261895 http://bugs.debian.org/261895

On Sat, 2004-08-07 at 16:40, Jeff Martin wrote:
>...
> This did not fix my bug 261895.
>
> -Jeff

i do some test's about your reported bug on 2 machines running same
version openoffice 1.1.2-3.

1- write 4 rows for some different fonts like this:

courier <-- normal
courier <-- bold
courier <-- italic
courier <-- underline

The fonts was: courier
               Nimbus mono
               helvetica
               nimbus roman
               times
               century schoolbook

I visualize this doc in both computers

Computer 1:

courier: only display different in underline
Nimbus mono: only display different in underline
helvetica: all display different ok :)
nimbus roman: display different italic and underline
times: display different italic and underline
century schoolbook: all display different ok :)

Computer 2:
courier: all display different ok :)
Nimbus mono: only display different in underline
helvetica: all display different ok :)
nimbus roman: display different italic and underline
times: all display different ok :)
century schoolbook: all display different ok :)

Computer 2 have some lib's newer than computer 1.

This suggest some issue with lib's and other more with fonts (i don't
know anything about fonts)

Then i print the doc on 2 different printers:

Printer 1 hp laserjet 1100 with cups (driver hp laserjet 4l
cups+gimpprint v4.26)

Printer 2 Epson stylus c43 ux (driver Epson stylus c43 ux cups+gimpprint
v2.26)

In both printers the results where:
courier: all printed different ok :)
Nimbus mono: only print different in underline
helvetica: all printed different ok :)
nimbus roman: printed different italic and underline
times: all printed different ok :)
century schoolbook: all printed different ok :)

This results are coincident with results on display doc on computer 2.

I hope that is useful to you.

Greetings.

debian bug 261895 and OpenOffice bug 31334 may be the same issue.
A file is available for download from the OpenOffice site or I can email it.
The OpenOffice people seemed to think it was a font issue with Debian.

-Jeff

I use the synaptic package manager to download updates. All I can figure
is that I downloaded something that fixed this.
-Jeff

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #261895 http://bugs.debian.org/261895

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 28 Jul 2004 14:57:45 -0500
From: Jeff Martin <email address hidden>
To: <email address hidden>
Subject: /usr/bin/openoffice: Bold font displays plain

Subject: /usr/bin/openoffice: Bold font displays plain
Package: openoffice.org-debian-files
Version: 1.1.2-2+1
Severity: important
File: /usr/bin/openoffice

*** Please type your report below this line ***
*I have this issue on the open office site but they are suggesting it's
a font issue.

I downloaded
Sarge about two weeks ago and have been doing update in the synaptic
program.

My openoffice is the package that downloaded at install and says 1.1.1.

In my file I have a line that appears
"The LDS Corporation* (2000-2002) Lenexa, KS"

In some places the bold indicator on the tool bar will indicate when
placed
on some letters but they display plain.

The reproducible error is:

I have a line of text with a date.
*"The LDS Corporation* (2000-2002) Lenexa, KS"
The text appears to be regular on the screen.
As I move the cursor to different locations the indicator on the bold
button
changes.
I select the entire line which is also a complete paragraph.
I select my custom style. I right click on "resbody".
I select modify.
The example window is displaying normal text but the "typeface" drop
down box
says bold.
I select normal in the "typeface" drop down box. The example changes to
bold print.
I click on OK and the paragraph then displays normally with the display
of the
bold text matching what was earlier only indicated by the color of the
bold button.

The file is available for download on the open office site issue 31334.

Thanks. Jeff
<email address hidden>

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.4.25-1-386
Locale: LANG=C, LC_CTYPE=C

Versions of packages openoffice.org-debian-files depends on:
ii debianutils 2.8.4 Miscellaneous utilities
specific t
ii openoffice.org 1.1.2-2 high-quality office
productivity s
ii openoffice.org-bin 1.1.2-2 OpenOffice.org office suite
binary

-- no debconf information

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Sat, 07 Aug 2004 17:55:09 -0500
From: Erick Lopez Carreon <email address hidden>
To: <email address hidden>
Subject: some test's

On Sat, 2004-08-07 at 16:40, Jeff Martin wrote:
>...
> This did not fix my bug 261895.
>
> -Jeff

i do some test's about your reported bug on 2 machines running same
version openoffice 1.1.2-3.

1- write 4 rows for some different fonts like this:

courier <-- normal
courier <-- bold
courier <-- italic
courier <-- underline

The fonts was: courier
               Nimbus mono
               helvetica
               nimbus roman
               times
               century schoolbook

I visualize this doc in both computers

Computer 1:

courier: only display different in underline
Nimbus mono: only display different in underline
helvetica: all display different ok :)
nimbus roman: display different italic and underline
times: display different italic and underline
century schoolbook: all display different ok :)

Computer 2:
courier: all display different ok :)
Nimbus mono: only display different in underline
helvetica: all display different ok :)
nimbus roman: display different italic and underline
times: all display different ok :)
century schoolbook: all display different ok :)

Computer 2 have some lib's newer than computer 1.

This suggest some issue with lib's and other more with fonts (i don't
know anything about fonts)

Then i print the doc on 2 different printers:

Printer 1 hp laserjet 1100 with cups (driver hp laserjet 4l
cups+gimpprint v4.26)

Printer 2 Epson stylus c43 ux (driver Epson stylus c43 ux cups+gimpprint
v2.26)

In both printers the results where:
courier: all printed different ok :)
Nimbus mono: only print different in underline
helvetica: all printed different ok :)
nimbus roman: printed different italic and underline
times: all printed different ok :)
century schoolbook: all printed different ok :)

This results are coincident with results on display doc on computer 2.

I hope that is useful to you.

Greetings.

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sat, 28 Aug 2004 11:09:35 -0500
From: Jeff Martin <email address hidden>
To: <email address hidden>
Subject: debian bug 261895 and OpenOffice bug 31334

debian bug 261895 and OpenOffice bug 31334 may be the same issue.
A file is available for download from the OpenOffice site or I can email it.
The OpenOffice people seemed to think it was a font issue with Debian.

-Jeff

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sat, 18 Sep 2004 20:21:40 -0500
From: Jeff Martin <email address hidden>
To: <email address hidden>
Subject: fixed

I use the synaptic package manager to download updates. All I can figure
is that I downloaded something that fixed this.
-Jeff

Matt Zimmerman (mdz) wrote :

*** Bug 9814 has been marked as a duplicate of this bug. ***

(In reply to comment #3)
> Message-ID: <email address hidden>
> Date: Sat, 28 Aug 2004 11:09:35 -0500
> From: Jeff Martin <email address hidden>
> To: <email address hidden>
> Subject: debian bug 261895 and OpenOffice bug 31334
>
> debian bug 261895 and OpenOffice bug 31334 may be the same issue.
> A file is available for download from the OpenOffice site or I can email it.
> The OpenOffice people seemed to think it was a font issue with Debian.
>
> -Jeff
>
Where can I download this file? I don't find it on the OpenOffice site.

The bug depends on the font you use. I have this problem with Nimbus Roman No9 L
but not with some other fonts I've tested.

Matthew East (mdke) wrote :

Yes I have this problem with Nimbus Roman and Times: please help!! It is
definitely not an openoffice.org bug, I've used the same version of ooo with
these fonts on other non-debian distros without any problems. Is this likely to
be fixed in the near future do you think?

Matt Zimmerman (mdz) wrote :

openoffice.org 1.1.3 packages are in preparation, and this bug should be
re-tested when they are ready.

Matthew East (mdke) wrote :

No change with the new 1.1.3, at least with the nimbus roman font.

:(

Works fine with the times new roman from the msttfonts package in multiverse,
maybe this is a font problem?

Matthew East (mdke) wrote :

yeah tested with abiword, result is exactly the same: with some fonts, no
difference is made by making them bold.

Hope this helps, M

Matthew East (mdke) wrote :

Tested with another distribution (gentoo): this must be an upstream problem. I
have no idea what package though. Is this an xorg problem? I'm leaving this bug
open so that someone can tell me and we can report it upstream.

thanks, M

Matthew East (mdke) wrote :

Ok i've done some more investigation: i'm not working on an ubuntu install but
have reproduced this problem on gentoo. After installing the package urw-fonts
(are these redhat fonts?), the problem is resolved.

I believe this problem is caused by the Nimbus Roman No 9 L font not actually
being installed at all. When this is the case, the Nimbus Roman font is simply
linked to another serif font.

Maybe someone can try this on an ubuntu install and see if they can close this bug.

Matt Zimmerman (mdz) wrote :

*** Bug 11231 has been marked as a duplicate of this bug. ***

Matt Zimmerman (mdz) wrote :

*** Bug 11263 has been marked as a duplicate of this bug. ***

Matt Zimmerman (mdz) wrote :

Chris, do you know what package is supposed to provide this font, or if we
should change the default?

Chris Halls (credativ) (halls) wrote :

I think Nimbus Roman is included in the gsfonts set.

There are several fonts that OOo can use and it tries to pick a good choice by default. The main
difference between Debian/Ubuntu OOo and upstream OOo is that upstream will use bitmap fonts in
documents, which means that there are more fonts available to choose from, but then you end up
with poor quality printouts or presentations.

Matt Zimmerman (mdz) wrote :

(In reply to comment #17)
> I think Nimbus Roman is included in the gsfonts set.
>
> There are several fonts that OOo can use and it tries to pick a good choice by
default. The main
> difference between Debian/Ubuntu OOo and upstream OOo is that upstream will
use bitmap fonts in
> documents, which means that there are more fonts available to choose from, but
then you end up
> with poor quality printouts or presentations.

Can oo.o use gsfonts directly, or does it need gsfonts-x11? The former is
included in the default install, while the latter is not.

Hm. I have a *lot* of weird fonts in OO.
I've done a clean warty > Hoary upgrade, and there are fonts there that I have
never heard of.
Times new roman is not among them, by the way.
I can select it, but it is not in the drop-down list, just times.

There are fonts I cannot read, there are far-eastern fonts, and all sorts of
things, but the plain old fonts are not there.
This bug affects me, and I can tell you, it makes editing a 20 page document to
an unpleasant experience.

Chris Halls (credativ) (halls) wrote :

(In reply to comment #19)
> Hm. I have a *lot* of weird fonts in OO.

See also bug #12018

> I've done a clean warty > Hoary upgrade, and there are fonts there that I have
> never heard of.
> Times new roman is not among them, by the way.

Times New Roman is only available if you download it by installing msttcorefonts.

merge 293213 293219
severity 279949 wishlist
reassign 293015 openoffice.org-dev
reassign 261895 openoffice.org
severity 261895 normal
merge 276511 249089 261895
reassign 271540 openoffice.org
severity 284014 grave
merge 284014 284096 289715 294628
reassign 273020 openoffice.org
reassign 288463 openoffice.org
reassign 288240 openoffice.org
thanks

Grüße/Regards,

René
--
"Freiheit ist ein Gut, das durch Gebrauch wächst,
durch Nichtgebrauch dahinschwindet.
  -- Carl Friedrich v. Weizsäcker

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 14 Feb 2005 06:17:46 +0100
From: Rene Engelhard <email address hidden>
To: <email address hidden>
Subject: bug maintenance

merge 293213 293219
severity 279949 wishlist
reassign 293015 openoffice.org-dev
reassign 261895 openoffice.org
severity 261895 normal
merge 276511 249089 261895
reassign 271540 openoffice.org
severity 284014 grave
merge 284014 284096 289715 294628
reassign 273020 openoffice.org
reassign 288463 openoffice.org
reassign 288240 openoffice.org
thanks

Gr�gards,

Ren�-
"Freiheit ist ein Gut, das durch Gebrauch w�st,
durch Nichtgebrauch dahinschwindet.
  -- Carl Friedrich v. Weizs�er

Matt Zimmerman (mdz) wrote :

Chris, is there anything we can do about this bug for Hoary?

It seems to affect both openoffice.org and openoffice.org2, and I have no idea
what the problem is

Matthew East (mdke) wrote :

I've installed gsfonts and gsfonts-x11 and the problem is not solved. Maybe this
package does not provide the font after all?

On the other hand, maybe the font itself is the problem: this looks related.
http://bugs.gentoo.org/show_bug.cgi?id=77519

Chris Halls (credativ) (halls) wrote :

Thanks for the references. That Red Hat bug report says the weight inside the
font was incorrect and they fixed it by modifying the font file itself. I'll
have to find out what that change was and if we are missing the fix in our packages.

Matthias Klose (doko) wrote :

fixing gsfonts package

Matthias Klose (doko) wrote :

fixed in gsfonts_8.14+v8.11-0.1ubuntu1

Matthew East (mdke) wrote :

brilliant thanks! works beautifully.

tag 249089 + fixed
tag 261895 + fixed
tag 276511 + fixed
tag 279544 + fixed

quit

This message was generated automatically in response to a
non-maintainer upload. The .changes file follows.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sun, 3 Apr 2005 01:00:14 +0200
Source: gsfonts
Binary: gsfonts
Architecture: source all
Version: 8.14+v8.11+urw-0.2
Distribution: unstable
Urgency: medium
Maintainer: Masayuki Hatta (mhatta) <email address hidden>
Changed-By: Matthias Klose <email address hidden>
Description:
 gsfonts - Fonts for the Ghostscript interpreter(s)
Closes: 249089 261895 276511 279544
Changes:
 gsfonts (8.14+v8.11+urw-0.2) unstable; urgency=medium
 .
   * Merge 8.14+v8.11-0.1ubuntu1, fix font weight of the Nimbus Roman No 9 L
     fonts (closes: #249089, #261895, #276511, #279544).
Files:
 26bb3fc8488bb6fb3e6048f79a8512ea 673 text optional gsfonts_8.14+v8.11+urw-0.2.dsc
 2cb7e11237f4f768fe3280639de1eae4 244853 text optional gsfonts_8.14+v8.11+urw-0.2.diff.gz
 594e875724666ddba788f1b91d5ffdee 3721928 text optional gsfonts_8.14+v8.11+urw-0.2_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFCTyT8StlRaw+TLJwRAt52AJ91fekAUSS637lXDyJSLYWlvlTU1ACfR1E3
+uVXsmEuGVeFhVFGHz4ZGQM=
=3/5f
-----END PGP SIGNATURE-----

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Sat, 02 Apr 2005 18:02:23 -0500
From: Matthias Klose <email address hidden>
To: <email address hidden>
Cc: Matthias Klose <email address hidden>, Masayuki Hatta (mhatta) <email address hidden>
Subject: Fixed in NMU of gsfonts 8.14+v8.11+urw-0.2

tag 249089 + fixed
tag 261895 + fixed
tag 276511 + fixed
tag 279544 + fixed

quit

This message was generated automatically in response to a
non-maintainer upload. The .changes file follows.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sun, 3 Apr 2005 01:00:14 +0200
Source: gsfonts
Binary: gsfonts
Architecture: source all
Version: 8.14+v8.11+urw-0.2
Distribution: unstable
Urgency: medium
Maintainer: Masayuki Hatta (mhatta) <email address hidden>
Changed-By: Matthias Klose <email address hidden>
Description:
 gsfonts - Fonts for the Ghostscript interpreter(s)
Closes: 249089 261895 276511 279544
Changes:
 gsfonts (8.14+v8.11+urw-0.2) unstable; urgency=medium
 .
   * Merge 8.14+v8.11-0.1ubuntu1, fix font weight of the Nimbus Roman No 9 L
     fonts (closes: #249089, #261895, #276511, #279544).
Files:
 26bb3fc8488bb6fb3e6048f79a8512ea 673 text optional gsfonts_8.14+v8.11+urw-0.2.dsc
 2cb7e11237f4f768fe3280639de1eae4 244853 text optional gsfonts_8.14+v8.11+urw-0.2.diff.gz
 594e875724666ddba788f1b91d5ffdee 3721928 text optional gsfonts_8.14+v8.11+urw-0.2_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFCTyT8StlRaw+TLJwRAt52AJ91fekAUSS637lXDyJSLYWlvlTU1ACfR1E3
+uVXsmEuGVeFhVFGHz4ZGQM=
=3/5f
-----END PGP SIGNATURE-----

# Automatically generated email from bts, devscripts version 2.9.22
reassign 249089 gsfonts
close 249089 8.14+v8.11+urw-0.2

Changed in openoffice.org:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.