Packages shouldn't depend on the transitional package python-gobject

Bug #778054 reported by Fred
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
Fix Released
Low
Unassigned
Trusty
Fix Released
Undecided
Unassigned
desktopcouch (Ubuntu)
Invalid
Undecided
Unassigned
eglibc (Ubuntu)
Invalid
Undecided
Unassigned
Trusty
Won't Fix
Undecided
Unassigned
gnome-utils (Ubuntu)
Invalid
Undecided
Unassigned
libreoffice (Ubuntu)
Fix Released
Undecided
Unassigned
Trusty
Fix Released
Undecided
Unassigned
openoffice.org (Ubuntu)
Invalid
Undecided
Unassigned
system-config-printer (Ubuntu)
Fix Released
Medium
Unassigned
Trusty
Fix Released
Medium
Unassigned
wine1.4 (Ubuntu)
Invalid
Undecided
Unassigned
zeitgeist (Ubuntu)
Fix Released
Low
Brian Murray
Trusty
Fix Released
Low
Brian Murray

Bug Description

[Impact]

python-zeitgeist depends on python-gobject, which means python-gobject cannot be removed from the system. python-gobject is a transitional package, and packages should be updated to no longer depend on it.

[Test Case]

* Install python-zeitgeist, and verify that python-gobject is not installed with it.

* If it is already installed, you should be able to run 'apt-get purge python-gobject' without removing python-zeitgeist.

[Regression Potential]

Negligible. There are no code changes. The fix only removes a dependency on a transitional package that doesn't provide any files.

---

[Impact]

system-config-printer-gnome depends on python-gobject, which means python-gobject cannot be removed from the system. python-gobject is a transitional package, and packages should be updated to no longer depend on it.

[Test Case]

* Install system-config-printer-gnome, and verify that python-gobject is not installed with it.

* If it is already installed, you should be able to run 'apt-get purge python-gobject' without removing system-config-printer-gnome.

[Regression Potential]

Negligible. There are no code changes. The fix only removes a dependency on a transitional package that doesn't provide any files.

affects: openoffice.org (Ubuntu) → desktopcouch (Ubuntu)
affects: desktopcouch (Ubuntu) → openoffice.org (Ubuntu)
Revision history for this message
Fred (eldmannen+launchpad) wrote :

I found a workaround.

$ sudo apt-get remove libreoffice-help-en-gb libreoffice-l10n-common libreoffice-l10n-en-gb libreoffice-l10n-en-za
$ sudo apt-get install libreoffice-help-en-gb libreoffice-l10n-common libreoffice-l10n-en-gb libreoffice-l10n-en-za

Now the system wont try to remove the packages.

Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Fred, thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect -p openoffice.org-writer 778054
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in openoffice.org (Ubuntu):
status: New → Incomplete
Changed in libreoffice (Ubuntu):
status: New → Incomplete
Changed in gnome-utils (Ubuntu):
status: New → Incomplete
Changed in desktopcouch (Ubuntu):
status: New → Incomplete
Revision history for this message
Fred (eldmannen+launchpad) wrote :

I can't since those packages are no longer installed, since I did the workaround.

Following packages are marked as transitional, yet I am unable to remove them.
* multiarch-support
* python-aptdaemon-gtk

tags: added: apport-collected natty
description: updated
Revision history for this message
Fred (eldmannen+launchpad) wrote : Dependencies.txt

apport information

description: updated
Revision history for this message
Fred (eldmannen+launchpad) wrote :

apport information

Changed in openoffice.org (Ubuntu):
status: Incomplete → Won't Fix
Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote : migrating packaging from OpenOffice.org to Libreoffice

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

Revision history for this message
Sebastian Heinlein (glatzor) wrote : Re: Trouble when removing transitional packages

Could please provide more details about what happens if you want to remove python-aptdaemon-gtk? Any error messages?

Changed in aptdaemon (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
Revision history for this message
Fred (eldmannen+launchpad) wrote :

wine1.4-common
Description: This is a transitional package to ease upgrades of older versions and contains no files.

The following packages were automatically installed and are no longer required:
  libopenal1:i386 libstdc++6:i386 libxfixes3:i386 libnet-ssleay-perl libldap-2.4-2:i386 liblcms1:i386 gnome-exe-thumbnailer libroken18-heimdal:i386 libgphoto2-port0:i386 libjpeg-turbo8:i386 libjpeg8:i386 liburi-perl libhtml-parser-perl
  libxxf86vm1:i386 libhttp-daemon-perl libgl1-mesa-dri:i386 libxcb-glx0:i386 libasn1-8-heimdal:i386 libgl1-mesa-glx:i386 libfont-afm-perl libhttp-negotiate-perl libfile-listing-perl libhtml-form-perl libx11-xcb1:i386 libgnutls26:i386
  libglapi-mesa:i386 libgssapi3-heimdal:i386 libtasn1-3:i386 libfreetype6:i386 libexpat1:i386 libhtml-tree-perl libencode-locale-perl libhttp-date-perl libmailtools-perl liblwp-protocol-https-perl libxcb1:i386 libp11-kit0:i386
  libwind0-heimdal:i386 libxau6:i386 libhttp-cookies-perl winetricks libhttp-message-perl libnet-http-perl icoutils libice6:i386 libxdmcp6:i386 libxml2:i386 libasound2:i386 libxpm4:i386 libusb-0.1-4:i386 cabextract
  libhcrypto4-heimdal:i386 liborc-0.4-0:i386 libhtml-format-perl libhx509-5-heimdal:i386 libgd2-xpm:i386 libheimbase1-heimdal:i386 libgstreamer-plugins-base0.10-0:i386 libsocket6-perl libmpg123-0 libmpg123-0:i386 libx11-6:i386
  libsasl2-2:i386 libfontconfig1:i386 ttf-mscorefonts-installer libhtml-tagset-perl libsm6:i386 libheimntlm0-heimdal:i386 libxdamage1:i386 libwww-perl libexif12:i386 libglu1-mesa:i386 libgstreamer0.10-0:i386 libio-socket-ssl-perl
  libxext6:i386 libsasl2-modules:i386 libwww-robotrules-perl liblwp-mediatypes-perl libsqlite3-0:i386 libltdl7:i386 libkrb5-26-heimdal:i386 libllvm3.0:i386 libio-socket-inet6-perl libgphoto2-2:i386
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  wine1.4 wine1.4-amd64 wine1.4-common wine1.4-i386:i386
0 upgraded, 0 newly installed, 4 to remove and 1 not upgraded.
Remv wine1.4-i386:i386 [1.4-0ubuntu4] [wine1.4:amd64 ]
Remv wine1.4-common [1.4-0ubuntu4] [wine1.4-amd64:amd64 wine1.4:amd64 ]
Remv wine1.4 [1.4-0ubuntu4] [wine1.4-amd64:amd64 ]
Remv wine1.4-amd64 [1.4-0ubuntu4]

Revision history for this message
Fred (eldmannen+launchpad) wrote :

python-gobject
Python 2.x bindings for GObject - transitional package
You can remove it safely when nothing else depends on it.

The following packages were automatically installed and are no longer required:
  python-mako libdmapsharing-3.0-2 rhythmbox-data printer-driver-sag-gdi python-markupsafe activity-log-manager-common
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  activity-log-manager-control-center alacarte checkbox-gtk gnome-orca python-appindicator python-gobject python-gst0.10 python-gtksourceview2 python-indicate python-pyatspi2 python-zeitgeist rhythmbox rhythmbox-plugin-cdrecorder
  rhythmbox-plugins sessioninstaller system-config-printer-gnome ubuntu-desktop update-manager update-notifier zeitgeist zeitgeist-core zeitgeist-datahub zeitgeist-extension-fts

Revision history for this message
Fred (eldmannen+launchpad) wrote :

multiarch-support
Transitional package to ensure multiarch compatibility
It can be removed once nothing on the system depends on it.

The following packages were automatically installed and are no longer required:
  folks-common wireless-regdb fonts-opensymbol libopenal-data libexttextcat-data libssl-doc fonts-droid activity-log-manager-common
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  {{ tons of packages here, more than thousands, too many to list }}
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  apt libapt-pkg4.12 (due to apt) libc6 (due to apt) libgcc1 (due to apt) libstdc++6 (due to apt) gnupg (due to apt) dpkg (due to apt) base-files base-passwd bash debianutils (due to bash) dash (due to bash) libtinfo5 (due to bash)
  bsdutils coreutils install-info (due to coreutils) libacl1 (due to coreutils) libattr1 (due to coreutils) libselinux1 (due to coreutils) diffutils libbz2-1.0 (due to dpkg) zlib1g (due to dpkg) tar (due to dpkg) xz-utils (due to dpkg)
  e2fsprogs e2fslibs (due to e2fsprogs) libblkid1 (due to e2fsprogs) libcomerr2 (due to e2fsprogs) libss2 (due to e2fsprogs) libuuid1 (due to e2fsprogs) util-linux (due to e2fsprogs) findutils grep gzip hostname login libpam0g (due to
  login) libpam-runtime (due to login) libpam-modules (due to login) mount libmount1 (due to mount) ncurses-bin perl-base python-minimal python2.7-minimal (due to python-minimal) sed lsb-base (due to util-linux) tzdata (due to
  util-linux) debconf (due to util-linux) libncurses5 (due to util-linux) libslang2 (due to util-linux)
0 upgraded, 0 newly installed, 1621 to remove and 0 not upgraded.

Revision history for this message
Fred (eldmannen+launchpad) wrote :

Sebastian Heinlein (glatzor),
There is no 'python-aptdaemon-gtk' package installed on my system anymore.
I guess this got solved.

Revision history for this message
Martin Pitt (pitti) wrote :

This is not a pygobject bug. Packages such as system-config-printer or python-zeitgeist need to drop the python-gobject dependency and either move to python-gobject-2 (for the static bindings) or python-gi (for GI bindings).

affects: pygobject (Ubuntu) → system-config-printer (Ubuntu)
Changed in system-config-printer (Ubuntu):
status: New → Triaged
Revision history for this message
Adam Conrad (adconrad) wrote :

The multiarch-support package can't be removed pretty much by design. Once the transition is all well and complete (after an LTS or two), it might go away.

Changed in eglibc (Ubuntu):
status: New → Invalid
Changed in libreoffice (Ubuntu):
status: Incomplete → Invalid
Revision history for this message
Scott Ritchie (scottritchie) wrote :

wine1.4-common went away properly in raring. It's a transitional package in precise but not for the traditional reason (a package rename), but rather as a workaround to ensure the multiarch dependencies work out correctly when upgrading from 10.04. While it contained no files, it did have a purpose in making the dependency chain resolve correctly.

Quantal has it too, but only because I forgot to remove it.

Changed in wine1.4 (Ubuntu):
status: New → Fix Released
Revision history for this message
Mathew Hodson (mhodson) wrote :

Attached debdiff for system-config-printer-gnome for trusty SRU. Now it depends on python-gi and python-gobject-2 instead of python-gobject. No other changes.

Changed in system-config-printer (Ubuntu):
assignee: nobody → Mathew Hodson (mathew-hodson)
status: Triaged → In Progress
tags: added: trusty
Revision history for this message
Mathew Hodson (mhodson) wrote :

Marking aptdaemon Fix Released due to comment 11.

Changed in aptdaemon (Ubuntu):
status: Incomplete → Fix Released
Changed in gnome-utils (Ubuntu):
status: Incomplete → Invalid
Revision history for this message
Mathew Hodson (mhodson) wrote :

gnome-utils and desktopcouch are no longer packaged.

Changed in desktopcouch (Ubuntu):
status: Incomplete → Invalid
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "system-config-printer-gnome.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Artur Rona (ari-tczew)
Changed in system-config-printer (Ubuntu):
assignee: Mathew Hodson (mathew-hodson) → nobody
importance: Undecided → Medium
status: In Progress → Confirmed
Revision history for this message
Michael Vogt (mvo) wrote :

The version of system-config-printer in utopic does no longer depend on python-gobject.

Changed in system-config-printer (Ubuntu):
status: Confirmed → Fix Released
Mathew Hodson (mhodson)
Changed in desktopcouch (Ubuntu Trusty):
status: New → Invalid
Changed in openoffice.org (Ubuntu Trusty):
status: New → Invalid
Changed in wine1.4 (Ubuntu Trusty):
status: New → Invalid
Changed in gnome-utils (Ubuntu Trusty):
status: New → Invalid
Mathew Hodson (mhodson)
tags: removed: migrateoootolo transitional
Mathew Hodson (mhodson)
description: updated
description: updated
Mathew Hodson (mhodson)
Changed in libreoffice (Ubuntu):
status: Invalid → Fix Released
Changed in libreoffice (Ubuntu Trusty):
status: New → Fix Released
Mathew Hodson (mhodson)
Changed in aptdaemon (Ubuntu Trusty):
status: New → Fix Released
Revision history for this message
Mathew Hodson (mhodson) wrote :

system-config-printer is the only issue from this bug that remains on trusty.

I guess the eglibc tasks should be marked Won't Fix based on comment #13.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Uploaded the fixed package (with the attached patch applied) to trusty-proposed. As sson as the package gets approved it will get available for testing and appropriate testing instructions posted here. Please test the package then as your feedback is required for the package to get an official update. Thanks.

Changed in system-config-printer (Ubuntu Trusty):
importance: Undecided → Medium
status: New → In Progress
Revision history for this message
Fred (eldmannen+launchpad) wrote :

$ apt-get -s remove python-gobject
The following packages will be REMOVED:
  python-appindicator python-gobject python-zeitgeist redshift-gtk zeitgeist
0 upgraded, 0 newly installed, 5 to remove and 0 not upgraded.
Remv redshift-gtk [1.8-0ubuntu6]
Remv python-appindicator [12.10.1+13.10.20130920-0ubuntu4]
Remv zeitgeist [0.9.14-2.2ubuntu2]
Remv python-zeitgeist [0.9.14-2.2ubuntu2]
Remv python-gobject [3.14.0-1]

Revision history for this message
Chris J Arges (arges) wrote : Please test proposed package

Hello Fred, or anyone else affected,

Accepted system-config-printer into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/system-config-printer/1.4.3+20140219-0ubuntu2.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in system-config-printer (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Mathew Hodson (mhodson) wrote : Re: Trouble when removing transitional packages

Verified that system-config-printer-gnome 1.4.3+20140219-0ubuntu2.2 doesn't depend on python-gobject.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.4.3+20140219-0ubuntu2.2

---------------
system-config-printer (1.4.3+20140219-0ubuntu2.2) trusty-proposed; urgency=medium

  * Depends on python-gi and python-gobject-2 instead of python-gobject,
    because it is a transitional package (LP: #778054)
 -- Mathew Hodson <email address hidden> Tue, 12 Aug 2014 23:21:40 -0400

Changed in system-config-printer (Ubuntu Trusty):
status: Fix Committed → Fix Released
Revision history for this message
Chris J Arges (arges) wrote : Update Released

The verification of the Stable Release Update for system-config-printer has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Mathew Hodson (mhodson) wrote : Re: Trouble when removing transitional packages

Attached debdiff for zeitgeist for trusty SRU. Now it depends on python-gi and python-gobject-2 instead of python-gobject. No other changes.

Revision history for this message
Mathew Hodson (mhodson) wrote :
Mathew Hodson (mhodson)
Changed in zeitgeist (Ubuntu):
status: New → In Progress
Changed in eglibc (Ubuntu Trusty):
status: New → Invalid
Changed in zeitgeist (Ubuntu Trusty):
status: New → In Progress
Mathew Hodson (mhodson)
description: updated
Mathew Hodson (mhodson)
tags: added: packaging
Mathew Hodson (mhodson)
summary: - Trouble when removing transitional packages
+ Packages shouldn't depend on the transitional package python-gobject
Mathew Hodson (mhodson)
Changed in zeitgeist (Ubuntu):
status: In Progress → Confirmed
Changed in zeitgeist (Ubuntu Trusty):
status: In Progress → Confirmed
Changed in zeitgeist (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
importance: Undecided → Low
status: Confirmed → In Progress
Changed in zeitgeist (Ubuntu Trusty):
assignee: nobody → Brian Murray (brian-murray)
importance: Undecided → Low
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zeitgeist - 0.9.14-2.2ubuntu3

---------------
zeitgeist (0.9.14-2.2ubuntu3) vivid; urgency=medium

  * Depend on python-gobject-2 and python-gi instead of python-gobject,
    because it's a transitional package (LP: #778054)
 -- Mathew Hodson <email address hidden> Tue, 10 Mar 2015 08:55:16 -0700

Changed in zeitgeist (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Timo Aaltonen (tjaalton) wrote : Please test proposed package

Hello Fred, or anyone else affected,

Accepted zeitgeist into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/zeitgeist/0.9.14-0ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in zeitgeist (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Revision history for this message
Mathew Hodson (mhodson) wrote :

Tested with python-zeitgeist 0.9.14-0ubuntu4.1. Looks good.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zeitgeist - 0.9.14-0ubuntu4.1

---------------
zeitgeist (0.9.14-0ubuntu4.1) trusty; urgency=medium

  * Depend on python-gobject-2 and python-gi instead of python-gobject,
    because it's a transitional package (LP: #778054)
 -- Mathew Hodson <email address hidden> Tue, 10 Mar 2015 09:00:19 -0700

Changed in zeitgeist (Ubuntu Trusty):
status: Fix Committed → Fix Released
Mathew Hodson (mhodson)
no longer affects: wine1.4 (Ubuntu Trusty)
no longer affects: openoffice.org (Ubuntu Trusty)
Changed in eglibc (Ubuntu):
status: Invalid → Won't Fix
Changed in eglibc (Ubuntu Trusty):
status: Invalid → Won't Fix
no longer affects: desktopcouch (Ubuntu Trusty)
no longer affects: gnome-utils (Ubuntu Trusty)
Changed in openoffice.org (Ubuntu):
status: Won't Fix → Invalid
Mathew Hodson (mhodson)
Changed in wine1.4 (Ubuntu):
status: Fix Released → Invalid
Mathew Hodson (mhodson)
Changed in eglibc (Ubuntu):
status: Won't Fix → Invalid
Revision history for this message
bojojo@orange.fr (bojojo-orange) wrote :

"[Bug 778054] Re: Trouble when removing transitional packages"
Fred doc

Revision history for this message
Nenad (nenad-mikanovic) wrote : Salut!

voulez avoir fille ce soir?

cliquez ici

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers