failed to upgrade to natty: openoffice.org-dmaths : Depends: libreoffice-dmaths but it is not installable

Bug #772387 reported by Ken Alves on 2011-04-28
80
This bug affects 10 people
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
High
Björn Michaelsen
Natty
High
Unassigned

Bug Description

Binary package hint: update-manager

2011-04-28 09:18:35,529 INFO Using config files '['./DistUpgrade.cfg']'
2011-04-28 09:18:35,529 INFO uname information: 'Linux Home 2.6.35-28-generic #50-Ubuntu SMP Fri Mar 18 19:00:26 UTC 2011 i686'
2011-04-28 09:18:35,530 INFO release-upgrader version '0.150' started
2011-04-28 09:18:35,808 DEBUG Using 'DistUpgradeViewKDE' view
2011-04-28 09:18:35,829 DEBUG aufsOptionsAndEnvironmentSetup()
2011-04-28 09:18:35,830 DEBUG using '/tmp/upgrade-rw-4Pi09e' as aufs_rw_dir
2011-04-28 09:18:35,830 DEBUG using '/tmp/upgrade-chroot-UUbvq9' as aufs chroot dir
2011-04-28 09:18:35,830 DEBUG enable dpkg --force-overwrite
2011-04-28 09:18:35,837 DEBUG creating statefile: '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'
2011-04-28 09:18:37,691 DEBUG lsb-release: 'maverick'
2011-04-28 09:18:37,692 DEBUG _pythonSymlinkCheck run
2011-04-28 09:18:37,713 DEBUG openCache()
2011-04-28 09:18:38,098 DEBUG /openCache(), new cache size 32338
2011-04-28 09:18:38,098 DEBUG needServerMode(): run in 'desktop' mode, (because of pkg 'kubuntu-desktop')
2011-04-28 09:18:38,098 DEBUG checkViewDepends()
2011-04-28 09:18:38,099 DEBUG running doUpdate() (showErrors=False)
2011-04-28 09:18:58,173 DEBUG openCache()
2011-04-28 09:19:00,051 DEBUG /openCache(), new cache size 32338
2011-04-28 09:19:00,051 DEBUG doPostInitialUpdate
2011-04-28 09:19:00,052 DEBUG Plugin modules in ./plugins: langpack_manual_plugin.py remove_lilo_plugin.py dpkg_status_plugin.py kdelibs4to5_plugin.py deb_plugin.py
2011-04-28 09:19:00,052 DEBUG Loading module ./plugins/langpack_manual_plugin.py
2011-04-28 09:19:00,053 DEBUG Plugins in <module 'langpack_manual_plugin' from './plugins/langpack_manual_plugin.py'>: <class 'langpack_manual_plugin.MarkLangpacksManuallyInstalledPlugin'>
2011-04-28 09:19:00,053 DEBUG Loading module ./plugins/remove_lilo_plugin.py
2011-04-28 09:19:00,053 DEBUG Plugins in <module 'remove_lilo_plugin' from './plugins/remove_lilo_plugin.py'>: <class 'remove_lilo_plugin.RemoveLiloPlugin'>
2011-04-28 09:19:00,053 DEBUG Loading module ./plugins/dpkg_status_plugin.py
2011-04-28 09:19:00,054 DEBUG Plugins in <module 'dpkg_status_plugin' from './plugins/dpkg_status_plugin.py'>: <class 'dpkg_status_plugin.DpkgStatusPlugin'>
2011-04-28 09:19:00,054 DEBUG Loading module ./plugins/kdelibs4to5_plugin.py
2011-04-28 09:19:00,055 DEBUG Plugins in <module 'kdelibs4to5_plugin' from './plugins/kdelibs4to5_plugin.py'>: <class 'kdelibs4to5_plugin.Kdelibs4devToKdelibs5devPlugin'>
2011-04-28 09:19:00,055 DEBUG Loading module ./plugins/deb_plugin.py
2011-04-28 09:19:00,055 DEBUG Plugins in <module 'deb_plugin' from './plugins/deb_plugin.py'>: <class 'deb_plugin.DebPlugin'>
2011-04-28 09:19:00,055 DEBUG plugins for condition 'PostInitialUpdate' are '[]'
2011-04-28 09:19:00,055 DEBUG plugins for condition 'nattyPostInitialUpdate' are '[]'
2011-04-28 09:19:00,055 DEBUG plugins for condition 'from_maverickPostInitialUpdate' are '[]'
2011-04-28 09:19:03,531 DEBUG Foreign: wine1.3-gecko google-chrome-stable ttf-symbol-replacement-wine1.3 winetricks wine1.3 gstreamer0.10-fluendo-plugins-mp3-partner
2011-04-28 09:19:03,531 DEBUG Obsolete: virtualbox-4.0
2011-04-28 09:19:03,532 DEBUG updateSourcesList()
2011-04-28 09:19:03,573 DEBUG rewriteSourcesList()
2011-04-28 09:19:03,576 DEBUG examining: 'deb http://us.archive.ubuntu.com/ubuntu/ maverick main restricted'
2011-04-28 09:19:03,576 DEBUG entry 'deb http://us.archive.ubuntu.com/ubuntu/ natty main restricted' updated to new dist
2011-04-28 09:19:03,576 DEBUG examining: 'deb-src http://us.archive.ubuntu.com/ubuntu/ maverick main restricted'
2011-04-28 09:19:03,576 DEBUG entry 'deb-src http://us.archive.ubuntu.com/ubuntu/ natty main restricted' updated to new dist
2011-04-28 09:19:03,577 DEBUG examining: 'deb http://us.archive.ubuntu.com/ubuntu/ maverick-updates main restricted'
2011-04-28 09:19:03,577 DEBUG entry 'deb http://us.archive.ubuntu.com/ubuntu/ natty-updates main restricted' updated to new dist
2011-04-28 09:19:03,577 DEBUG examining: 'deb-src http://us.archive.ubuntu.com/ubuntu/ maverick-updates main restricted'
2011-04-28 09:19:03,577 DEBUG entry 'deb-src http://us.archive.ubuntu.com/ubuntu/ natty-updates main restricted' updated to new dist
2011-04-28 09:19:03,577 DEBUG examining: 'deb http://us.archive.ubuntu.com/ubuntu/ maverick universe'
2011-04-28 09:19:03,577 DEBUG entry 'deb http://us.archive.ubuntu.com/ubuntu/ natty universe' updated to new dist
2011-04-28 09:19:03,577 DEBUG examining: 'deb-src http://us.archive.ubuntu.com/ubuntu/ maverick universe'
2011-04-28 09:19:03,577 DEBUG entry 'deb-src http://us.archive.ubuntu.com/ubuntu/ natty universe' updated to new dist
2011-04-28 09:19:03,577 DEBUG examining: 'deb http://us.archive.ubuntu.com/ubuntu/ maverick-updates universe'
2011-04-28 09:19:03,577 DEBUG entry 'deb http://us.archive.ubuntu.com/ubuntu/ natty-updates universe' updated to new dist
2011-04-28 09:19:03,577 DEBUG examining: 'deb-src http://us.archive.ubuntu.com/ubuntu/ maverick-updates universe'
2011-04-28 09:19:03,577 DEBUG entry 'deb-src http://us.archive.ubuntu.com/ubuntu/ natty-updates universe' updated to new dist
2011-04-28 09:19:03,577 DEBUG examining: 'deb http://us.archive.ubuntu.com/ubuntu/ maverick multiverse'
2011-04-28 09:19:03,578 DEBUG entry 'deb http://us.archive.ubuntu.com/ubuntu/ natty multiverse' updated to new dist
2011-04-28 09:19:03,578 DEBUG examining: 'deb-src http://us.archive.ubuntu.com/ubuntu/ maverick multiverse'
2011-04-28 09:19:03,578 DEBUG entry 'deb-src http://us.archive.ubuntu.com/ubuntu/ natty multiverse' updated to new dist
2011-04-28 09:19:03,578 DEBUG examining: 'deb http://us.archive.ubuntu.com/ubuntu/ maverick-updates multiverse'
2011-04-28 09:19:03,578 DEBUG entry 'deb http://us.archive.ubuntu.com/ubuntu/ natty-updates multiverse' updated to new dist
2011-04-28 09:19:03,578 DEBUG examining: 'deb-src http://us.archive.ubuntu.com/ubuntu/ maverick-updates multiverse'
2011-04-28 09:19:03,578 DEBUG entry 'deb-src http://us.archive.ubuntu.com/ubuntu/ natty-updates multiverse' updated to new dist
2011-04-28 09:19:03,578 DEBUG examining: 'deb http://us.archive.ubuntu.com/ubuntu/ maverick-backports main restricted universe multiverse'
2011-04-28 09:19:03,578 DEBUG entry 'deb http://us.archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse' updated to new dist
2011-04-28 09:19:03,578 DEBUG examining: 'deb http://archive.canonical.com/ubuntu/ maverick partner'
2011-04-28 09:19:03,578 DEBUG entry 'deb http://archive.canonical.com/ubuntu/ natty partner' updated to new dist
2011-04-28 09:19:03,578 DEBUG examining: 'deb-src http://archive.canonical.com/ubuntu/ maverick partner'
2011-04-28 09:19:03,579 DEBUG entry 'deb-src http://archive.canonical.com/ubuntu/ natty partner' updated to new dist
2011-04-28 09:19:03,579 DEBUG examining: 'deb http://extras.ubuntu.com/ubuntu/ maverick main'
2011-04-28 09:19:03,579 DEBUG entry 'deb http://extras.ubuntu.com/ubuntu/ natty main' updated to new dist
2011-04-28 09:19:03,579 DEBUG examining: 'deb-src http://extras.ubuntu.com/ubuntu/ maverick main'
2011-04-28 09:19:03,579 DEBUG entry 'deb-src http://extras.ubuntu.com/ubuntu/ natty main' updated to new dist
2011-04-28 09:19:03,579 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu/ maverick-security main restricted'
2011-04-28 09:19:03,579 DEBUG entry 'deb http://security.ubuntu.com/ubuntu/ natty-security main restricted' updated to new dist
2011-04-28 09:19:03,579 DEBUG examining: 'deb-src http://security.ubuntu.com/ubuntu/ maverick-security main restricted'
2011-04-28 09:19:03,579 DEBUG entry 'deb-src http://security.ubuntu.com/ubuntu/ natty-security main restricted' updated to new dist
2011-04-28 09:19:03,579 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu/ maverick-security universe'
2011-04-28 09:19:03,579 DEBUG entry 'deb http://security.ubuntu.com/ubuntu/ natty-security universe' updated to new dist
2011-04-28 09:19:03,579 DEBUG examining: 'deb-src http://security.ubuntu.com/ubuntu/ maverick-security universe'
2011-04-28 09:19:03,580 DEBUG entry 'deb-src http://security.ubuntu.com/ubuntu/ natty-security universe' updated to new dist
2011-04-28 09:19:03,580 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu/ maverick-security multiverse'
2011-04-28 09:19:03,580 DEBUG entry 'deb http://security.ubuntu.com/ubuntu/ natty-security multiverse' updated to new dist
2011-04-28 09:19:03,580 DEBUG examining: 'deb-src http://security.ubuntu.com/ubuntu/ maverick-security multiverse'
2011-04-28 09:19:03,580 DEBUG entry 'deb-src http://security.ubuntu.com/ubuntu/ natty-security multiverse' updated to new dist
2011-04-28 09:19:03,580 DEBUG examining: 'deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu maverick main'
2011-04-28 09:19:03,582 DEBUG entry '# deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu natty main # disabled on upgrade to natty' was disabled (unknown mirror)
2011-04-28 09:19:03,582 DEBUG examining: 'deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu maverick main'
2011-04-28 09:19:03,585 DEBUG entry '# deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu natty main # disabled on upgrade to natty' was disabled (unknown mirror)
2011-04-28 09:19:03,585 DEBUG examining: 'deb http://archive.canonical.com/ maverick partner #added by U1MusicStoreWidget'
2011-04-28 09:19:03,585 DEBUG entry 'deb http://archive.canonical.com/ natty partner #added by U1MusicStoreWidget' updated to new dist
2011-04-28 09:19:03,585 DEBUG examining: 'deb http://dl.google.com/linux/chrome/deb/ stable main'
2011-04-28 09:19:03,588 DEBUG entry '# deb http://dl.google.com/linux/chrome/deb/ stable main # disabled on upgrade to natty' was disabled (unknown mirror)
2011-04-28 09:30:05,951 DEBUG running doUpdate() (showErrors=True)
2011-04-28 09:32:24,098 DEBUG openCache()
2011-04-28 09:32:24,099 DEBUG failed to SystemUnLock() (E:Not locked)
2011-04-28 09:32:26,342 DEBUG /openCache(), new cache size 33602
2011-04-28 09:32:26,343 DEBUG needServerMode(): run in 'desktop' mode, (because of pkg 'kubuntu-desktop')
2011-04-28 09:36:51,054 ERROR Dist-upgrade failed: 'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'
2011-04-28 09:36:51,055 DEBUG abort called
2011-04-28 09:36:51,078 DEBUG openCache()
2011-04-28 09:36:51,078 DEBUG failed to SystemUnLock() (E:Not locked)
2011-04-28 09:36:52,974 DEBUG /openCache(), new cache size 32338
2011-04-28 09:36:52,975 DEBUG enabling apt cron job

Jean-Baptiste Lallement (jibel) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add the log files from '/var/log/dist-upgrade/' to this bug report as separate attachments? Thanks in advance.

Changed in update-manager (Ubuntu):
status: New → Incomplete
Ken Alves (knalves) wrote :
Ken Alves (knalves) wrote :
Ken Alves (knalves) wrote :
Ken Alves (knalves) wrote :

The file "term.log" is empty. Do you need the file: apt-clone_system_state.tar.gz?

Regards,
Ken

Jean-Baptiste Lallement (jibel) wrote :

The upgrade failed because
openoffice.org-dmaths : Depends: libreoffice-dmaths but it is not installable

This looks like a missing transition from openoffice to libreoffice.

Marking as triaged and affecting to libreoffice.

summary: - Update-manager failed to upgrade
+ failed to upgrade to natty: openoffice.org-dmaths : Depends:
+ libreoffice-dmaths but it is not installable
affects: update-manager (Ubuntu) → libreoffice (Ubuntu)
Changed in libreoffice (Ubuntu):
importance: Undecided → High
status: Incomplete → Triaged
Ken Alves (knalves) wrote :

I removed openoffice.org-dmaths and the upgrade is working.

Thanks,
Ken

Changed in libreoffice (Ubuntu Natty):
status: New → Triaged
importance: Undecided → High
milestone: none → natty-updates

A quick check at debian shows no libreoffice-dmath package on their latest release:

 http://packages.debian.org/source/sid/libreoffice

although there is a transitional openoffice.org-dmath package depending on it:

 http://packages.debian.org/sid/openoffice.org-dmaths

Harris Georgiou (xgeorgio) wrote :

Confirmed, removing openoffice.org-dmaths makes the upgrade process work properly.
Tried it on Acer Aspire ONE (netbook), upgrading a fully updated 10.10 to 11.04, still not complete but seems fine so far.

Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
status: Triaged → Fix Committed
Thomas J. Girsch (tgirsch) wrote :

I removed OpenOffice.org and I was able to run the upgrade successfully.

Tiago (tcavaleiro) wrote :

Confirmed the workaround of removing package 'openoffice.org-dmaths'.

Retried the ugprade again with success.

tags: added: patch
Martin Pitt (pitti) on 2011-05-03
affects: libreoffice (Ubuntu) → openoffice.org (Ubuntu)

Accepted openoffice.org into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in openoffice.org (Ubuntu Natty):
status: Triaged → Fix Committed
tags: added: verification-needed

SRU verification for Natty:
I have reproduced the problem with openoffice.org 1:3.3.0-7ubuntu1 in natty and have verified that the version of openoffice.org 1:3.3.0-7ubuntu2 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openoffice.org - 1:3.3.0-7ubuntu2

---------------
openoffice.org (1:3.3.0-7ubuntu2) natty-proposed; urgency=low

  * remove broken package deps (LP: #772387)
 -- Bjoern Michaelsen <email address hidden> Thu, 28 Apr 2011 19:36:19 +0200

Changed in openoffice.org (Ubuntu Natty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to oneiric as well.

Changed in openoffice.org (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions