soffice.bin crashed with SIGSEGV in cppu::throwException()

Bug #753655 reported by Vincent Hindriksen on 2011-04-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org

This time with a fully updated system.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: openoffice.org-core 1:3.2.1-7ubuntu1.1
ProcVersionSignature: Ubuntu 2.6.38-7.39~lucid1-generic-pae 2.6.38
Uname: Linux 2.6.38-7-generic-pae i686
NonfreeKernelModules: nvidia
Architecture: i386
CrashCounter: 1
Date: Wed Apr 6 19:46:01 2011
Disassembly: => 0x9ca563e4: Cannot access memory at address 0x9ca563e4
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/openoffice/program/soffice.bin
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcCmdline: /usr/lib/openoffice/program/soffice.bin -writer /home/username/.evolution/cache/tmp/evolution-username-nX1pj5/Java\ Developer.doc -splash-pipe=5
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=nl_NL.UTF-8
SegvAnalysis:
 Segfault happened at: 0x9ca563e4: Cannot access memory at address 0x9ca563e4
 PC (0x9ca563e4) not located in a known VMA region (needed executable region)!
SegvReason: executing unknown VMA
Signal: 11
SourcePackage: openoffice.org
StacktraceTop:
 ?? ()
 cppu::throwException(com::sun::star::uno::Any const&) () from /usr/lib/openoffice/program/../basis-link/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3
 ucbhelper::cancelCommandExecution(com::sun::star::ucb::IOErrorCode, com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&, com::sun::star::uno::Reference<com::sun::star::ucb::XCommandEnvironment> const&, rtl::OUString const&, com::sun::star::uno::Reference<com::sun::star::ucb::XCommandProcessor> const&) () from /usr/lib/openoffice/program/../basis-link/program/libucbhelper4gcc3.so
 ?? () from /usr/lib/openoffice/program/../basis-link/program/libucpfile1.so
 ?? () from /usr/lib/openoffice/program/../basis-link/program/libucpfile1.so
Title: soffice.bin crashed with SIGSEGV in cppu::throwException()
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev sambashare tape video

StacktraceTop:
 ?? ()
 ?? ()
 uno_Environment_invoke_v ()
 uno_Environment_invoke ()
 ?? () from /usr/lib/ure/lib/libgcc3_uno.so

Changed in openoffice.org (Ubuntu):
status: New → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libc-bin: installed version 2.12.1-0ubuntu10.2, latest version: 2.12.1-0ubuntu10.3
libc6: installed version 2.12.1-0ubuntu10.2, latest version: 2.12.1-0ubuntu10.3

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-i386-retrace
Changed in openoffice.org (Ubuntu):
status: Invalid → Opinion

This is untrue!

libc-bin: installed version 2.12.1-0ubuntu10.2, latest version: 2.12.1-0ubuntu10.3
libc6: installed version 2.12.1-0ubuntu10.2, latest version: 2.12.1-0ubuntu10.3

The latest version is in proposed only: https://launchpad.net/ubuntu/maverick/+package/libc-bin

visibility: private → public
Changed in openoffice.org (Ubuntu):
status: Opinion → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers