[upstream] Anti-aliasing-option in OpenOffice does not work, when Anti-Aliasing is turned off in KDE system settings

Bug #72796 reported by mokka on 2006-11-22
4
Affects Status Importance Assigned to Milestone
OpenOffice
Invalid
Undecided
openoffice.org (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: openoffice.org

Hello,

here is how to reproduce the issue in Kubuntu 6.10 (edgy) :

1. Disable Anti-Aliasing for fonts in KDE via System Settings -> Appearance -> Fonts

2. Enable "Screen font antialiasing" in OpenOffice Writer via Tools -> Options -> OpenOffice.org -> View

But although the antialiasing option is enabled for OpenOffice, the fonts actually aren`t anti-aliased.

This has not been a problem in Kubuntu 6.06 (at least on my machine).
I don`t know if this is an issue in Ubuntu 6.10.

holmbaeck (holmbaeck-gmail) wrote :

Hi

I have the same problem (also running edgy). When using AA in KDE OpenOffice menus and Interface is gray and blurry, and when switching off AA it gets VERY edgy and ugly?

This was not a problem in Dapper. It might however be a problem with OpenOffice 2.0.4?

Brian Murray (brian-murray) wrote :

I can confirm this using openoffice.org in Feisty.

Chris Cheney (ccheney) on 2008-03-15
Changed in openoffice.org:
status: New → In Progress
Chris Cheney (ccheney) on 2008-03-30
Changed in openoffice.org:
status: In Progress → Fix Committed

I believe that this is probably due to the KDE setting turning off anti-aliasing for the whole system. I will forward this bug upstream to see if they can potentially grey out the option in cases that it has no use.

Changed in openoffice.org:
importance: Undecided → Wishlist
status: Fix Committed → Confirmed
Chris Cheney (ccheney) on 2008-06-14
Changed in openoffice.org:
status: Confirmed → Triaged
Chris Cheney (ccheney) on 2008-10-21
Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → In Progress
Chris Cheney (ccheney) on 2010-05-14
tags: added: kubuntu
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

dino99 (9d9) on 2012-08-31
affects: openoffice → libreoffice (Ubuntu)
Changed in libreoffice (Ubuntu):
status: In Progress → Invalid
affects: libreoffice (Ubuntu) → openoffice
Changed in openoffice:
importance: Unknown → Undecided
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.