[Upstream] Writer docx table not parsed correctly

Bug #726454 reported by Glen Luscombe on 2011-02-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice
Invalid
Medium
libreoffice (Ubuntu)
Medium
Unassigned
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org-writer

Hi,

OpenOffice Writer does not appear to be parsing docx tables correctly (Ubuntu 10.10). No issues with Windows XP version. Can attach example docx if required.

==============================
dpkg -l
ii openoffice.org-writer 1:3.2.1-7ubuntu1.1 office productivity suite -- word processor

Jack Leigh (leighman) wrote :

Please do attach a demo file which shows this problem and if possible screenshots of right and wrong.

Changed in openoffice.org (Ubuntu):
status: New → Incomplete
Jack Leigh (leighman) wrote :

You could also try installing Libreoffice 3.3.1 (which will be the default in the next Ubuntu release) from https://launchpad.net/~libreoffice/+archive/ppa and test whether the problem still occurs in that

Glen Luscombe (glenluscombe) wrote :

Hi leighman,

I'll try libreoffice another time when I have more time on my hands, however for the moment I have attached the example demo file, and screenshots of Ubuntu 10.10 vs Windows XP Open Office parsing.

Glen Luscombe (glenluscombe) wrote :
Glen Luscombe (glenluscombe) wrote :
Glen Luscombe (glenluscombe) wrote :
  • example.docx Edit (10.7 KiB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
Jack Leigh (leighman) wrote :

How was this docx produced?
I see the problem in LibreOffice but the file also opens wrong in Word 2007 in Wine

Glen Luscombe (glenluscombe) wrote :
  • example2.docx Edit (99.5 KiB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)

The document was produced in XP Word 2007, however I may have accidentally saved over it with Ubuntu OOO (I tried opening the file and got the same result you did). I had another similar file exhibiting differences in the table parsing, however it was not quite as stark.

I've attached it as example2.docx and well as screenshots.

I'd like to give LibreOffice a try - is it in Ubuntu universe yet or do I need a PPA?

Glen Luscombe (glenluscombe) wrote :
Glen Luscombe (glenluscombe) wrote :

Created attachment 44014
Problem file

Upstreaming from https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/726454

When opening the attached file in LibreOffice in Linux the table is stretched downwards and takes up much more space than when viewed in Word 2007.

The file was produced in Word 2007.
Also apparently displays correctly in OpenOffice on Windows

Created attachment 44015
How the file should look - Word 2007

Jack Leigh (leighman) wrote :

I can confirm this problem in LibO
Upstreamed.

You can download from the ppa linked in #2 or wait for the release of Natty which will use it by default

Changed in libreoffice (Ubuntu):
status: New → Triaged
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in openoffice.org (Ubuntu):
status: Incomplete → New
summary: - openoffice writer linux does not parse docx tables correctly
+ Writer docx table not parsed correctly
tags: added: lo33
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
summary: - Writer docx table not parsed correctly
+ [Upstream] Writer docx table not parsed correctly
Changed in openoffice.org (Ubuntu):
status: New → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

After having deleteted picture (invisible with MS WORD Viewer), what seems to be the main problem here, I see a problem that in WRITER Row with
"LIBRARY Ms Evelina And I" is additionally shown on first page, while in MS WORD viewer that "main row" will be shown on next page.
My knowledge is not sufficient to decide whether that's a general WRITER limitation or related to docx import.

No reaction within a year, so reassigned to List.

@leighman
Such a Multi problems Bug will never be fixed (as you see), we will have to divide into separate bugs for each problem.
<https://wiki.documentfoundation.org/BugReport#General_information>

Please feel free to submit additional Reports (with reference to this sample document) for separate problems you see (and to add me to CC).

I confirm some mistakes with LO 4.1.1 on Windows 7:
- pages 2 and 3 are lost
- on page 1, the table appears "cut" at the bottom of the page

I reproduce the issue described in comment 4 with LibreOffice 4.2.5 and 4.3.1.1 on Linux.

The issue is reproducible in LibreOffice 4.4.0.0-beta1 the same way as in 4.3

The issues mentioned in comment 4 postdate this report. The original issue does not seem to be relevant to the current rendering.

-> RESOLVED WORKSFORME

(Most likely there is a duplicate report for the later issue - I will find/create it and comment the bug number here later)

Bug for floating tables not splitting across pages: bug 61594

Migrating Whiteboard tags to Keywords: (filter:docx)
[NinjaEdit]

Changed in df-libreoffice:
status: Confirmed → Invalid
Changed in libreoffice (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.