Ubuntu

Form Wizard in Base does not complete

Reported by Gavin Hamill on 2006-11-18
260
This bug affects 3 people
Affects Status Importance Assigned to Milestone
openoffice.org (Debian)
Fix Released
Unknown
openoffice.org (Ubuntu)
Medium
Unassigned
Nominated for Edgy by Matthew Flaschen
Nominated for Feisty by danyul

Bug Description

Version: 2.0.4-0ubuntu2

Steps to reproduce:

Open Base.
Create a new database. Finish. Accept 'New Database' as filename.

Click Tables -> Use Wizard to Create Table. Press ' >> ' to include all 'Assets' fields. Press Finish. Close the data view of 'Assets'. It doesn't matter if you insert any data or not.

Click Forms -> Use Wizard to Create Form. Press ' >> ' to include all 'Assets' fields. Press Finish.

At this point, you are unable to press 'Finish' again to end the Wizard. The only button that works is 'Cancel' which will destroy the form.

Neither 'Work with this form' nor 'Modify the form' have any effect.

piti118 (piti) wrote :

I confirm this bug.

Brian Passavanti (gottaloveit) wrote :

my version crashes. bug 72539 has the crash log that i uploaded

https://launchpad.net/distros/ubuntu/+source/openoffice.org/+bug/72539

Brian Passavanti (gottaloveit) wrote :

Has anyone been able to confirm this or take a look at it yet? It's kind of difficult to use when it keeps crashing trying to use the wizards and forms.

Casey (kcourier-gmail) wrote :

I confirm this bug - very irritating.

This is exactly what happens to me.

Thanos Lefteris (alefteris) wrote :

I can also confirm this bug for Edgy and with sun's jre 1.6.0-rc-b103.

Checked with someone using fedora6 and sun jre 1.5 and he doesn't have this problem. So must be debian or ubuntu specific.

Changed in openoffice.org:
status: Unconfirmed → Confirmed
Thanos Lefteris (alefteris) wrote :

Bug remains in proposed update 2.0.4-0ubuntu3

Changed in openoffice.org:
status: Unknown → Unconfirmed
Ropetin Again (ropetin) wrote :

I can confirm this in Edgy, with OpenOffice package "2.0.4-0ubuntu3".

I have sun-java5-jre package "1.5.0-08-0ubuntu1", 'java -version' shows, "build 1.5.0_08-b03"

Giorgos Koklas (geo-kok) wrote :

Why doesn't Ubuntu compile/convert its own version of OO.
Clearly all these bugs that come from the Debian compilation are
not needed in ubuntu....

Just ship the OO.org version and all should be fine...

Michael Stein (der-stein) wrote :

Good question.
I'm using the OO.org version. It simply works.

I can also confirm this in Edgy with OpenOffice package "2.0.4-0ubuntu4". I also have sun-java-jre 1.5.0-08-0ubuntu1.

Hoagie (andreasabu) wrote :

I can confirm this bug on Ubuntu 6.10 Edgy Eft.
Open Office.org version: 2.0.4

danyul (dal2010) wrote :

This bug is possibly contributing to bug #1 for me. Please consider making this bug high priority. Thanks! (I'm on Edgy, using Sun's java, though non-Sun java also doesn't work.)

Alec Wright (alecjw) wrote :

I can confirm this. I think that this bug should be given a high priority, as one is completely unable to make a report in OOo base without it.

For anyone who needs a working OOo, remove openoffice.org and then install it from these packages:

For x86: http://ftp.linux.cz/pub/localization/OpenOffice.org/devel/680/OOF680_m5/Build-1/OOo_OOF680_m5_LinuxX86_install_en-US_deb.tar.gz

Or for AMD64: http://ftp.linux.cz/pub/localization/OpenOffice.org/devel/680/OOF680_m5/Build-1/OOo_OOF680_m5_LinuxX86-64_install_en-US_deb.tar.gz

Changed in openoffice.org:
importance: Undecided → Medium
Giorgos Koklas (geo-kok) wrote :

I confirm the bug and agree that it should be of high priority.
The importance of this can be seen from the duplicate reports of this bug in launchpad as well as the other related issues with it, revealed in the debian report (the link given at the top of this bug report).

Office is a major component of a distro and this really makes ubuntu NOT a usable choice for a working environment.

I am professor and I give classes of computer science alphabetization.

Unfortunately I have had to discard the use of Ubuntu in my classes by details of this type.

I can solve to the problem in my classroom installing a version of OO.org different from including in Ubuntu, but my students do not have the sufficient experience to do the same when they arrive at his houses.

Change the priority and you give a definitive solution to the problem of OO.org, please.

pirast (pirast) wrote :

I can also confirm this bug on Feisty.

Also interesting is that when I use a Sun JRE, the "Wizard to Create Form" does not start.

When I use the JRE from the FSF, which is default, I run into the same behavior reported here.

Jens Bremmekamp (nem75) wrote :

I confirm this bug. And yes, it's been there for way too long. Please decide on a course of action and do something about it.

Matt Vickers (mattyv) wrote :

Still exists in openoffice.org 2.2.0rc3oof680m10-0ubuntu3, Thu Mar 8 14:02.

This is the latest in Feisty at the time if writing.

If there's any simply debugging that can be done to help find a solution let me know. This really should work on a clean Feisty install with no extra packages.

Matt

pirast (pirast) wrote :

Does not happen with Opensuse 10.2

Matthias Klose (doko) wrote :

> Does not happen with Opensuse 10.2

which Java runtime is enabled?

pirast (pirast) wrote :

Hi, with both, 1.4.2 from the FSF and 1.5.0 update 10 from Sun.

danyul (dal2010) wrote :

From the original Debian bug report it seems to be a factor of the Java version with which OOo was built. (The original bug report is now over a year old. It looks like there is some progress on it, but it seems very slow.) It seems that probably the only way this will get fixed is if OOo built with the now GPL'ed (or soon-to-be GPL'ed?) Sun java gets into the distribution. If it comes by way of upstream, then that's perfect, otherwise does anybody know whether it would be possible for Ubuntu to add it? Does anybody know who would be responsible for making a decision on this? Even a definitive "no" on this would be helpful, because then we'd know that it's just a matter of waiting for upstream to fix it, and that any efforts would be better spent on the Debian side of things. (BTW, as has been reported by others, removing all OOo packages and installing OOo from Sun's site fixed the problem for me. I had previously experienced these problems using the package-installed OOo with both Sun's runtime Java and the FSF's Java.)

Matt Vickers (mattyv) wrote :

Looking at the Debian bug report, the final comment (2 months old) seems to indicate that Fedora use GCJ also, but don't experience the problem. As suggested, it might not even be the fact that Debian/Ubuntu isn't built with Sun's Java that causes the problem.

Unfortunately that doesn't help us much, as still we don't know where the problem lies.

ouellettesr (ouellette-kevin) wrote :

I too am confirming this bug. It is very annoying. I tried installing the version from openoffice.org but i get a bunch of failed dependencies errors. I really need to get this working. Any help is appreciated :)

Bancherd (bancherd) wrote :

I am also confirming this bug.

I've done some experimenting on this bug and I've come to suspect this problem is really two different bugs conflated as one: (1) a problem with hsqldb (as hinted at in both the upstream Debian bug and the Fedora bug mentioned in Debian's tracker) as well as (2) bugs in the patches applied to the gcj upstream sources. Using the latest OOo in feisty at the time of writing (2.2.0-0ubuntu2) and a vainilla gcj/gij install the hang occurs as described: the form wizard cannot finish. If I install the openoffice.org-gcj package and dependencies, the form wizard locks up on start.

Weiers Coetser (coetserw) wrote :

I've just done a clean install of Ubuntu 7.04 and the bug still exists. It creates the form on my screen (using writer) and displays all the fields, but when I press "Finish", nothing happens.

Yup - I agree with Weiers on this - same results. I have tried with a clean install of 7.04, and a fully up-to-date (all suggested updates installed) version and still see the behaviour.
The form wizard can not be completed - hanging OpenOffice until the process is killed.

squarepeg (lewis-bruce) wrote :

I can confirm the bug. This is the only thing about Ubuntu that I am disappointed in so far. Does anyone know if the Debian people are really working on it?

Why is this bug still marked as being of Medium Importance?

Note to devs - If this bug remains, then Ubuntu is _not_ usable in a business environment. All the joint actions with Sun, press releases with Mepis, Parisian parliamentary success - these count for squat against such a serious bug which renders the OS non-productive.

Business users don't care about compiz sweetness &c - they want a tool which works like it supposed to.

I confirm this bug.

I'm using Edgy with java version 1.5.0_09.

SOLUTION?

A very similar bug to this has been reported elsewhere: Bug #72539. Please see my note there, even if it is slightly off topic.

Additional to the OO.oB bug that is reported here, there is a flaw in a Java 6 .xml file reported early this year. I have not seen the code for the Java 5, but it might well be legacied in.

I fixed my Java file using the suggestion in <http://www.clasohm.com/blog/one-entry?entry%5fid=40367> and I now do not have the problem. Additionally, I have updated to OO.o 2.2, but I don't believe that that would be necessary - just fix the Java .xml file.

David,
I am not sure this is related to the Base form Wizard. However, I did check the equivalent file at /usr/lib/jvm/java-6-sun-1.6.0.00/jre/lib/desktop/mime/packages/x-java-archive.xml and found that indeed the required "<" was missing from the entry in the file. I have fixed that, and it makes no odds for this particular issue, it is most certainly wrong. Clearly as the article referred to Fedora, then it is an upstream issue.

With regards to your comments on #72539 - which is related - reproducing the bug involves going through a database wizard, and table wizard so tables will be present. It is after fields and layout have been selected and upon trying to press finish that the form either hangs, or refuses to complete.

Either way - if no tables had been created, then the product should certainly not crash or hang. It should quite possibly throw up a message dialog explaining to the user that they need to do something else first, but definitely not hang or crash.

Good point, Danny.

Definitely there should be notification to user that table creation is
necessary first, even if that notification is only an error dialog.

I wonder if this hanging error is not coming up for me because I built
my OO.o 2.2 from RPM (because I'm running Dapper and I can't get 2.2
from the repository)? If so, maybe that's the kludge for the moment.

swan_fl (aezekowitz) wrote :

I should like to point out that I have tried this in Windows, PCLinuxOS and Gentoo and the problem cannot be reproduced in those 3 instances.

The problem with Sun Java 6 in Fedora mentioned above has no relation to the OOo forms wizard problem. It is rather a problem with the ooo-build codebase used to produce the binaries. And the upstream for that ooo-build source code, in the case of Ubuntu is Debian 8see alioth.debian.org). *And* the original upstream for all GNU/Linux distributions using ooo-build is Novell, namely OpenSUSE.

The OOo binaries used in Ubuntu are compiled with GNU GCJ (version 4.1.2 in the 7.04 release) and the problem is related to two bugs, one in the java bytecode compiler and the other in the HSQL source code that triggers the bug in the compiler, that is the bytecode is defective. This is mentioned in the upstream bug entry in the Debian bugtracker (see link at the beginning of the page) with pointers to the original bug reports in the Fedora bugtracker.

I should clarify (in case it is taken incorrectly), that when I said "I have fixed that" - I mean, I applied that suggested fix to my boxes.Just wanted to avoid any confusion about that statement.

Matthias Klose (doko) wrote :

DannyStaple
> I am not sure this is related to the Base form Wizard. However, I did check the equivalent file at /usr/lib/jvm/java-6-sun-1.6.0.00/jre/lib/desktop/mime/packages/x-java-archive.xml and found that indeed the required "<" was missing from the entry in the file. I have fixed that, and it makes no odds for this particular issue, it is most certainly wrong. Clearly as the article referred to Fedora, then it is an upstream issue.

this is now https://bugs.launchpad.net/ubuntu/+source/sun-java6/+bug/107233, unrelated to this report.

Matthias Klose (doko) wrote :

Pedro Alejandro López-Valencia:
> The OOo binaries used in Ubuntu are compiled with GNU GCJ (version 4.1.2 in the 7.04 release) and the problem is related to two bugs, one in the java bytecode compiler and the other in the HSQL source code that triggers the bug in the compiler, that is the bytecode is defective. This is mentioned in the upstream bug entry in the Debian bugtracker (see link at the beginning of the page) with pointers to the original bug reports in the Fedora bugtracker.

Pedro, could you explictely mention the two bug reports? I cannot find a reference to the java byte code interpreter, and the HSQL source code looks unmodified.

Matthias Klose (doko) wrote :

Following the steps in the first report, I'm unable to reproduce the reported behaviour. Please could people check with a recent daily live CD / fresh install?

Mattias the bug I reffered to is <https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=154919> The commenter Caolan McNamara <caolanm (at) readhat.com> mentions he patched out some hsqldb upstream fixes to work around a problem caused by hsqldb in libgcj, I haven't been able to find that patchset somewhere accesible (surely they are in the source RPMs?).

Pedro Alejandro López-Valencia schrieb:
> Mattias the bug I reffered to is
> <https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=154919> The
> commenter Caolan McNamara <caolanm (at) readhat.com> mentions he patched
> out some hsqldb upstream fixes to work around a problem caused by hsqldb
> in libgcj, I haven't been able to find that patchset somewhere accesible
> (surely they are in the source RPMs?).

no, this was reported two years ago for OOo version 1.9.89. Fedora uses the
system hsqldb version 1.8.0.7, as Ubuntu does.

Hmm... Then I'm at a loss here. As I had commented sometime ago in this bug report, I still suspect gcj is involved in this problem; in my system (this is an IA32 box if that matters) the wizard locks up on load if I install the openoffice.org-gcj package and dependencies while runs to the point where the form wizard is ready to generate the actual from but the finish button fails.

I've just tested this in a new install made with the i386 RC ISO image under VMware (ISO hasn't changed in a couple of days, synced with rsync). The bug is still there.

I think the bug description is not clear on how to reproduce the bug. I'll rince and repeat for the sake of clarity:

1. Open OpenOffice.org Base.

2. Create a new database, save the file. You'll be droped into the Form window.

3. Click on the Tables button on the left. Click on the second option in the upper section of the Tables section when it appears: "Use wizard to create table".

4. Go with the flow: Add all the fields offered by the default template using the ">>" button, Keep clicking "Next" until it deactivates. Select "Create a form based on this table" and click "Finish"

5. The Form Wizard opens up and loads the modal dialog. Copy all the available fields to the form with th e">>" button. Click "Next" and keep clicking it until it deactivates.

6. Click "Finish". There, that's the bug.

Matthias Klose (doko) wrote :

Pedro Alejandro López-Valencia schrieb:
> I've just tested this in a new install made with the i386 RC ISO image
> under VMware (ISO hasn't changed in a couple of days, synced with
> rsync). The bug is still there.
>
> I think the bug description is not clear on how to reproduce the bug.
> I'll rince and repeat for the sake of clarity:
>
> 1. Open OpenOffice.org Base.
>
> 2. Create a new database, save the file. You'll be droped into the Form
> window.
>
> 3. Click on the Tables button on the left. Click on the second option in
> the upper section of the Tables section when it appears: "Use wizard to
> create table".
>
> 4. Go with the flow: Add all the fields offered by the default template
> using the ">>" button, Keep clicking "Next" until it deactivates. Select
> "Create a form based on this table" and click "Finish"

reproducible until here.

> 5. The Form Wizard opens up and loads the modal dialog. Copy all the
> available fields to the form with th e">>" button. Click "Next" and keep
> clicking it until it deactivates.

instead of the form wizard opening, nothing happens.

> 6. Click "Finish". There, that's the bug.

Mattias,

do you have installed the gcj native libraries? In my case, if I install them, the wizard doesn't load just as you describe. That is, the bug triggers in step 4 instead of 5.

Mattias - following these steps (which is pretty much what I was doing), I have to start the form wizard myself to start step 5 - but it does hang when finish is clicked on the form wizard.

Ante Karamatić (ivoks) wrote :

I can confirm this on Feisty release. Form wizard does not work at all.

Ante Karamatić (ivoks) wrote :

Just to make some things clear:

- if one is using Sun's Java (both 5 and 6), then wizard doesn't start at all
- if one is using Free Software Foundation's Java, then wizard start but fails to finish

In Feisty my experience is the same. If I select to go into the form wizard after the table wizard finishes, I cannot finish the form wizard with the default JRE, and the Sun JRE's do not start the form wizard at all even though it was selected.
I think with the number of me too's this defect is well and truly confirmed.

Davide Corio (davide-corio) wrote :

In Feisty, i cannot finish the form wizard.
If I install openoffice.org-gcj the form wizard starts and immediately stops loading.

Rebuild OOo with the Sun JDK under Debian/Ubuntu could solve the problem?

Carl Davis (carl.davis) wrote :

I can confirm that pushing the finish button in the form wizard does nothing at all. I am currently running Edgy. Is there a work around?

Carl Davis (carl.davis) wrote :

I am guessing this doesn't help any, but here is what shows up at console:

=======================================================
=== Note: An Exception was thrown which should have ===
=== caused a crash. I caught it. Please report this ===
=== to openoffice.org ===
=======================================================
java.lang.reflect.InvocationTargetException
   at java.lang.reflect.Method.invoke(libgcj.so.70)
   at com.sun.star.wizards.ui.event.MethodInvocation.invoke(MethodInvocation.java)
   at com.sun.star.wizards.ui.event.AbstractListener.invoke(AbstractListener.java)
   at com.sun.star.wizards.ui.event.CommonListener.actionPerformed(CommonListener.java)
Caused by: java.lang.IllegalAccessError: com.sun.star.wizards.form.FormDocument: com.sun.star.wizards.form.FormDocument$ControlForm.setFormProperties([Lcom.sun.star.beans.PropertyValue;Lcom.sun.star.wizards.db.CommandMetaData;)V
   at com.sun.star.wizards.form.FormDocument.finalizeForms(FormDocument.java)
   at com.sun.star.wizards.form.FormWizard.finishWizard(FormWizard.java)
   at com.sun.star.wizards.ui.WizardDialog.finishWizard_1(WizardDialog.java)
   at java.lang.reflect.Method.invoke(libgcj.so.70)
   ...3 more
=======================================================
=== Note: An Exception was thrown which should have ===
=== caused a crash. I caught it. Please report this ===
=== to openoffice.org ===
=======================================================
java.lang.reflect.InvocationTargetException
   at java.lang.reflect.Method.invoke(libgcj.so.70)
   at com.sun.star.wizards.ui.event.MethodInvocation.invoke(MethodInvocation.java)
   at com.sun.star.wizards.ui.event.AbstractListener.invoke(AbstractListener.java)
   at com.sun.star.wizards.ui.event.CommonListener.actionPerformed(CommonListener.java)
Caused by: java.lang.IllegalAccessError: com.sun.star.wizards.form.FormDocument: com.sun.star.wizards.form.FormDocument$ControlForm.setFormProperties([Lcom.sun.star.beans.PropertyValue;Lcom.sun.star.wizards.db.CommandMetaData;)V
   at com.sun.star.wizards.form.FormDocument.finalizeForms(FormDocument.java)
   at com.sun.star.wizards.form.FormWizard.finishWizard(FormWizard.java)
   at com.sun.star.wizards.ui.WizardDialog.finishWizard_1(WizardDialog.java)
   at java.lang.reflect.Method.invoke(libgcj.so.70)
   ...3 more

Paulo (paulo-fmtm) wrote :

I confirm this bug.

SMut (steffen-webanimations) wrote :

The problem is, as the Debian maintainer told me, not the Java Runtime Envirenment we use to execute the code needed to get the application running. The bleeding edge is the JDK, the COMPILER with which the OOo-packages are built.
The actually used JDK for compiling by the OOo-team is not released under the GPL yet and we have to wait until openjdk (version 7) is released by SUN.

As soon as the jdk is released under an open licence everything will be fine. Only workaround is to install the OOo-packages built by the OOo team, but you run into trouble if you want to use the addons for Gnome, themes or Evolution for example.

Changed in openoffice.org:
status: Unconfirmed → Fix Released
m.gagliardi (m-gagliardi) wrote :

Bug confirmed... irritating

There is a fix. It's not a fun fix, but it works.

Go to OpenOffice.org, download the "official" Linux stuff (Fedora RPMs), Alien them, and install the deb verison built by Alien. You may have to uninstall your previous OO.o first.

This takes about half an hour. It's a pity that there isn't an easier way through the Ubuntu repositories, but there isn't (see up two or three messages to see why). On the other hand, it [i]is[/i] fixable.

The problem and its envisioned eventual resolution point out quite well the weakness of "distributed and uncompensated labor" and decentralised management being used with Ubuntu, Debian, and Linux in general. In the other OSs if a problem like this were identified to be a public relations or money burden, somebody would be put on it until it was solved. Our systems do not encourage a rapid response to problems like this one because is it a "specialised use" problem rather than a "clamoring multitudes" problem.

On the other hand, what will be lacked in speed in getting to the remedy [i]will[/i] be made up for in thoroughness in application. Our programmers can really rock sometimes!

Very good answers and propositions ????
but what I do is simply :
 I removed UBUNTU from my computer , and I installed OPENSUSE and NO PROBLEM anymore

Antonio Macchi III (macchi) wrote :

Irritating bug confirmed.

For less experienced users this bug seem to block completely the use of OO Base, the importance/severity should be higher.
The most common use case for less experienced users is generating a simple database application with help of the wizards.

I will run to the forum to find a workaround. So far I fear that installation of the latest stuff from OO.org will break other things.

fachex (fabianlazarte) wrote :

I confirm this bug. But I have a horrible solution. Download the latest version of OO (I downloaded 2.2) and replace the OO files with those in the RPM's folder and you've got. This solution was done in Ubuntu Festy Fawn. This is not the most optimum solution but it works.

Simply ask for a backport of the version presently in Gutsy.

Joel Parker (jjkp) wrote :

Will that help? Anyway, it's done.

Tantrik (danielb-mundo-r) wrote :

I'm upgrading openoffice.org from the gutsy wild repositories.
http://ubuntuforums.org/showthread.php?t=473010
The following packets are being installed:
      gcc-4.2-base libcurl4-gnutls liblzo2-2 libnspr4-0d libnss3-0d
And the following are being upgraded:
       libc6 libc6-dev libc6-i686 libgcc1 libglib2.0-0 libgnutls13 libhunspell-1.1-0 libopencdk8 libpango1.0-0 libpango1.0-common libstdc++6
       openoffice.org openoffice.org-base openoffice.org-calc openoffice.org-core openoffice.org-draw openoffice.org-evolution
       openoffice.org-filter-mobiledev openoffice.org-gnome openoffice.org-gtk openoffice.org-impress openoffice.org-java-common
       openoffice.org-math openoffice.org-writer python-uno tzdata
If my system stil working later, I write if it can help.

BANZAI!!!

All is working great under Gutsy.
OpenOffice 2.2.1~rc3-1ubuntu3

Tantrik (danielb-mundo-r) wrote :

It seem to work.
Now my Firefox orthographic corrector crash.
I hope there is not any more broken on my system.

Ann Oldroyd (a-e-oldroyd) wrote :

Again, I can confirm this bug in Feisty.

Also, can confirm what Antonio Macchi III said:
"For less experienced users this bug seem to block completely the use of OO Base, the importance/severity should be higher." - I have just started using Ubuntu and OO, and don't understand half of the advice above to fix this problem, so right now I cannot use it as I'd hoped. A wasted afternoon at work is the result.

Joel Parker (jjkp) wrote :

Here's a description of how I worked around the problem, hopefully clear enough for everyone to use:

1. Install Sun's version of Java: package sun-java6-jre from Synaptic (Multiverse repository)
2. In Synaptic, go to Settings->Preferences and uncheck "Consider recommended packages as dependencies" (I don't know if this is necessary, mine's always unchecked, and I'm afraid leaving it checked would cause many more packages to be uninstalled in the next step).
3. In Synaptic, uninstall all openoffice.org-* packages and their dependencies (there should only be a few non-openoffice.org ones that need to be removed).
4. Finally, in Synaptic, install alien.
5. Go to http://openoffice.org and download the latest Linux version (making sure you uncheck the "Include the Java JRE" button below the download links).
6. Unzip the download.
7. In a terminal, go into the unzipped folder, then the RPMS folder.
8. Copy the one .deb file from the desktop-integration folder into the main RPMS folder.
9. Delete openoffice.org-kde-integration-<numbers>.rpm (or the gnome counterpart if you use KDE)
10. Run "sudo alien --scripts *.rpm".
11. Run "sudo dpkg -i *.deb".
12. Log out and back in to get the menus to update, if necessary.

Doing all that will remove Ubuntu's version of OOo and install the latest one from OpenOffice.org, which works fine in Feisty (I'm using it now).

Matt Vickers (mattyv) wrote :

Fixed in Gutsy, will request backport or stable release upgrade.

Changed in openoffice.org:
status: Confirmed → Fix Released
Matt Vickers (mattyv) on 2007-06-21
Changed in openoffice.org:
status: Fix Released → Confirmed
Bob Kline (bkline) wrote :

Yet another workaround: I have found that copying the .odb file to a SuSE system, creating the form there, then copying back to the Ubuntu computer seems to work. Yes, it's a workaround with limited applicability (you have to have another computer available running a distribution of Linux on which OOo isn't broken), but until this bug gets fixed on Ubuntu, we have to take what we can get. Haven't tested on a Windows OOo.

BigBert (lnxrlz) wrote :

Any idea when this will be fixed?

Mark M (ubuntu-prototribe) wrote :

Same problem. Makes me want to install MS Office via Wine. My questions are when will it be fixed or when will Gutsy be out?

Mark: both of your questions are answered by reading the comments before yours. Please read the whole bug report before asking a question.

Dianne Reuby (pramclub) wrote :

I've followed Joel Parkers instructions in Feisty. However the menus don't show OO. If I double-click an .odt file, it opens in Archive Manager. If I double-click a .doc file, it opens the "add/remove apps" dialogue. It recommends OO, and displays the version that I've just installed:
Writer module for OpenOffice.org 2.2
Writer module for OpenOffice.org 2.2
(Converted from a rpm package by alien version 8.65.)
Version: 2.2.1-9162 (openoffice.org-writer)
but clicking OK doesn't open OO. It's on there somewhere, but I can't find it to add it manually!

pirast (pirast) wrote :

fixed in gutsy

as it does not seem like there will be a fix in feisty, I'd suggest to have a look at other distros with a better politic concerning the maintenance of stable releases.

Changed in openoffice.org:
status: Confirmed → Fix Released
Johnathon (kirrus) wrote :

If you need it in feisty (or dapper) a Stable Release Upgrade process needs to be started.

https://wiki.ubuntu.com/StableReleaseUpdates

Bob Kline (bkline) wrote :

> ... it does not seem like there will be a fix in feisty ...

If that's true, what did Matt Vickers mean when he wrote back in June: "will request backport or stable release upgrade"?

Matt Vickers (mattyv) wrote :

I attempted to get in contact with the Ubuntu OOo maintainer. We spoke briefly on irc, then I emailed him to get the SRU process started but never heard back.

Bob Kline (bkline) wrote :

Who is the Ubuntu package maintainer for OOo (bringing up the Ubuntu home page and doing a search on "package maintainers" didn't provide anything useful)? If you let me have his/her email address I'll provide a nudge.

Cheers,
Bob

SMut (steffen-webanimations) wrote :

Hi Bob!

Bob Kline wrote:
> Who is the Ubuntu package maintainer for OOo
Do you have the slightest idea how the package management in GNU/Linux
Debian style works?
Maybe you should take a peek at the frontend called apt:

apt-cache show openoffice.orgPackage: openoffice.org
Priority: optional
Section: editors
Installed-Size: 28
Maintainer: Ubuntu Core Developers <email address hidden>
Original-Maintainer: Debian OpenOffice Team
<email address hidden>
Architecture: i386

This gives you the information you were looking for,
> (bringing up the Ubuntu
> home page and doing a search on "package maintainers" didn't provide
> anything useful)? If you let me have his/her email address I'll provide
> a nudge.
>
Do you have an idea what's the goal of GNU software?
The Debian maintainers use ONLY software whitch suits the needs of the
GNU-software idea, meaning they don't use commercial closed source to
produce their packages.
The result is, that there are bugs produced by a free java-compiler due
to the fact that the SUN-java compiler has not been released under the
GNU-licence.
As soon at it's available most of the bugs will be gone.

As I already stated here times and times again, use the .deb packages
built by the OOo-team. Unfortunately they don't offer deb.packages as
you can see here:
http://download.openoffice.org/common/instructions.html#other_linux
bt the sid-packages worked out for me.
unistall openoffice.org on yoiur system, get the debian-packages from
SID, throw them into a folder and do a
sudo dpkg -i *

And, please, stop complaining :-)
> Cheers,
> Bob
>
Steffen

pirast (pirast) wrote :

Wait, the bug does not appear in Gutsy's OOo, which is compiled with GCJ (free java compiler), also. So there *is* a fix but it is not being applied to Feisty.

This leads me to the assumption that Ubuntu does not really set value on maintaining stable releases (yes, OOo is in main).

Bob Kline (bkline) wrote :

Steffen:

I'm sure my knowledge of the Debian package internals is woefully inadequate compared with yours. I imagine that's probably true for most Ubuntu users, given the target audience for the distribution.

I do know, however, that the bug fix in the version of Ubuntu which hasn't been released works with the free Java implementation.

It would never have occurred to me that requesting a stable release upgrade would be seen as "complaining."

Regards,
Bob

Johnathon (kirrus) wrote :

----- "SMut" <email address hidden> wrote:
...
>
> And, please, stop complaining :-)
> Steffen
>

This is a critical-level functionality bug in a core piece of software. This software working well is *key* to Ubuntu adoption in enterprise applications. (Workplace offices.) Preferably, it needs to work off the shelf. There is no way that anyone with more than 20+ machines to maintain will run around installing the "Official" version of OO, on each of them. Yes, they could automate a script to do it, but it will introduce a version of OO that *is not* supported by Ubuntu.

Regards,
Johnathon

Dear Johnathon!

Johnathon schrieb:
> ----- "SMut" <email address hidden> wrote:
> ...
>
>> And, please, stop complaining :-)
>> Steffen
>>
>>
>
> This is a critical-level functionality bug in a core piece of software.
>
Which I reported already a couple of months ago.
I already offered a solution, but I _never_ received an e-mail about
this matter by the maintainer team.
I should really get worried but I found my way out of this trouble.
> This software working well is *key* to Ubuntu adoption in enterprise
> applications. (Workplace offices.)
Indeed I still use Debian for enterprise solutions. Ubuntu is good for a
home-office or a end-user to see what's next in Debian, because the
release cycles are very, hm, rare...
> Preferably, it needs to work off the
> shelf.
That's exactly what I'm on about. Did you have a look at the lots of
(unresolved) bugs in Ubuntu?
> There is no way that anyone with more than 20+ machines to
> maintain will run around installing the "Official" version of OO, on
> each of them.
You know how the package sytstem works?
Of course there is a solution for +200 and more machines if you need a
working version of OpenOffice.
> Yes, they could automate a script to do it, but it will
> introduce a version of OO that *is not* supported by Ubunt
>
Ever heared of apt-pinning?
You can tell the system to prefer certain packages.
You just have to alter the apt-sources-list to your needs, heres a howto:

http://jaqque.sbih.org/kplug/apt-pinning.html

What could happen, really, if you install a version that is running like
you expect it to?
You won't run into trouble, if you use the complete package by the
DEBIAN team, because the .deb packages are not compiled or supported by OOo.
Double trouble?
No, I don't think so, just a working application.
http://openoffice.debian.net/
Have a look in the SID-tree. It is Still In Development but working
better, as the Ubuntu package (but I spotted different bugs, but those
ones went to bugs.debian.org and were already resolved)

If you want to run a good piece of software in a company I will suggest
and prefer Debian, or a LTS version of Ubuntu, which is still Dapper...

Don't worry, Gutsy's on the way.
(With a new pack of bugs, for shure!)

Kind regards from germany,
Steffen

Johnathon (kirrus) wrote :
Download full text (3.2 KiB)

Hello :)

> Which I reported already a couple of months ago.
> I already offered a solution, but I _never_ received an e-mail about
> this matter by the maintainer team.
> I should really get worried but I found my way out of this trouble.

I've had the same trouble, with bugs I've reported. In the end, I gave up, and triaged about 20-30 bugs.

> > This software working well is *key* to Ubuntu adoption in
> enterprise
> > applications. (Workplace offices.)
> Indeed I still use Debian for enterprise solutions. Ubuntu is good for
> a
> home-office or a end-user to see what's next in Debian, because the
> release cycles are very, hm, rare...
> > Preferably, it needs to work off the
> > shelf.
> That's exactly what I'm on about. Did you have a look at the lots of
> (unresolved) bugs in Ubuntu?
I've triaged some of them. Most of them, just need someone to do IT gopher work, and do the basic level triaging. It doesn't help that there is a new bug added every 5 minutes, give or take, and it takes a lot longer than 5 minutes to triage each bug...

> > There is no way that anyone with more than 20+ machines to
> > maintain will run around installing the "Official" version of OO,
> > on each of them.
> You know how the package sytstem works?
> Of course there is a solution for +200 and more machines if you need
> a working version of OpenOffice.
> > Yes, they could automate a script to do it, but it will
> > introduce a version of OO that *is not* supported by Ubunt
> >
> Ever heared of apt-pinning?
> You can tell the system to prefer certain packages.
> You just have to alter the apt-sources-list to your needs, heres a
> howto:
>
> http://jaqque.sbih.org/kplug/apt-pinning.html

Never heard of it, thanks for the link!
At the moment, we're leaning towards LTSP systems, rather than mass-desktop deployments. (Two beefy servers serving desktop onto a whole load of HP thin clients...)

> What could happen, really, if you install a version that is running
> like you expect it to?
> You won't run into trouble, if you use the complete package by the
> DEBIAN team, because the .deb packages are not compiled or supported
> by OOo.
> Double trouble?
> No, I don't think so, just a working application.
> http://openoffice.debian.net/
> Have a look in the SID-tree. It is Still In Development but working
> better, as the Ubuntu package (but I spotted different bugs, but
> those
> ones went to bugs.debian.org and were already resolved)
>
The Debian and Ubuntu systems appear to be slowly becoming more separated with each release, as Ubuntu loads its particular variables and patches to the pulls from the debian repos.

> If you want to run a good piece of software in a company I will
> suggest
> and prefer Debian, or a LTS version of Ubuntu, which is still
> Dapper...
>
We're moving someone to Feisty from Dapper atm, because of some of the fun *unresolved* bugs in it. (gnome-cups-icon eats 100% cpu, among others)

> Don't worry, Gutsy's on the way.
> (With a new pack of bugs, for shure!)
>
> Kind regards from germany,
> Steffen
>
> --
> Form Wizard in Base does not complete
> https://bugs.launchpad.net/bugs/72262
> You received this bug notification becaus...

Read more...

Frederik (frederik-debuck) wrote :

Bug confirmed (Feisty x86, fresh install) and found to be very annoying. Hoping for better in Gutsy...

Thanks everyone for pointing to this bug. This is already fixed for Gutsy and has been nominated for Edgy and Feisty. There's no need to add to this bug - just wait for the goodies to come to you.

I understand that a fix for this has happened in Gutsy and that it's
nominated for Feisty and Edgy.

I run Dapper, which was promoted as a "Long Term Support" release. Will
there be a fix released in Dapper?

tomhoo (tomhoo) wrote :

Still does not complete in Feisty.

Gee, this is NOT what i expected of Ubuntu!

Johnathon (kirrus) wrote :

It will take TIME. I can't see any patches attached to this bug report, so one will need to be generated, the code that fixes the bug isolated and applied, and a debdiff generated. That will then have to be put through the Stable Release Upgrade process, which is itself not fast by design. To be honest, I recommend that you upgrade to Gutsy. I'm not going to spend the time isolating & pulling the patch through for fiesty & gusty, although a Ubuntu MOTU may, if you're patient.

Johnathon (kirrus) wrote :

*feisty and dapper

I presented this work-around several months ago. It ought to work fine for anyone who needs to get things going again: <https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/72262/comments/32>

Yes, it is quite a bother and annoyance to have a bug floating for a year. This is a proof in the breach of the truism that *n?x is a very responsive system for bug repair.

The truth seems rather that the responsiveness comes quickly when a bug is inconvenient for programmer types rather than for the non-programmer types. (This, incidentally, is precisely the strength of "pay for me" OSes like Windows and Mac: they have to hold on to their user base in order to continue making money - so they'll deal with specialised "consumer issues" much more quickly than non-compensated volunteers.)

Listen and learn.

I have tried this in Jaunty and can no longer reproduce it. The fix is released for sure.

Thanks!

On Sun, May 31, 2009 at 6:42 AM, Danny Staple <email address hidden>wrote:

> I have tried this in Jaunty and can no longer reproduce it. The fix is
> released for sure.
>
> --
> Form Wizard in Base does not complete
> https://bugs.launchpad.net/bugs/72262
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
---------------------------------------------
Gary Van Meter
Special Projects - Policies
---------------------------------------------
Education's purpose is to replace an empty mind with an open one. - Malcolm
Forbes
---------------------------------------------------

Erasmus M. Spitta (e-spitta) wrote :

Thank you very much indeed!

----- Original Message -----
From: Gary Van Meter <email address hidden>
Date: Sunday, May 31, 2009 4:31 pm
Subject: Re: [Bug 72262] Re: Form Wizard in Base does not complete

> Thanks!
>
> On Sun, May 31, 2009 at 6:42 AM, Danny Staple
> <email address hidden>wrote:
>
> > I have tried this in Jaunty and can no longer reproduce it. The
> fix is
> > released for sure.
> >
> > --
> > Form Wizard in Base does not complete
> > https://bugs.launchpad.net/bugs/72262
> > You received this bug notification because you are a direct
> subscriber> of a duplicate bug.
> >
>
>
> --
> ---------------------------------------------
> Gary Van Meter
> Special Projects - Policies
> ---------------------------------------------
> Education's purpose is to replace an empty mind with an open one. -
> MalcolmForbes
> ---------------------------------------------------
>
> --
> Form Wizard in Base does not complete
> https://bugs.launchpad.net/bugs/72262
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Thank you!
Maiquel Sampaio de Melo

On Mon, Jun 1, 2009 at 12:14 PM, Erasmus M. Spitta <email address hidden> wrote:

> Thank you very much indeed!
>
> ----- Original Message -----
> From: Gary Van Meter <email address hidden>
> Date: Sunday, May 31, 2009 4:31 pm
> Subject: Re: [Bug 72262] Re: Form Wizard in Base does not complete
>
> > Thanks!
> >
> > On Sun, May 31, 2009 at 6:42 AM, Danny Staple
> > <email address hidden>wrote:
> >
> > > I have tried this in Jaunty and can no longer reproduce it. The
> > fix is
> > > released for sure.
> > >
> > > --
> > > Form Wizard in Base does not complete
> > > https://bugs.launchpad.net/bugs/72262
> > > You received this bug notification because you are a direct
> > subscriber> of a duplicate bug.
> > >
> >
> >
> > --
> > ---------------------------------------------
> > Gary Van Meter
> > Special Projects - Policies
> > ---------------------------------------------
> > Education's purpose is to replace an empty mind with an open one. -
> > MalcolmForbes
> > ---------------------------------------------------
> >
> > --
> > Form Wizard in Base does not complete
> > https://bugs.launchpad.net/bugs/72262
> > You received this bug notification because you are a direct subscriber
> > of a duplicate bug.
> >
>
> --
> Form Wizard in Base does not complete
> https://bugs.launchpad.net/bugs/72262
> You received this bug notification because you are a direct subscriber
> of the bug.
>

neast (fl-hrdent) wrote :

For those who are still having trouble with this, and can get to "Finish" in the wizard but yet nothing happens as happened to me, here's what worked for me..

I backed up in the wizard and re-selected the database I was working with in the first window. After this I was able to progress through the
wizard and everything worked properly.

Not quite as clean an output as MS Access, but not as expensive either!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.