Ubuntu

openoffice cannot open paths with non-english characters

Reported by Øyvind Jensen on 2011-01-14

This bug report was converted into a question: question #141434: openoffice cannot open paths with non-english characters.

8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org

When I open files with a path that contains one of the non-english characters æ, ø or å, OpenOffice fails with the message: /absolute/path/to/file/with/an/ø does not exist. This happens for the Writer, Calc and Impress components.

I attach an empty odt file with a name that triggers the bug on my computer.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: openoffice.org 1:3.2.0-7ubuntu4.1
ProcVersionSignature: Ubuntu 2.6.32-27.49-generic 2.6.32.26+drm33.12
Uname: Linux 2.6.32-27-generic i686
Architecture: i386
Date: Fri Jan 14 11:33:31 2011
ProcEnviron:
 LANGUAGE=nb_NO:nb:no_NO:no:en_GB:en
 PATH=(custom, user)
 LANG=nb_NO.utf8
 SHELL=/bin/bash
SourcePackage: openoffice.org

Øyvind Jensen (jegerjensen) wrote :
ElPasmo (elpasmo) wrote :

I can't confirm this bug in both Lucid and Maverick.

I can open the file you have attached without errors:
Lucid 10.04 x86_64 2.6.32-27.49 with openoffice.org-writer 1:3.2.0-7ubuntu4.1
Maverick 10.10 i386 2.6.35-24.42 with openoffice.org-writer 1:3.2.1-7ubuntu1

Can you try with another user? Maybe is a configuration problem.

Øyvind Jensen (jegerjensen) wrote :

You are right. I started a guest session and to my surprise the file opened. So now I am really stumped but this is clearly not a bug in openoffice. Thanks.

Øyvind Jensen (jegerjensen) wrote :

For some reason OpenOffice is not able to access files with non-english characters on my computer. The problem does not exist for a different user on the same computer, so it has to be something in my configuration. I have absolutely no idea what could be the cause of this, but someone might have a suggestion?

Changed in openoffice.org (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions