Ubuntu

[ooo-build] Crash when browsing document templates when Assistive Technologies (accessibility) used (WARNING **: Invalidate all children called)

Reported by Vincenzo Ciancia on 2006-10-30
54
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenOffice
Fix Released
Medium
libreoffice (Ubuntu)
Undecided
Unassigned
Declined for Feisty by Chris Cheney
Declined for Intrepid by Chris Cheney
openoffice.org (Ubuntu)
Low
Unassigned
Declined for Feisty by Chris Cheney
Declined for Intrepid by Chris Cheney

Bug Description

Binary package hint: openoffice.org-core

In any openoffice app, I click on "new" then "templates and documents", then "templates", and openoffice crashes, backtrace follows.

#0 0xb798c46b in SvtFileView::ResetCursor ()
   from /usr/lib/openoffice/program/libsvt680li.so
#1 0xb77e03f4 in non-virtual thunk to SfxStyleSheet::~SfxStyleSheet() ()
   from /usr/lib/openoffice/program/libsvt680li.so
#2 0xb780d872 in non-virtual thunk to SfxStyleSheet::~SfxStyleSheet() ()
   from /usr/lib/openoffice/program/libsvt680li.so
#3 0xb77e4af1 in non-virtual thunk to SfxStyleSheet::~SfxStyleSheet() ()
   from /usr/lib/openoffice/program/libsvt680li.so
#4 0xb79a1976 in SvHeaderTabListBox::CreateAccessibleCell ()
   from /usr/lib/openoffice/program/libsvt680li.so
#5 0xb780c260 in non-virtual thunk to SfxStyleSheet::~SfxStyleSheet() ()
   from /usr/lib/openoffice/program/libsvt680li.so
#6 0xb780c686 in non-virtual thunk to SfxStyleSheet::~SfxStyleSheet() ()
   from /usr/lib/openoffice/program/libsvt680li.so
#7 0xb780c6a8 in non-virtual thunk to SfxStyleSheet::~SfxStyleSheet() ()
   from /usr/lib/openoffice/program/libsvt680li.so
#8 0xb7c3a10d in VclEventListeners::Call ()
   from /usr/lib/openoffice/program/libvcl680li.so
#9 0xb7e065f3 in Window::CallEventListeners ()
   from /usr/lib/openoffice/program/libvcl680li.so
#10 0xb79d1e9b in SvTreeListBox::CallImplEventListeners ()
   from /usr/lib/openoffice/program/libsvt680li.so
#11 0xb79a29f1 in non-virtual thunk to SvHeaderTabListBox::CreateAccessibleCell(long, unsigned short) () from /usr/lib/openoffice/program/libsvt680li.so
#12 0xb79d5b94 in SvTreeListBox::Select ()
   from /usr/lib/openoffice/program/libsvt680li.so
#13 0xb79a6c2d in non-virtual thunk to SvHeaderTabListBox::CreateAccessibleCell(long, unsigned short) () from /usr/lib/openoffice/program/libsvt680li.so
#14 0xb79a6d4b in non-virtual thunk to SvHeaderTabListBox::CreateAccessibleCell(long, unsigned short) () from /usr/lib/openoffice/program/libsvt680li.so
#15 0xb7dcb585 in SelectionEngine::SelMouseButtonDown ()
   from /usr/lib/openoffice/program/libvcl680li.so
#16 0xb79a80ab in non-virtual thunk to SvHeaderTabListBox::CreateAccessibleCell(long, unsigned short) () from /usr/lib/openoffice/program/libsvt680li.so
#17 0xb79d2e1a in SvTreeListBox::MouseButtonDown ()
   from /usr/lib/openoffice/program/libsvt680li.so
#18 0xb7e19717 in Window::~Window ()
   from /usr/lib/openoffice/program/libvcl680li.so
#19 0xb7e1ac1d in Window::~Window ()
   from /usr/lib/openoffice/program/libvcl680li.so
#20 0xb5aba119 in GtkSalFrame::signalButton ()
   from /usr/lib/openoffice/program/libvclplug_gtk680li.so
#21 0xb586db00 in _gtk_marshal_BOOLEAN__BOXED ()
   from /usr/lib/libgtk-x11-2.0.so.0
#22 0xb5d3779b in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#23 0xb5d47b93 in g_signal_chain_from_overridden ()
   from /usr/lib/libgobject-2.0.so.0
#24 0xb5d48e7f in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#25 0xb5d49279 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#26 0xb59815f8 in gtk_widget_get_default_style ()
   from /usr/lib/libgtk-x11-2.0.so.0
#27 0xb5866ef3 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#28 0xb58680f7 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#29 0xb5ebb7ea in _gdk_events_init () from /usr/lib/libgdk-x11-2.0.so.0
#30 0xb5cc3802 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#31 0xb5cc67df in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#32 0xb5cc6d45 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#33 0xb5a94291 in GtkXLib::Yield ()
   from /usr/lib/openoffice/program/libvclplug_gtk680li.so
#34 0xb56a8037 in X11SalInstance::Yield ()
   from /usr/lib/openoffice/program/libvclplug_gen680li.so
#35 0xb7c30f08 in Application::Yield ()
   from /usr/lib/openoffice/program/libvcl680li.so
#36 0xb7da027d in Dialog::Execute ()
   from /usr/lib/openoffice/program/libvcl680li.so
#37 0xaeeed3fb in SfxApplication::InsertDocumentDialog ()
   from /usr/lib/openoffice/program/libsfx680li.so
#38 0xaeee43d8 in SfxApplication::GetInterface ()
   from /usr/lib/openoffice/program/libsfx680li.so
#39 0xaf0b97ca in SfxDispatcher::Execute ()
   from /usr/lib/openoffice/program/libsfx680li.so
#40 0xaf0b9f68 in SfxDispatcher::_Execute ()
   from /usr/lib/openoffice/program/libsfx680li.so
#41 0xaf0b9fd8 in SfxDispatcher::_Execute ()
   from /usr/lib/openoffice/program/libsfx680li.so
#42 0xaf0e9915 in non-virtual thunk to SvxSearchItem::~SvxSearchItem() ()
   from /usr/lib/openoffice/program/libsfx680li.so
#43 0x08824a68 in ?? ()
#44 0x08d51730 in ?? ()
#45 0xbfa759a8 in ?? ()
#46 0x0808f17e in non-virtual thunk to desktop::DesktopContext::getValueByName(rtl::OUString const&) ()
#47 0x08d584d8 in ?? ()
#48 0x08867168 in ?? ()
#49 0xbfa759c8 in ?? ()
#50 0xaf0e98b9 in non-virtual thunk to SvxSearchItem::~SvxSearchItem() ()
   from /usr/lib/openoffice/program/libsfx680li.so
#51 0x08867168 in ?? ()
#52 0x08d51730 in ?? ()
#53 0x08d527f4 in ?? ()
#54 0xb7ef25f0 in ?? () from /usr/lib/openoffice/program/libvcl680li.so
#55 0x08093ba0 in (anonymous namespace)::VectorTraits::g_signature ()
#56 0x08d49f20 in ?? ()
#57 0xbfa75bb8 in ?? ()
#58 0xb7e1b096 in Window::~Window ()

Vincenzo Ciancia (vincenzo-ml) wrote :

The report was incomplete: after clicking on "templates" one has to additionally click on one of the template folders which are presented. This bug is grave, is it possible that nobody uses templates in openoffice on ubuntu?

Vincenzo Ciancia (vincenzo-ml) wrote :

Fixed in feisty.

Changed in openoffice.org:
status: Unconfirmed → Fix Released
Vincenzo Ciancia (vincenzo-ml) wrote :

Reopening, exactly the same odd behaviour in intrepid beta.

Changed in openoffice.org:
status: Fix Released → New
Vincenzo Ciancia (vincenzo-ml) wrote :

Don't know if the above backtrace is still valid, will try to produce a new one.

Chris Cheney (ccheney) on 2008-10-16
Changed in openoffice.org:
status: New → Incomplete
Vincenzo Ciancia (vincenzo-ml) wrote :

This also happens in hardy, must be some dependency missing. I attach the backtrace in hardy.

Changed in openoffice.org:
status: Incomplete → New
Vincenzo Ciancia (vincenzo-ml) wrote :

I found the problem: I had assistive technologies enabled (not that I truly need it, just wanted to see how orca works). This came to my mind after I remembered a similar problem being closed in suse, so it's several years this problem has been there. You may want to prioritise it for the sake of your users that need assistive technologies.

Is there a tag for such problems?

Chris Cheney (ccheney) on 2008-10-18
Changed in openoffice.org:
importance: Undecided → Medium
status: New → Confirmed

When you enable Gnome Assistive Technologies and try to go to "File->New->Templates and Documents" OOo crashes. It doesn't seem to happen with the Sun version so it appears to be an ooo-build issue.

Changed in openoffice.org:
status: Confirmed → Triaged
Changed in openoffice:
status: Unknown → Confirmed
Download full text (4.5 KiB)

I was able to replicate it.

bt:

#0 0x00007faddf090138 in ?? () from /home/rodo/ooo/m9-3-0/program/../basis-link/program/libsvtlx.so
#1 0x00007fadc5232239 in accessibility::AccessibleBrowseBoxBase::AccessibleBrowseBoxBase () from /home/rodo/ooo/m9-3-0/basis3.0/program/libacclx.so
#2 0x00007fadc525d123 in accessibility::AccessibleBrowseBoxCell::AccessibleBrowseBoxCell () from /home/rodo/ooo/m9-3-0/basis3.0/program/libacclx.so
#3 0x00007fadc5238035 in accessibility::AccessibleBrowseBoxTableCell::AccessibleBrowseBoxTableCell ()
   from /home/rodo/ooo/m9-3-0/basis3.0/program/libacclx.so
#4 0x00007fadc526cb66 in accessibility::AccessibleFactory::createAccessibleBrowseBoxTableCell () from /home/rodo/ooo/m9-3-0/basis3.0/program/libacclx.so
#5 0x00007faddf0a3c17 in SvHeaderTabListBox::CreateAccessibleCell () from /home/rodo/ooo/m9-3-0/program/../basis-link/program/libsvtlx.so
#6 0x00007fadc525b6b2 in accessibility::AccessibleTabListBoxTable::ProcessWindowEvent () from /home/rodo/ooo/m9-3-0/basis3.0/program/libacclx.so
#7 0x00007fadc525bbeb in accessibility::AccessibleTabListBoxTable::WindowEventListener () from /home/rodo/ooo/m9-3-0/basis3.0/program/libacclx.so
#8 0x00007fadddb83b6a in VclEventListeners::Call () from /home/rodo/ooo/m9-3-0/program/../basis-link/program/libvcllx.so
#9 0x00007fadddd4a52f in Window::CallEventListeners () from /home/rodo/ooo/m9-3-0/program/../basis-link/program/libvcllx.so
#10 0x00007faddf0ac47f in ?? () from /home/rodo/ooo/m9-3-0/program/../basis-link/program/libsvtlx.so
#11 0x00007faddf0d4be6 in SvTreeListBox::KeyInput () from /home/rodo/ooo/m9-3-0/program/../basis-link/program/libsvtlx.so
#12 0x00007faddf0979f7 in ?? () from /home/rodo/ooo/m9-3-0/program/../basis-link/program/libsvtlx.so
#13 0x00007fadddd63383 in ?? () from /home/rodo/ooo/m9-3-0/program/../basis-link/program/libvcllx.so
#14 0x00007fadddd6503d in ?? () from /home/rodo/ooo/m9-3-0/program/../basis-link/program/libvcllx.so
#15 0x00007fadd5b201a3 in ?? () from /home/rodo/ooo/m9-3-0/basis3.0/program/libvclplug_gtklx.so
#16 0x00007fadd5b20624 in ?? () from /home/rodo/ooo/m9-3-0/basis3.0/program/libvclplug_gtklx.so
#17 0x00007fadd5661998 in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
#18 0x00007fadd898520d in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#19 0x00007fadd899908c in ?? () from /usr/lib64/libgobject-2.0.so.0
#20 0x00007fadd899a392 in g_signal_emit_valist () from /usr/lib64/libgobject-2.0.so.0
#21 0x00007fadd899aa53 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#22 0x00007fadd5776a8e in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
#23 0x00007fadd565a5ed in gtk_propagate_event () from /usr/lib64/libgtk-x11-2.0.so.0
#24 0x00007fadd565b55b in gtk_main_do_event () from /usr/lib64/libgtk-x11-2.0.so.0
#25 0x00007fadd97022ac in ?? () from /usr/lib64/libgdk-x11-2.0.so.0
#26 0x00007fadd84eb93a in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#27 0x00007fadd84ef040 in ?? () from /usr/lib64/libglib-2.0.so.0
#28 0x00007fadd84ef1dc in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#29 0x00007fadd5af38e4 in ?? () from /home/rodo/ooo/m9-3-0/basis3.0/program/libvclplug_gtklx.so
#30 0x00007fadddb7c61e in Applica...

Read more...

Changed in openoffice:
status: Confirmed → In Progress

Thanks a million Vincenzo, I had the same problem (it's fun playing with orca... :P ) but would never have suspected orca to crash my openoffice installation.

AlanQ (alan-q) wrote :

Same problem in Ubuntu Intrepid (8.10):
Ubuntu OpenOffice.org 2.4.1
openoffice.org-core 1:2.4.1-11ubuntu2.1, Thu Nov 20 10:16:29 UTC 2008

The problem in a nutshell:
OpenOffice Writer
File > New > Templates and Documents > Templates > My Templates > Crash.

(OpenOffice Recovery tool says: "Click 'Next' to open the Error Report Tool". But there is no 'Next'.)

Quick fix:
System > Preferences > Assistive Technologies
Un-check 'Enable Assistive Technologies'
Then Log-Out and log back in (or reboot).

Chris Cheney (ccheney) on 2009-01-24
Changed in openoffice.org:
assignee: nobody → ccheney
milestone: none → ubuntu-8.10-beta

Assistive Technologies is off, but OO has crashed ever on Templates since the installation of 8.04. Took out the Ubuntu version and reinstalled it, same problem. Tried Oxygen Office, same problem. These are the installed Templates, not additional/third-party templates. If there are any other ideas, I would love to hear them.

Any progress on this bug?

Changed in openoffice.org (Ubuntu):
assignee: ccheney → nobody
milestone: ubuntu-8.10-beta → none

I am having the same problem - Ubuntu 8.10 and have turned off the assistive technologies.

This seems a serious shortcoming quite beyond me to do anything about other than comment that it should be fixed to preserve OO/Ubuntu credibility.

Not a very helpful remark, I know, but I can't think of anything else to say.

Ciao,

Nigel

Vincenzo Ciancia (vincenzo-ml) wrote :

But can someone please report upstream?

Chris Cheney (ccheney) wrote :

Vincenzo,

It was reported to go-oo (ooo-build) upstream 7 months ago. They haven't been able to track down what is wrong because the issue goes away while debugging.

Chris

Vincenzo Ciancia (vincenzo-ml) wrote :

Thank you Chris. Can the upstream bug be linked to here or is it a closed BTS perhaps?

Chris Cheney (ccheney) wrote :

Vincenzo,

It already is... just look at the top on the page:

https://bugzilla.novell.com/show_bug.cgi?id=440403

This is an ooo-build issue which is why it is linked to the novell bugzilla instead of openoffice.org issue tracker.

Il giorno ven, 15/05/2009 alle 20.55 +0000, Chris Cheney ha scritto:
>
> It already is... just look at the top on the page:
>
> https://bugzilla.novell.com/show_bug.cgi?id=440403

I just didn't know that go-oo was related to novell, sorry for noise. I
thought it was the corresponding bug in Suse.

Chris Cheney (ccheney) on 2009-09-11
summary: [ooo-build] Crash when browsing document templates when Assistive
- Technologies (accessibility) used
+ Technologies (accessibility) used (WARNING **: Invalidate all children
+ called)
zimm (faloz) wrote :

I am having the same problem Ubuntu jaunty 64bit
openoffice.org, Architecture: amd64, Version: 1:3.0.1-9ubuntu3

The 'openoffice.org-gtk' make the probleme. Do the 'openoffice.org-gtk' remove from the system and we hav'nt problem. The Template are go.

apt-cache depends openoffice.org-gtk talk
...
Kollidiert: libgtk2.0-0
Kollidiert: <oooqs-kde>
Kollidiert: <ooqstart-gnome>
...

In the system is the libgtk2.0-0 version 2.16.1-0ubuntu2

Martin (martinmolenaar) wrote :

The pc of my father has got the same problem.

 - 32bit
 - Ubuntu 9.04
 - 1:3.0.1-9ubuntu3

I found that starting a guest-account the templates works fine.

Removing the .openoffice.org and .openoffice.org2 directory (I think the last is an old version and not necessary to remove). It doesn't solve the problem.

Martin (martinmolenaar) wrote :

hello,

Excuse me for the last message. As mentioned in the title of this bug report when the "Assistive Technologies" is enabled this problem occurs. I disabled the "Assistive Technologies" and now the templates of Openoffice.org works fine.

Martin

Vincenzo Ciancia, this issue is unreproducible in LibreOffice. Does this work for you?

lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

Changed in libreoffice (Ubuntu):
status: New → Incomplete

Vincenzo Ciancia, Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 69247
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in openoffice.org (Ubuntu):
importance: Medium → Low
status: Triaged → Incomplete

hi, I had this problem, turned off the accessibility stuff as suggested, (though I usually need this so that's not very convenient)
and it changed to

** (soffice:3221): WARNING **: Invalidate all children called

I have much crashing and freezing and auto save is a bit screwy too.

anyone have any clues as to whats up? Crash seems to centre on moving stuff or adding movements in my non-tech opinion. am in 10.10 with two screens and not enough possessing power

Changed in openoffice.org (Ubuntu):
status: Incomplete → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

Vincenzo Ciancia, your crash report for LibreOffice is missing. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

Now open your file manager, navigate to your /var/crash directory and open the crash report you wish to submit.
If this fails you will have to open a terminal and file your report with 'ubuntu-bug /var/crash/_my_crash_report.crash' where _my_crash_report.crash is the crash you would like to report. If you get an error that you aren't allowed to access this report you will have to file it with 'sudo ubuntu-bug /var/crash/_my_crash_report.crash'.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in libreoffice (Ubuntu):
status: Incomplete → Invalid

I am unable to reproduce the crash with LO-3.5. There were some fixes in this area => closing.

Changed in openoffice:
importance: Unknown → Medium
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.