openoffice.org for edgy-updates

Bug #68396 reported by Matthias Klose on 2006-10-26
20
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

openoffice.org (2.0.4-0ubuntu3) edgy-proposed; urgency=low

  * Disable the Shrink patchset (optimizations only), disabled in
    ooo-build by default. Ubuntu #62432, #65226, #67093.

    -> fixes crashes pasting text to evolution, gaim, and other applications

  * Fix crash in draw/impress on amd64 (taken from FC). Ubuntu #64919.

    -> fixes crash hitting the del key when no object is selected

  * Update cs desktop menu translations from Rosetta.

  * Merge from Debian:
    - fix regcomp installation. Ubuntu #66466.

      -> makes the regcomp program usable

  * Updated catalan GSI file (Jordi Mallach).
  * Updated kurdish GSI file (Erdal Ronahi), do not re-import the
    kurdish translations into Rosetta, which are manually fixed in
    Rosetta.
  * broffice.org: Divert the Ubuntu bitmap files, not the community
    bitmap files (universe only).

    -> the reason for the broffice.org package is not to show the OOo
         bitmaps at all.

  * Extract the language data for Kannado (kn), Tsonga (ts), Swahili (sw).
  * Fix a race condition for parallel builds.

 -- Matthias Klose <email address hidden> Fri, 1 Dec 2006 10:32:55 +0000

Matthias Klose (doko) wrote :

Back out for now:

* Force hinting style to normal (was light). Slightly better results
    on Kubuntu, see #54776.

Matthias Klose (doko) wrote :
Matthias Klose (doko) on 2006-12-06
description: updated
Matthias Klose (doko) on 2006-12-06
description: updated
Matthias Klose (doko) wrote :

debdiff as uploaded to edgy-proposed

Colin Watson (cjwatson) wrote :

Approved and accepted for edgy-proposed. Please now follow the "Test" phase of http://wiki.ubuntu.com/StableReleaseUpdates, starting by contacting Simon Law.

You did not include a reference to this bug number (the SRU bug) in debian/changelog, although I did ask for that on IRC. I'm making an exception this time because I realise that openoffice.org uploads take a long time to prepare, and this has been pending for several weeks now. I've put a reference to this bug in bug 62432 (the first in the changelog) to make it easier to spot. However, please inform Simon of this bug number, and please ensure that the upload to edgy-updates contains a reference to this bug for ease of cross-referencing; otherwise any edgy-updates upload will be rejected. Thanks in advance.

Changed in openoffice.org:
status: Unconfirmed → Fix Committed

Colin Watson schrieb:
> You did not include a reference to this bug number (the SRU bug) in
> debian/changelog, although I did ask for that on IRC.

misunderstanding then. I added the bug number for the amd64 crash report.

Colin Watson (cjwatson) wrote :

On Thu, Dec 07, 2006 at 08:14:30AM +0100, Matthias Klose wrote:
> misunderstanding then. I added the bug number for the amd64 crash report.

Ah, right, sorry for the confusion.

Matthias Klose (doko) wrote :

checked on i386 and amd64 that the packages fix the issues #62432, #64919 (amd64 only), #66466, checked the diversion of the bitmap files for broffice.org.

Eduard Grebe (eduardgrebe) wrote :

I can confirm that the issue reported in #62432 is fixed on powerpc with the packages in edgy-proposed. Not sure if I should be reporting the results of my tests.

Simon Law (sfllaw) wrote :

I tested this patch without finding regressions, but am concerned that it's a big update.

Still, it's good to go into -updates today.

Matthias Klose (doko) wrote :

Not yet uploading to -updates; Colin requested at least two or three confirmations from users for each bug mentioned in the changelog with a bug number before the package can be uploaded to edgy-updates.

Alexander Oltu (sazs) wrote :

Checked package from edgy-updates on i386. Can confirm that #65226 and #67093 are resolved.

François Montel (zerohalo) wrote :

I installed packages from edgy-proposed. I confirm that they fix bug #62432. Danke!

(Packages from ~doko repo also fix the bug.)

pirast (pirast) wrote :

I can confirm that the proposed updates fix bug 62432

sam tygier (samtygier) wrote :

confirm fix of bug 62432 on powerpc

Daniel Moyne (dmoyne) wrote :

no problem with AMD 64 version of OpenOffice : bug fixed.

Hope we get a fix for the black screen the same way.
Thanks.

Matthias Klose (doko) wrote :

openoffice.org (2.0.4-0ubuntu4) edgy-updates; urgency=low

  * Upload to edgy-updates. Ubuntu #68396.
  * Checked on amd64 and i386 that the bugs mentioned in -0ubuntu3 are fixed.
    (Matthias Klose).
  * Tested without finding reqgressions (Simon Law).
  * Confirmed the fix for #62432 or a duplicate report: Eduard Grebe,
    Alexander Oltu, Fran<C3><A7>ois Montel, sam tygier, Martin J<C3><BC>rgens.
  * Confirmed the fix for #64919: Daniel Moyne.

 -- Matthias Klose <email address hidden> Mon, 18 Dec 2006 17:05:12 +0000

Colin Watson (cjwatson) wrote :

Accepted into edgy-updates. Please let the TB know immediately if you hear of any regressions.

Changed in openoffice.org:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers