Impress: Missing UI entry for grow/shrink animation

Bug #651511 reported by hazelsct on 2010-09-29
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
LibreOffice
New
Undecided
Unassigned
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org-impress

The OpenOffice.org Impress UI is missing an animation entry for grow/shrink animation. The effect is there, and is visible in imported PowerPoint presentations, but is not in any of the Animation menus. This has been a known problem for at least 4.5 years, e.g.: http://www.oooforum.org/forum/viewtopic.phtml?t=33998

The following patch (vs. Lucid) fixes this by putting the entry into the effects menu under Emphasis -> Basic:

--- /usr/lib/openoffice/basis3.2/share/registry/data/org/openoffice/Office/UI/Effects.xcu~ 2010-06-02 22:40:03.000000000 -0400
+++ /usr/lib/openoffice/basis3.2/share/registry/data/org/openoffice/Office/UI/Effects.xcu 2010-09-29 16:29:59.000000000 -0400
@@ -1699,7 +1699,7 @@
           <value xml:lang="en-US">Basic</value>
         </prop>
         <prop oor:name="Effects" oor:type="oor:string-list">
- <value oor:separator=";">ooo-emphasis-fill-color;ooo-emphasis-font;ooo-emphasis-font-color;ooo-emphasis-font-size;ooo-emphasis-font-style;ooo-emphasis-line-color;ooo-emphasis-spin;ooo-emphasis-transparency</value>
+ <value oor:separator=";">ooo-emphasis-fill-color;ooo-emphasis-font;ooo-emphasis-font-color;ooo-emphasis-font-size;ooo-emphasis-font-style;ooo-emphasis-grow-and-shrink;ooo-emphasis-line-color;ooo-emphasis-spin;ooo-emphasis-transparency</value>
         </prop>
       </node>
       <node oor:name="special" oor:op="replace">

It looks like somebody just forgot to include this entry in one of these emphasis lists.

Even with this patch, the "shrink" option doesn't work: when I specify a value smaller than 100%, instead of shrinking, it grows by that amount. For example, 25% makes it grow 25%, not shrink to 25% of its original size. It does not accept negative values, but truncates them at 0%.

However, shrinking elements imported from PowerPoint work just fine... I'll see if I can patch that another day.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: openoffice.org-impress 1:3.2.0-7ubuntu4.1 [modified: usr/lib/openoffice/basis3.2/share/registry/data/org/openoffice/Office/UI/Effects.xcu]
ProcVersionSignature: Ubuntu 2.6.32-24.43-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic x86_64
Architecture: amd64
Date: Wed Sep 29 16:34:13 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/tcsh
SourcePackage: openoffice.org

hazelsct (hazelsct) wrote :
Robert Roth (evfool) on 2011-02-10
Changed in openoffice.org (Ubuntu):
status: New → Confirmed
Changed in openoffice.org (Ubuntu):
status: Confirmed → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed

This release of Ubuntu is no longer receiving maintenance updates. If this is still an issue on a maintained version of Ubuntu please let us know.

Changed in libreoffice (Ubuntu):
status: Confirmed → Incomplete
no longer affects: libreoffice (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers