Ubuntu

URE: Component registries might be corrupted

Reported by Michael Nelson on 2010-03-25
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
openoffice.org (Ubuntu)
High
Chris Cheney
Lucid
High
Chris Cheney

Bug Description

Binary package hint: openoffice.org

This may actually be a valid warning, but I'm not sure that it's the kind of message Ubuntu users should see during the upgrade.

Screenshot to come.

ProblemType: Bug
Architecture: i386
Date: Thu Mar 25 11:58:03 2010
DistroRelease: Ubuntu 10.04
Package: ure 1.6.0+OOo3.2.0-4ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
SourcePackage: openoffice.org
Uname: Linux 2.6.32-17-generic i686

Michael Nelson (michael.nelson) wrote :
Chris Cheney (ccheney) wrote :

It is a valid message. I guess we could just let users find out the hard way?

James Troup (elmo) wrote :

Chris, the content of the message may be valid but in addition to being completely indecipherable to the average user, it's also completely unclear what if anything I should do based on the warning.

Changed in openoffice.org (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) wrote :

The maintainer script indicates that this is forcibly shown to all OOo users on upgrade. I think this needs to be dropped in severity and, e.g., moved to the release notes instead.

Changed in openoffice.org (Ubuntu Lucid):
importance: Undecided → Medium
importance: Medium → High
Michael Vogt (mvo) wrote :

Targeting because every ubuntu desktop user will see this message on upgrade to lucid if we do not fix it.

Changed in openoffice.org (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-2
Chris Cheney (ccheney) wrote :

Yea, I talked with Michael about this yesterday and mentioned I thought we could drop it to the release notes.

Michael Vogt (mvo) wrote :

I looked into this a little bit, the bug in debian releated to this are:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=566832
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=566829
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=566189

The error thrown is 'com::sun::star::deployment::DeploymentException'. Rene mentioned that
the error may have been only in 1:3.1.1-14 version. However that is not fully certain. We never
shiped -14. So we may be safe. A search in launchpad did only find a single com::sun::star::deployment::DeploymentException' hit (and only on armel). I think we need some
further confirmation and research that we are not affected but it does not look too bad.

If we are affected the fix appears to be very difficult as it may affect files in:
• /var/spool/openoffice
• /var/lib/openoffice/basis3.2/program/services.rdb
• ~/.openffice.org/3
and there is no way of detecting if a rdb file is broken other than that OOo crashes.

Chris Cheney (ccheney) on 2010-03-31
Changed in openoffice.org (Ubuntu Lucid):
assignee: nobody → Chris Cheney (ccheney)
Jarige (jarikvh) wrote :

Also happened when manually upgrading to OpenOffice 3.2 by ppa from Karmic.
But user had to do this himself.

Steve Langasek (vorlon) wrote :

The note being dropped from the package is:

  Component registries might be corrupted

  You are upgrading from a version which might have corrupted service/component registry files (*.rdb). Especially /var/lib/openoffice/basis3.1/program/services.rdb and the rdbs below /var/spool/openoffice/uno_packages/cache for installed extensions.

  If you experience problems with the component manager or segmentation faults in either unopkg or OOo which involve store, please check those (and eventually cleanly reinstall the packages and/or use a clean user profile)

Changed in ubuntu-release-notes:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openoffice.org - 1:3.2.0-4ubuntu3

---------------
openoffice.org (1:3.2.0-4ubuntu3) lucid; urgency=low

  * 'URE: Component registries might be corrupted' debconf warning converted
    to a release note item. Closes LP: #546797
  * Update splash image, aboutbox image and copyright for Oracle branding.
    Closes LP: #535041
 -- Chris Cheney <email address hidden> Thu, 01 Apr 2010 15:30:00 -0500

Changed in openoffice.org (Ubuntu Lucid):
status: Confirmed → Fix Released
Steve Langasek (vorlon) wrote :

Documented at <https://wiki.ubuntu.com/LucidLynx/ReleaseNotes#OpenOffice.org%20registry%20may%20be%20corrupted%20on%20upgrade%20from%20version%203.1.1-14>:

Users who had installed pre-release versions of Ubuntu 9.10 may have corrupted OpenOffice.org service or component registry files on their system as a result of a bug in version 1:3.1.1-14 of the OpenOffice.org packages. If you experience segfaults in either unopkg or OpenOffice.org after upgrade, you may need to remove and regenerate the registry files in /var/lib/openoffice/basis3.2/program/ and /var/spool/openoffice/uno_packages/cache. (546797)

Changed in ubuntu-release-notes:
status: Confirmed → Fix Released

I understand this is solved. But please, how an "average user" is supposed to know *how* to remove and regenerate the registry files? WHich files? What I have to rm, exactly? And how do I regenerate them?
What about posting a couple command line to do the trick?
Thanks...

Jesse Cohn (jessecohn) wrote :

May I second Romano's request for more specific instructions? I plead noobdom.

Chris Cheney (ccheney) wrote :

The remove part is fairly obvious to regenerate the files I believe you need to reinstall the extensions. For packaged extensions you can do this via apt-get install --reinstall (package name) for manually installed extensions reinstall them via the extension manager in OpenOffice.org

Chris Cheney (ccheney) wrote :

A full reinstall of the OpenOffice.org related packages probably wouldn't hurt either and may be easier to do than the above.

Jesse Cohn (jessecohn) wrote :

I removed and reinstalled all my OpenOffice packages (using the Ubuntu Software Center), but this doesn't seem to have solved my problems with the OpenOffice Writer (which now not only crashes when I try to save a file to a different destination via "Save As" but also when I try to _open_ some large files). Sigh!

Chris Cheney (ccheney) wrote :

Its very unlikely you are experiencing the bug referenced by the release note. There are numerous or causes of crashes besides just the corrupt registry database and if a reinstall didn't fix it, it is most likely not the registry at fault.

Jan Greeff (jan-verslank) wrote :

The vague "removal is fairly obvious" to a specific question about what files need to be removed and re-installed does not help the uninitiated, like myself.

When I upgraded from Ubuntu 9.10 to 10.04 I received an error message which stated that the upgrade could only be done partially. I received the following message:

The GRUB boot loader was previously installed to a disk that is no longer present, or whose normally unique identifier has changed for some reason.

I have no idea where to go from here.

Jan Greeff (jan-verslank) wrote :

I keep on getting this result when I try to do anything in the package manager, it just goes round in circles:

jan@jan-desktop:~$ sudo apt-get install dselect
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

When I try to run sudo apt-get install dselect it goes back to where I started.

Jan Greeff (jan-verslank) wrote :

If I try to remove any software via the software centre, I get this message: Previous installation hasn't been completed

Did you try "sudo dpgk --configure -a" as suggested in the error message.?

Steve Langasek (vorlon) wrote :

Jan,

The problems you describe also have nothing to do with this bug. You should file a bug report on the grub2 package using the command 'ubuntu-bug grub2', or consult the resources listed at http://www.ubuntu.com/support for support.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.