Ubuntu

I can't save a spreadsheet in a dbase format

Reported by Esdras Andrade on 2010-01-02
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenOffice
Invalid
Medium
libreoffice (Ubuntu)
Undecided
Unassigned
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org

I can't save a spreadsheet in dbase (*.dbf) format.

ProblemType: Bug
Architecture: i386
Date: Sat Jan 2 20:29:01 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: openoffice.org-core 1:3.1.1-5ubuntu1
ProcEnviron:
 LANGUAGE=pt_BR.UTF-8
 PATH=(custom, no user)
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: openoffice.org
Uname: Linux 2.6.31-16-generic i686
XsessionErrors:
 (gnome-settings-daemon:1618): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:1658): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:1650): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

Esdras Andrade (ezrandrade) wrote :
Dave Walker (dogatemycomputer) wrote :

Esdras:

I am running Kubuntu 9.10 and I can recreate the problem by opening an empty spreadsheet, clicking FILE then SAVE AS, giving the spreadsheet a name, choose DBase format from the pulldown and clicking SAVE.

What error message do you get? Can you attach a screenshot?

Hi Dave,

This email was attached a screenshot of the warning when I try to save the
file .dbf.
Thanks for the help

2010/1/2 Dave Walker <email address hidden>

> Esdras:
>
> I am running Kubuntu 9.10 and I can recreate the problem by opening an
> empty spreadsheet, clicking FILE then SAVE AS, giving the spreadsheet a
> name, choose DBase format from the pulldown and clicking SAVE.
>
> What error message do you get? Can you attach a screenshot?
>
> --
> I can't save a spreadsheet in a dbase format
> https://bugs.launchpad.net/bugs/502462
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Esdras Andrade.
http://geoparalinux.wordpress.com

Dave Walker (dogatemycomputer) wrote :

Esdras:

This is a different error than what I am getting. Can you attach a copy of the spreadsheet you are trying to save that is generating this error?

Esdras Andrade (ezrandrade) wrote :
  • teste1.ods Edit (15.2 KiB, application/vnd.oasis.opendocument.spreadsheet; name="teste1.ods")

Ok, Dave.
The spreadsheet file was attached.
Again, thank you. And I put myself available for any questions. ok?

2010/1/3 Dave Walker <email address hidden>

> Esdras:
>
> This is a different error than what I am getting. Can you attach a copy
> of the spreadsheet you are trying to save that is generating this error?
>
> --
> I can't save a spreadsheet in a dbase format
> https://bugs.launchpad.net/bugs/502462
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Esdras Andrade.
http://geoparalinux.wordpress.com

Changed in openoffice.org (Ubuntu):
status: New → Confirmed
Dave Walker (dogatemycomputer) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:

https://bugzilla.novell.com/show_bug.cgi?id=567920

Dave Walker (dogatemycomputer) wrote :

I also wanted to note in this bug report that I could not reproduce this bug using the Sun DEBS with Debian proper. This appears to be a Novell specific bug or a Ubuntu specific bug.

Dave Walker (dogatemycomputer) wrote :

The Novell guys confirmed this was not a problem on 3.11 or 3.2 so this must be a Ubuntu specific bug OR they are doing something different than what is described in the steps required to reproduce the problem.

alice (alice) wrote :

I have the same problem on ubuntu 9.10. Is there any solution?

Esdras Andrade (ezrandrade) wrote :

Hi Alice,

no solution yet. I wrote to the team of ubuntu and no response.

2010/2/1 alice <email address hidden>

> I have the same problem on ubuntu 9.10. Is there any solution?
>
> --
> I can't save a spreadsheet in a dbase format
> https://bugs.launchpad.net/bugs/502462
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Esdras Andrade.
http://geoparalinux.wordpress.com

Esdras Andrade (ezrandrade) wrote :

I found the solution. The problem occurs because the OpenOffice Base is not installed. To solve the problem, simply install it. Thanks to all who cooperate.

alice (alice) wrote :

great! it works here too.
thanks a lot.

Yes, the same for me!

Chris Cheney (ccheney) on 2010-03-01
Changed in openoffice.org (Ubuntu):
status: Confirmed → Invalid
Changed in openoffice:
importance: Unknown → Medium
status: Unknown → Invalid
alice (alice) wrote :

this bug is confirmed and not fixed yet. why do you set it "invalid"?

Changed in openoffice.org (Ubuntu):
status: Invalid → Confirmed

Esdras Andrade, this issue is unreproducible in LibreOffice Calc via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/502462/+attachment/1087357/+files/teste1.ods && unoconv --listener && unoconv -f dbf teste1.ods

does this work for you?

lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

apt-cache policy libreoffice-calc
libreoffice-calc:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

apt-cache policy unoconv
unoconv:
  Installed: 0.3-6
  Candidate: 0.3-6
  Version table:
 *** 0.3-6 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status

Changed in libreoffice (Ubuntu):
status: New → Incomplete
Changed in openoffice.org (Ubuntu):
status: Confirmed → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

closing as invalid (expired) because of missing reply.

Changed in libreoffice (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.