Writer does not print capital Й with msttcorefonts

Bug #449255 reported by Maxim N. Kostrikin on 2009-10-12
This bug affects 21 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Declined for Jaunty by Chris Cheney
Declined for Karmic by Chris Cheney
Declined for Lucid by Chris Cheney
openoffice.org (Ubuntu)
Declined for Jaunty by Chris Cheney
Declined for Karmic by Chris Cheney
Declined for Lucid by Chris Cheney

Bug Description

Binary package hint: cups


  cups installed from ubuntu repository does not print capital Й while installed ttf-mscore fonts (document should you the font).

  The issue leave if cups reinstalled from source used from cups.org
  Test file to prove the issue will be attached.
  Without ttf-mscore fonts installed system substitude similar fonts and all symbols prints fine.

  This issue presents cince 8.04 release, hope at 9.10 release it will changed

Thank you.
For note: Й - is cyrrilic symbol from russian lang.

Maxim N. Kostrikin (kmax) wrote :

Printing to PDF printer should show the issue as well.

tags: added: ttf-mscorefonts
Saha (smirta) wrote :

I confirm this bug.
And I should notice that this is NOT bug of OpenOffice. Here I have attached the ps-file with Russian letters Й.
The problem is solving by installing CUPS from official site, BUT only version 1.3.11 (and, may be, earlier).
I had a problems with installing CUPS version 1.4.1 (my printer didn't recognized).

Confirm this bug.

Vlad (badfiles) wrote :

I also confirm in 9.10 beta with cups 1.4.1

isp99 (isp99) wrote :

Confirm. 9.04.

Nolgen (nolgen) wrote :

Confirm for Ubuntu 8.10 and 9.04.With ttf-mscorefonts and native MS fonts Arial, Times New Roman and Courier New.
This bug usually solved after install cups downloaded from www.cups.org (sources).
But the same should not be. Wants to have everything worked out of the box.
p.s. U+0419 CYRILLIC CAPITAL LETTER SHORT I in UTF-8: 0xD0 0x99 UTF-16: 0x0419

xenar (vent-nu) wrote :

Confirm . 9.04

Alex (alex-kostjukov) wrote :

Confirm the problem for Jaunty. I tried cups 1.3.9-17ubuntu3.2 from jaunty-updates, as well as compiled from the sources from cups.org 1.3.11 and 1.4.1 that is bundled with karmic. Problem remains in all the cases with only difference that in later two versions print space instead of U+0419, while 1.3.9 corrupts text near by this letter. In all the cases:
- when test document is exported to PDF first, then it prints correctly. It is only way to get document printed.
- when test document is printed to cups-pdf problems remains same.
- when test document is saved to postscript file, postscript viewers I have installed both evince and okular show document correctly, but printout is wrong with the exactly same problem.

I noted that in then postscript file (where all used glyphs should be embedded for cups) there is no U+0419 glyph for fonts affected.
I think, when postscript viewer shows the file it just takes omitted glyph from system fonts. When cups is printing it omit letter with version 1.3.9 or replaces it space in 1.3.11 and 1.4.1.

In the sample attached first line is in Arial and the U+0419 the second letter in the third word. Arial glyphs for first four words of the line are given in the postscript file in lines 14051 - 14074. U+0419 have encoding 14 that is missed here.
Same phrase in another msttcorefonts's font Comic Sans MS is at line 7 of the odt file. It prints via either cups correctly. Comic's glyphs are defined in lines 16944 - 16967, at line 16950 there is definition for letter with encoding 14, for U+0419.

ArcFi (arcfi) wrote :


Do not print letter "Й".
Text font: Times New Roman


ssfrolov (ssf) wrote :

I also confirm in 9.10 amd64 final with cups 1.4.1

Nolgen (nolgen) wrote :

Ubuntu 9.10 i386
Do not print letter "Й" only from OpenOffice.org. From Abiword printed normally.
Reinstalling cups 1.4.1 from source does not help. Reinstalling from source cups 1.3.11.

Ivanov1965 (post-2) wrote :


Do not print letter "Й" in OpenOffice 3.1 in documents, formated with text font "Times New Roman".

Ubuntu 9.10

Ivanov1965 (post-2) wrote :


It is very important for Russian users, because they can not print in Open Office documents in MS Winword format, which is the de facto standard for government agencies and corporations in Russia

Alex (alex-kostjukov) wrote :

Как-то оно совсем без сдвигов. Я попытался изложить сей баг на сайте ООо. Дополняйте, может авторы сподобятся его вылечить.

There is no progress there. I tried to post the bug on OOo site. Issue #106833, http://gsl.openoffice.org/issues/show_bug.cgi?id=106833. Comments are welcome.

KeenEars (fl-blade) wrote :

Issue in Kubuntu 9.10 final too. Letter Й in Times New and б in Arial, in OO.o 3.1.1. Can someone try to do a cups -1.4.2.deb file?

Alex (alex-kostjukov) wrote :

It was found a way to make it working. Both cases, “Short I”, U+0419 in mscorefonts loaded Arial, Courier New, Times New Roman and “Be”, U+0431 in DejaVu Sans.
If the freaky OOo postscript output will be passed through ghostscript distiller first, then fed into further cups processing chain, out of some kind of fright, it prints out correct.
I used few lines script oo3-pstops placed into /usr/lib/cups/filter and added one line to each of oopstops.types and oopstops.convs in /etc/cups. Then cups was restarted by invoke-rc.d cups restart. All this setup should be done as root, of cause.
Attachment contains script mentionied and final versions (after lines added) of oopstops.* configuration files.

Ivanov1965 (post-2) wrote :

Compiling cups -1.4.2.deb (1.4.1 too) from sources not helped in Ubuntu 9.10. But install cups-1.3.11 (configure/make/make install) eliminated the problem.

Russel (russel-kirovnet) wrote :

Confirm. Do not print "Й" with CUPS-1.4.2 (compiling from sources) in Ubuntu 9.10.

ubuntu 9.10x64
CUPS 1.4.1
HP LaserJet 1020 Foomatic/foo2zjs.c,v 1.84 2009/03/07 21:46:43

Alex (alex-kostjukov) wrote :

To: Dmitry Kuznetsov (easy)

Try method form post #16 above. It just works on all three ubuntu machines we are using

Saha (smirta) wrote :

To Alex
Would you be so kind to put your decision of the problem here:
or, may be, here but in Russian, because I couldn't understand quite clear what is the root of the problem. As I understand, this is a bug of OO?

Stas Solovey (whats-up) wrote :

I confirm this bug.

utilitytrack (utilitytrack) wrote :

I confirm this problem. Missing letters "Й" (U+0419) when printing with fonts: Times New Roman, Arial, Courier New (all from packet ttf-mscorefonts-installer v3.0) It is really important for my and all users who spoken on russian, ukrainian, belarussian, bulgarian and others languages of East Europe.


Debian GNU/Linux 5.0 (2.6.30-2-686)
OpenOffice.org 3.1.1
CUPS 1.4.2 (compiled from source)

Canon PIXMA MP250 All-in-one with official drivers cnijfilter-mp250series and cnijfilter-common

Ivanov1965 (post-2) wrote :

>To Saha

I think this is a bug program CUPS, but not Open Office, since the replacement of CUPS on an earlier version removes the problem.

Marat-Kazan (linux-kazan) wrote :

Confirm . 9.10
CUPS 1.4.1
HP LaserJet M1522nf MFP Foomatic/Postscript

Andrey Voronov (voronov84) wrote :

Confirm . 9.10
cups 1.4.1-5ubuntu2.1
Samsung ML-2015

Alex (alex-kostjukov) wrote :

Cyrillic capital Short I (U+0419), in fonts Arial, Courier New, and Times New Roman, as well as Cyrillic small letter Be (U+0431) in DejaVu Sans and Cyrillic small letter Ef (U+0444) in Antiqua are sooner being losing during pdf-to-postscript conversion in the CUPS pipeline.
This conversion is set up with the package install scripts to be performed by /usr/lib/cups/filter/cpdftocps script. This script uses /usr/lib/cups/filter/pdftops filter which actually use /usr/bin/pdftops poppler front end.

Modeling CUPS pipeline conversions step by step starting with OOo generated postscript file ShortI.ps (with only letter capital Short I in Arial), converting it to PDF using ps2pdf13, and finally converting it back to postscript using /usr/bin/pdftops gives result file ShortI-pdftops.ps that seems to have no Short I included.

Considering explanations from http://bugs.ghostscript.com/show_bug.cgi?id=690935 /usr/bin/pdftops rather not render so called “.notdef” glyphs that are required to be rendered in order to get letters in subject showed/printed.

If the pdf-to-postscript conversion will be performed using ghostscript with RENDERTTNOTDEF option, the result (ShortI-gsps.ps) contain the letters and can be printed successfully.

/usr/lib/cups/filter/pdftops filter is introduced on Jaunty with pdftops-cups-1.4.dpatch, and is contained in cups 1.4 originally. It seems that if either pdftops will be called from the filter somehow to render “.notdef” or conditional compilation in pdftops filter will be switched to using ghostscript and RENDERTTNOTDEF option included, the letters in subject will pass pipeline successfully.

Alex (alex-kostjukov) wrote :
Alex (alex-kostjukov) wrote :
sergeyfromminsk (shu-mail) wrote :

Confirm. 9.04.

It is possible that this problem is caused by the dame OOo bug as bug 376953. Bug 376953 is already fixed. Please check this bug with the appropriate OOo version.

Arkadiy (diakas) wrote :

I have this bug in Ubuntu64 9.04 symbol cyrillic capital Short I (U+0419) - "Й", in fonts Arial, Courier New, and Times New Roman in OO3.1.1 not printing :( , but in MSO2003 in WINE is printing OK!

caskad (caskad) on 2009-12-23
Changed in cups (Ubuntu):
assignee: nobody → caskad (caskad)
assignee: caskad (caskad) → nobody
assignee: nobody → caskad (caskad)
KeenEars (fl-blade) wrote :

Well, this bug seems to be gone away from me, probably with some update. My CUPS is 1.4.1-5ubuntu2.1. Printing with Postscript on HP 1320 and with PCL3 on HP1022n

KeenEars (fl-blade) wrote :

No It isn`t gone, sorry. It still happens, but now I got letters missing, not a space char instead of them.

Saha (smirta) wrote :

Please try OpenOffice 3.2, this bug should be fixed there.
For more information see http://www.openoffice.org/issues/show_bug.cgi?id=106833

Moving to OpenOffice.org, as the bug got fixed there.

affects: cups (Ubuntu) → openoffice.org (Ubuntu)
Changed in openoffice.org (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
summary: - cups with ttf-mscorefonts does not print capital Й
+ OpenOffice.org does not print capital Й with msttcorefonts

9.10 only has OpenOffice.org 3.1, while Lucid has 3.2, where the bug seems to be fixed. Could you confirm that's the case? Thanks!

Changed in openoffice.org (Ubuntu):
status: Triaged → Incomplete
Chris Cheney (ccheney) on 2010-05-17
Changed in openoffice.org (Ubuntu):
assignee: caskad (caskad) → nobody
status: Incomplete → New
status: New → Incomplete
Changed in openoffice.org (Ubuntu):
assignee: nobody → Bogdan Derevenets (bodya-dnepr)
assignee: Bogdan Derevenets (bodya-dnepr) → nobody

Maxim N. Kostrikin, this issue is unreproducible in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/449255/+attachment/812873/+files/test%D0%99.odt && mv test?%99.odt example.odt && unoconv --listener && unoconv -f pdf example.odt && acroread example.pdf

Does this work for you?

lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

apt-cache policy libreoffice-writer
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

apt-cache policy unoconv
  Installed: 0.3-6
  Candidate: 0.3-6
  Version table:
 *** 0.3-6 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy acroread
  Installed: 9.4.2-0natty1
  Candidate: 9.4.2-0natty1
  Version table:
 *** 9.4.2-0natty1 0
        500 http://archive.canonical.com/ubuntu/ natty/partner i386 Packages
        100 /var/lib/dpkg/status

Changed in libreoffice (Ubuntu):
status: New → Incomplete
summary: - OpenOffice.org does not print capital Й with msttcorefonts
+ does not print capital Й with msttcorefonts
summary: - does not print capital Й with msttcorefonts
+ Writer does not print capital Й with msttcorefonts
Changed in openoffice.org (Ubuntu):
importance: Medium → Low
Changed in libreoffice (Ubuntu):
importance: Undecided → Low
Changed in openoffice.org (Ubuntu):
status: Incomplete → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

incomplete, not reproducible as per comment 39, no further info => closing

Changed in libreoffice (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.