OO.o GTK support does not use current GTK icon set

Bug #42061 reported by Jacob D'Agostino
22
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Wishlist
Munchkinguy
Declined for Feisty by Matthias Klose

Bug Description

OpenOffice, with the GTK plugin installed, does not use the current GTK icon set for its toolbars, menus, etc, instead using the GNOME defaults. Since Human is moving away from the GNOME default set, this means that on a fresh install, OpenOffice does not fit in with the rest of the desktop apps, making this somewhat important.

Revision history for this message
Matthias Klose (doko) wrote :

Please install the -gnome package; the -gtk package was split out on request from the Xubuntu team. I'll add an recommendation of the -gnome package to the -gtk package.

Revision history for this message
Jacob D'Agostino (jdagost1) wrote :

I have the -gnome package installed. It does not use the icon set that all my other programs have selected, instead using the default GNOME icon set (which, I might add, is no longer default in Ubuntu, with the new Human icons).

Revision history for this message
Jani Monoses (jani) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

unsubscribe xubuntu-team
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFEjs/hVApuG8WqIwERAiRJAJ9TD4be4u2ijoiYtolq5UgNWvYXfgCfVInS
Bbf+hhxsfdH2BT7gKBbE8nA=
=1n0F
-----END PGP SIGNATURE-----

Revision history for this message
Jani Monoses (jani) wrote : and now indent the command

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 unsubscribe xubuntu-team
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFEjtSJVApuG8WqIwERApDOAJ9X8zh/H5uoW5Lm6bhedOgQWICBOQCgrj9S
dyz+navGxqHDURo4kIvC80s=
=vGek
-----END PGP SIGNATURE-----

Changed in openoffice.org:
status: Unconfirmed → Confirmed
Revision history for this message
Séverin Lemaignan (skadge) wrote :

It would be nice if OpenOffice in Ubuntu could follow the Tango icon set...

Revision history for this message
Martin Kretzschmar (martink) wrote : Re: [Bug 42061] Re: OO.o GTK support does not use current GTK icon set

Novell is working on tango icons for OOo.

Revision history for this message
Munchkinguy (10068660) wrote :

We can start working on this now. I have uploaded the OpenOffice icon folder along with this post. All we have to to is replace the icons. I've started a few already. Most of the replaceable icons are in the "res" folder. Don't replace the "High Contrast" icons.

You can get the icons at http://daniel.holba.ch/ubuntu/ic/

Revision history for this message
Daniel Holbach (dholbach) wrote :

It'd make more sense if OpenOffice used GTK Icon Theme lookup, else you will end up updating the Icons tarball whenver there is a change in Human/Tango/... but that's probably not terribly easy to do.

Revision history for this message
Munchkinguy (10068660) wrote :

But somewhat outdated Human icons are better than severely outdated Industrial icons.

Revision history for this message
Daniel Holbach (dholbach) wrote :

I disagree. What if the user uses Tango or Tangerine or Gartoon or the GNOME icon theme? Do you want them to use Human anyway? If OOo used icon theme lookup it would fit in whatever look you're having. Apart from that, it'd cost a big amount of time to get the icons together in a manual way.

Revision history for this message
Munchkinguy (10068660) wrote :

I agree that it's better to use the icon theme lookup, but in the meantime, there is an option to pick different icon themes in OpenOffice, so someone using Tango or Tangerine could just pick it that way.

Yes, I realize that it would be terribly time-consuming, but this could be some thing that people could download optionally if they want to make their OpenOffice prettier.

Revision history for this message
Munchkinguy (10068660) wrote :

On the other hand, Daniel, it would be better for the Ubuntu OpenOffice package to come with Human icons, because then it would match at least one Ubuntu icon theme (and the default one too). The Industrial icon theme no longer ships with Ubuntu, and the default GNOME theme is starting to be Tangoized.

I have emailed Mr. Müller-Prove at Sun to encourage him to incorporate the GTK Icon Theme lookup into OpenOffice. You may email him via: mmp at openoffice dot org

Revision history for this message
Munchkinguy (10068660) wrote :

I've created a specification request for this bug. It is called openoffice-human-icons. If anyone wants to help out, please do.

Munchkinguy (10068660)
Changed in openoffice.org:
assignee: nobody → 10068660
Revision history for this message
Munchkinguy (10068660) wrote :

Here is the first version of the new icon file. I took pre-existing Tango icons (many from Jakub Steiner) and replaced the old ones. Then, I started going through and replacing as many of those Tango icons with icons from the Ubuntu Human theme.

If anyone would like to contribute, please do so, but please tell me so that I don't end up doing work that someone else is already doing.

Revision history for this message
Munchkinguy (10068660) wrote :

For any doubters, here is an example of how lovely tango icons look in OpenOffice.

Revision history for this message
Munchkinguy (10068660) wrote :
Revision history for this message
Oumar Aziz OUATTARA (wattazoum) wrote :

Thank you for that work on Tango icon set.

Default Industrial icon set was so ugly :( . I really wonder why we keep it :/

Revision history for this message
Munchkinguy (10068660) wrote :
Revision history for this message
Matthias Klose (doko) wrote :

- where do these icons come from (in the patch)?
- copyright and license are missing

Changed in openoffice.org:
status: Confirmed → Needs Info
Revision history for this message
Oumar Aziz OUATTARA (wattazoum) wrote :

cool !!! seems like someone heard my prayers :) .

Revision history for this message
Oumar Aziz OUATTARA (wattazoum) wrote :

informations on the set of icons can be found here :
http://ubuntuforums.org/showthread.php?p=2168119

Revision history for this message
Munchkinguy (10068660) wrote :
Revision history for this message
Munchkinguy (10068660) wrote :

Matthias Klose:

There is extensive copyright information within the zip file. Just unzip and enjoy.

Revision history for this message
Matthias Klose (doko) wrote :

> There is extensive copyright information within the zip file. Just unzip and enjoy.

Unfortunately not; are you involved in this release? Is there a ChangeLog which icons were modified? Is this work proposed to upstream? If the copyright questions are answered, but if this is not going upstream, I can consider it for the ubuntu package as an option, if you send patches to introduce the icons as an optional icon set.

Revision history for this message
Matthias Klose (doko) wrote :
Revision history for this message
Matthias Klose (doko) wrote :

the 0.3.2 file is not up to date, please clean up the diffs seen at
http://people.ubuntu.com/~doko/ooicons/index_diffs.html

all icons can be seen at http://people.ubuntu.com/~doko/ooicons/

Revision history for this message
Matthias Klose (doko) wrote :

Munchkinguy: your email address is invalid.

Revision history for this message
Matthias Klose (doko) wrote :

Munchkinguy: If you do want to update your changes, please base your work on
http://people.ubuntu.com/~doko/ooicons/images_tango.tar.gz

A list of the different sources for the icons would be helpful. It's essential for us to know the license and copyright for these changes icons.

Revision history for this message
Munchkinguy (10068660) wrote :

Matthias Klose: All of the websites you have pointed me towards seem to not exist. Also, I have updated my email address so that we converse more easily.

As for the copyright information, I have not made any changes to the changelog :(. However, I have listed the copyright owners in the Readme file.

Revision history for this message
Munchkinguy (10068660) wrote :

... and yes, I am "involved in this release"

Revision history for this message
Matthias Klose (doko) wrote :

Munchkinguy schrieb:
> Matthias Klose: All of the websites you have pointed me towards seem to
> not exist. Also, I have updated my email address so that we converse
> more easily.

the site should be up again.

  - http://people.ubuntu.com/~doko/ooicons/

your current set of icons diverges too much:

  - http://people.ubuntu.com/~doko/ooicons/diff_tango_human.html

that should be most interesting for you:

  - http://people.ubuntu.com/~doko/ooicons/diff_tango_human22.html

what would help me most is a tarball/zipfile with only the icons you add
(and maybe even split those by the origin of the icons, one zip with
icons from source A, and so on; might be easier for tracking).

> As for the copyright information, I have not made any changes to the
> changelog :(. However, I have listed the copyright owners in the Readme
> file.

it would be better to get this right.

Revision history for this message
Munchkinguy (10068660) wrote :

Alright. What about icons (from the existing set) that I made changes to?
Also, this will be a lot of different zip files. Where do I upload them all
to. Should I just email them all to you?

Revision history for this message
Munchkinguy (10068660) wrote :
Revision history for this message
Oumar Aziz OUATTARA (wattazoum) wrote :

Very nice! And even the copyrights inside are very verbose and seem complete .

Will it be possible to add it now on OO.o ? :)

Revision history for this message
Matthias Klose (doko) wrote :

closing the report; the current packages in feisty include the tango upstream icons; please submit new reports for additional icons, don't send the complete zip file each time.

Changed in openoffice.org:
status: Needs Info → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers